Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

IOS 14.5 requires update

mSecure has to be updated in order to work with IOS 14.5. SO do NOT install 14.5 as long as the app. is not updated. If it is not fixed  within a few days I will stop using this app. It  is too essential and should work all the time.


16 people have this problem

What problems are you getting? It seems to work OK for me.

Andy - a new iOS version was released by Apple yesterday, iOS version 14.5


mSecure will now not launch.


It says this when you try to launch the app: "mSecure needs to be updated. The developer of this app needs to update it to work with this version of iOS."


(I had to create a new forums account because I cannot access any of my passwords anymore.)

Weird, I just replied but it never showed up. Here I go again:


Yesterday, April 26 2021, Apple released a new iOS version 14.5. mSecure worked fine until yesterday.


mSecure now will not launch. You get an error popup the moment you try to tap on the app icon.


The message it gives is:

"'mSecure' Needs to Be Updated. The developer of this app needs to update it to work with this version of iOS."

I have the same issue. Using mSecure v4 and no longer working since upgrading to iOS 14.5. The error message says: mSecure needs to be updated The developer of this app needs to update it to work with this version of iOS Screenshot attached. Appreciate any help. Thanks!

 I also updated to 14.5 iOS. Now mSecure can no longer be started. Message: The developer needs to update this app in order for it to work with this iOS version.

Curious - I have 14.5 iOS on both iPhone and Ipad and no problems with mSecure

 Using mSecure v4 ?

I'm using 5.7.2 without problems

 Apparently the error only occurs with the older version V4. I've been using this version for 10 years and there has never been a problem updating the iOS version

 I hope the support will find a solution. There are around 480 passwords inside.  :-(

iPad v4.5.4 works after upgrading to iOS14.5

The iPhone version v4 does not work after the iOS update.

Please fix, I have the issue too: iPhone X / v4.5.4 / IOS 14.5 / same screenshot as Paul.

I have the same problem - the old v4 does not work under iOS 14.5. Please could there be a way to allow me to upgrade my old v4 to the current version so that I can use it under 14.5.

i have the same problem too. I was running mSecure 4 on my iPhone X for years and rely on it for my password storage. My phone advised on update and now the firmware i 14.5 and i am getting the same message as others. It is concerning since i need to undertake a back up of my current list prior to upgrading to secure 5 should that be the only option to move forward.


Once cannot re-download version 4 from the app store nor through your website which i find odd.


Can support please help with a clear process of how users like on this thread and including myself can resolve through an logical process?


As i have been running a paid version of version 4 for years on my phone how would i migrate to version 5 with my data being synced over? i do not use the cloud and would rather have it backed up via a current back up file. Please advise on the folder  path i would need to set on my mac to allow a correct sync on the new version if this should be the only way.


Thanks

Nav


Login or Signup to post a comment