Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Giving Up on mSecure

I have used mSecure since 2012 as a way to have secure access to passwords I use on my mobile devices. I used another password manager, DataVault, on my Windows 10 computer as the main repository for all of my passwords and sensitive identity information. When I needed to create or update a password that I used on my mobile devices, I did so by first creating or updating the login using DataVault and then emailed myself the new password so that I could manually update mSecure. 


After updating to mSecurePro, I used mSecure on my computer as a more straightforward way to keep the online passwords stored in mSecure for my mobile devices in sync with my main password/vault application, DataVault. Syncing through Dropbox appeared to work flawlessly. Although it was not my main password manager, passwords that I updated through mSecure on my PC were reliably available on my mobile devices. If I needed to create a new login while not at my PC, I could do it with mSecure on my mobile device, knowing that I would have easy access to it once I was at my PC so that I could copy it to DataVault.


It has been several years since there has been any kind of update to DataVault. I've become increasingly concerned about its security and reliability, so have been looking for a way to migrate all of my data to a more modern password manager. Given my very satisfactory experience with mSecure, I hoped that the new mSecure6 would fill the bill. However, in working with the Premium trial version of mSecure6, I have uncovered serious problems with sync, both through Dropbox and through the proprietary mSecure Cloud. Records that were originally in mSecure5 cannot be reliably updated. Changes made to a record using mSecure6 revert to their previous information during the sync operation.


Using mSecure6 on my PC, I modified my existing mSecure5 records to change the template from Login, which I used almost exclusively in mSecure5 to new templates to better organize my passwords. I am creating new templates and/or modifying the "canned" templates to fit my requirements. I plan to use the template names as a method for organizing my records (using the Sort By Template display option). I do not have mSecure6 open on either of my mobile devices while modifying the existing records.


When I update an existing record to specify a new template (and make no other changes), the name of the template shown in record appears to update but then when the auto-sync to Dropbox completes, the record has reverted back to the original template name (Login). For example, when I change the template for my password record for CBS from "Login" to "Entertainment" the record appears to change but quickly reverts after an automatic sync. I created a new record for CBS using the new Entertainment template; this worked fine. However, when I then attempted to delete the original CBS record, it would disappear and then quickly reappear flowing the automatic sync. I now have two CBS records, one using the original Login template and one using the new Entertainment template. Similarly, I cannot delete records I no longer need. Again, the record appears to be deleted but when the auto-sync to Dropbox completes, the record is still present.


I have tried disabling sync on all devices, then modifying records on my PC to change the template associated with each record as desired, and then manually generating a backup file. I then delete all the records from mSecure on my PC, deleted the mSecure sync file: Dropbox/Apps/mSecure 5/UserID/data.mssb file, and then restored the records using the backup file. I then set the sync method to Dropbox with auto-sync off and then click the Sync button, which automatically creates a new data.mssb file. I then launched mSecure on my tablet and phone. In both cases, sync was set to Dropbox, even though I had previously disabled sync. Auto-sync was off on my Android tablet; my iPhone had auto-sync turned on as soon as I enabled Dropbox sync.

It appears that if you turn off auto-sync on the iPhone, there's no way to manually sync. If auto-sync is on, the records that were on the iPhone immediately overwrite the data.mssb file, which then undoes the changes made on the PC. As long as auto-sync is turned off, changes to records do not revert to their previous form. I have not reenabled auto-sync at this time because I'm tired of having changes I make on my PC overridden by the auto-sync.


Finally, I tried setting sync to mSecure cloud, even though I'm not really comfortable storing my data on a proprietary cloud that I can't actually manage. Unfortunately, I encountered the same sync over-write problems I've described above so I went back to Dropbox without auto-sync.


From what I can tell through looking at other posts on the Forum, the problem with sync through Dropbox has been around for at least a couple of years since I found it discussed at length in the following Windows topic on the mSecure support site:


I have submitted tickets and posted on the mSecure Forum about the sync problem. Given the lack of response, it is clear that mSecure is not the answer to my desire to simplify my password security process.

This saddens me. Until the "update" of mSecure5 to mSecure6, I had complete confidence it this product. Now I'm questioning everything.

Thank you for writing up these details of the issue you're experiencing here Lynne. We're working on this issue in a different thread, and I think, though I'm not sure yet, that there are a couple other users dealing with the same issue. There is definitely a problem here, but our developer is working on it as we speak. The only issue I think you're experiencing here is the sync issue, and from what I can tell, it's getting caused by the modified dates getting out of sync between your Windows computer and your iPhone. We're doing everything we can now to get the problem fixed.

We can continue troubleshooting your issue here or in the other thread we have started, but do choose one or the other, as it will become too difficult for me to keep track of the specific information you provide if we're talking in different posts. 

Hi, Mike. 

Thanks for your ongoing help. I will stick to the "Windows" thread at I originally posted about this problem as a support ticket at The response I received from the ticket was useless, as all it did was point me to the mSecure6 product release blog. It was clear that the person responding to the ticket had not really bothered to read the information in the ticket. In frustration and desperation, I posted in the discussion threads because it seemed, until your response on the Windows thread, that the problem was being ignored, regardless of where I posted.

Would it help if I deleted all of my posts except the one in the Windows thread? I am comfortable doing that now that the problem has been acknowledged and an effort is being made to resolve it.

Hi Lynne,

For clarification, the response you received via email was not from a person. We send out an automated response to each customer's email request going over frequently asked questions in hopes that it will help them without having to wait for a personalized email. We understand it won't help everyone, but we figure if it can help some or many, it's better than making each person wait for a response, especially when we're overloaded in support as we are now.

If you would like to delete other posts you have made in the forum, that would be ok, but it's not needed. As long as moving forward we keep our correspondence in the thread, that's what will be most helpful =)

Oh, and I'll be getting to that thread as soon as I can. Just trying to make my way through older posts this morning.

I, too, am having issues with msecure 6.  I may leave msecure altogether, as it is not as user friendly as it was when I first got it.  I need to be able to change my passwords and save in a easy manner. 

@Sharon I'm not sure what you are saying here. You should have no problems changing data in mSecure and saving it just as easily as you did any any version of the app. When you say you having issues with mSecure 6, can you please explain in some detail what exactly is happening? It's possible I could be able to clear up what's happening very quickly.

I'm not giving up after all. With amazing help from Mike, the problems I was seeing have been resolved. Be patient fellow users. mSecure is still the password manager we know and love. happy to hear your issues are resolved.  And I agree, patience while mSecure resolves a few issues....this is one of the best password managers I have had the pleasure to use. I can't wait to see how family sharing is going to work...already greatly impressed with the "premium" version that I happily subscribed to.

@Lynn It's so good to hear you were able to get everything working. I am sorry you had to deal with any of the issues you experienced, but thank you so much for your patience in waiting for a response and then as we worked through the problems. If you need any other help, please don't hesitate to post or send an email!

Thank you again for your feedback @Noella! It's been a pleasure having your help in the forum and working with you the few times I have with issues you have experienced in the app. I'm sure we'll talk soon =)

On second thought... Now that my trial period for mSecure6 has ended, two essential features (Sync and Backup/Restore) that were in mSecure5 now require a subscription. Given that according to mSecure's promise that no one with an mSecure5 license would lose functionality after the forced upgrade to mSecure6 if they chose not to purchase a subscription, I am now reconsidering whether to stick with mSecure.

Hi Lynne,

I just saw your email in our support system, so I'll respond to it instead of here. The short story is there is no v5 Pro license on your account, which is the reason why the syncing is now disabled. We'll have to figure that out via email support.

I always was able to sign in to the app and see all of my accounts and passwords immediately. Now I cannot figure out how to get to them! Not useful!

@Sharon We don't have any known issues that keep some data from showing in any of the mSecure apps, so I'm hoping this is a filtering issue. To make sure no filters are set and all records are visible, please follow the instructions below.

For iOS:

1) Tap the menu icon in the top left of your screen to bring in the menu

2) Tap "All Records" at the top of the list, then close the menu

3) Tap the leftmost icon in the filterbar at the top of the main view

4) Look at the star in the top right of the main view. Is it yellow? If it is, tap it to disable the favorites filter.

For Android:

1) Tap the menu icon in the top left of your screen to bring in the menu

2) Tap "All Items" at the top of the list, then close the menu

3) Look at the star in the top right of the main view. Is it yellow in the on position? If it is, tap it to disable the favorites filter.

For Mac:

1) Click "All Records" at the top of the left column

2) Look at the star in the top right of the middle column. Is it yellow? If it is, tap it to disable the favorites filter.

For Windows:

1) Click "All Items" at the top of the left column

2) Look at the star in the top right of the middle column. Is it yellow? If it is, tap it to disable the favorites filter.

Mike, thank you for solving my issue. It was simply understanding what to do to correct my problem. Us older users just aren’t as saved with technology!

Login or Signup to post a comment