Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Win 10 edits to records not saved

 When updating or editing existing records, the edits appear to save upon click of the green check mark.

But then auto-sync runs and reverts to the original record. This is very scary, it means that existing records cannot be trusted to be accurate and the most current data.

Version on Win10 with DropBox sync

1 person has this problem

Hi Rand,

Thank you for contacting us. I think I may know what's happening here, but I need some information before I can be sure. Can you let me know all the different types of devices on which you are running mSecure? Also, please provide the version numbers for the mSecure app on each of those devices.

If you look at the Last Modified date on one of the records that is reverting changes you make, does it have a date sometime in the future?

Hi again Mike,

I'm not the OP but I just had this problem start happening to me as well.  I tried to delete a entry and it immediately runs a re-sync and restores the entry.  When I look at the modified date it shows up with the year 2100.  When I sort entries by date I found maybe a half a dozen other entries with incorrect future modified dates.  What is the fix for this?



Sorry, forgot to include that I'm running desktop version on two different Win10 PCs, as well as app version 5.7.2 on an Android 9 smart phone. 

Hi Ryan,

It looks like you have run into a known bug introduced in an older version of mSecure 5. Since the modified date is set in the future, when a sync takes place, mSecure sees the future date and simply discards changes that should actually be applied. The sync feature is working, but since the data is corrupted somehow, the changes are never saved.

We are still trying to figure out what's causing this to happen, but it is difficult to get the information needed, since our customer's data must remain private. We have some ideas on how to proceed with a fix, and we hope to implement that soon.

There is a pretty straightforward work-around, but you will want to run through the instructions on your computer, because it has bulk editing capabilities. You can follow the steps below:

1. Find the sync settings in mSecure's Settings on your PC, then disable syncing altogether. This must be done in order to keep old, corrupted data from causing issues after everything is reset. If for some reason you can't turn off syncing, please stop here and let me know.

2. Create a new backup using the instructions you'll find here: Backup and Restore - Windows (this is just to be extra cautious and shouldn't be needed)

3. Delete the data.mssb sync file if using Dropbox syncing. You can find that file in this folder: Dropbox/Apps/mSecure 5/userId/data.mssb

4. Use the bulk editor to temporarily delete all of your records. You can do this by selecting all records using ctrl+a, or you can manually select all records with your mouse, then click the delete button in the right column. To be clear, this is only a temporary deletion. In the next step you will open the "Deleted Items" filter and recover your records.

5. Use the bulk editor to recover all of your records. You can do this by clicking on the "Deleted Items" filter in the left column, selecting all of the records, then click the restore button in the right column.

After you see all of your records restored from the temporary deletion on your computer, everything should be fixed on that device. You can look at a couple of the records you saw with the future modification dates, and they should now be set to the current date/time. Now you need to reinstall mSecure on all your other devices.

After mSecure is reinstalled on your other devices, go ahead and sign in to your account. If needed, you can reveal the QR code in the Account Settings of mSecure on your computer, which will make it easy to authenticate in the Android version of mSecure.

The last thing to do is enable syncing again, but only if you were successful in deleting the data.mssb file in your cloud account. If you were not able to delete that file in the steps above, do not turn on syncing, because it will simply sync in the bad modification dates again.

Once all your records have been restored, a new modified data will be set on each of them, so you should not see the issue again in the future.

Did this take care of the problem Ryan?

That worked great Mike.  Thanks for the easy to follow instructions.  Solid fix.


No problem at all Ryan! It's good to hear everything is working correctly now. It is possible that at some point in time in the future this issue may arise again, but we are working to find a solution. Thanks so much for your time, and take care!

Hello again,

Just wanted to drop in and let you know that this happened again to me starting today.  I have been watching to see if this reoccurred, and after using  extensively up until yesterday with no error, I noticed it happened to a few records today after my PC crashed while I had the program open.  Maybe that will provide you with some clues as to why this happens.

I will run the procedure again.



Hi Ryan,

Thank you for the follow-up, and I'm sorry you're experiencing this issue. I'm not sure, but the problem with the records may have something to do with the Windows version having troubles syncing. When you say your PC crashed, are you saying you were in the process of using mSecure, and then your PC shut down? Did it show you the blue screen that tells you something when wrong before or as it crashed?

The crash was a BSoD because of a printing error due to a recent Win10 upgrade that I've been fighting with.  The crash was not because of mSecure.  I just meant that I had the program open and unlocked at the same time the machine crashed to blue screen and then restarted.

Thank you for the extra information. I was thinking that if the computer crashed in the middle of mSecure trying to sync, then that would possible cause some issues with the data being synced over to your Android device. We're still not sure what is causing the issue with the modification dates getting set to way in the future, but it is still on our radar. At this time, all of our focus is on our version 6 release, so after that is out, we will be looking into this issue in much more depth. In the meantime, the steps to work-around it will work to get things back on track. Also, if you do experience it again, please let us know like did here. Any information we can get could be helpful in finding the actual cause of the bug.

Login or Signup to post a comment