Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

mSecure 6 - Records do not update when using auto-sync through Dropbox

I am a long-time mSecure user. I have mSecure6 on my Win10 computer, Android tablet, and iPhone (day 23 of Premium trial). I am syncing through DropBox, the sync method I have used successfully since purchasing mSecure Pro. I am also using automatic backups, again to Dropbox.

Using mSecure6 on my Win10 PC, I am attempting to modify my existing mSecure records to change the template from "Login," which I used almost exclusively in mSecure5 to more descriptive new templates to better organize my passwords. I plan to use templates as a method for sorting my records (using the Sort By Template display option). I am creating new templates and/or modifying the "canned" templates to fit my requirements. I do not have mSecure6 open on either of my mobile devices. 

When I update an existing record to apply a new template, the record appears to update and then quickly reverts back to the original, unchanged record when the auto-sync to Dropbox completes. For example, when I change the template for my password record for CBS from "Login" to a new template named "Entertainment - Streaming," which has two fields: Username and Password, the record appears to change but when the auto-sync to Dropbox completes, the record has reverted back to show the Login as the template. If I create a new record for CBS using my new "Entertainment - Streaming" template, it works fine. However, I cannot delete the original CBS record or, for that matter, any records I no longer need. Again, the record appears to be deleted but when the auto-sync to Dropbox completes, the record is still present.


If I turn off Dropbox auto-sync, delete the mSecure sync file: Dropbox/Apps/mSecure 5/UserID/data.mssb file, modify or delete a record, and then click the Sync button to manually sync to Dropbox, the problem does not manifest. The data.mssb sync file reappears. If I check the record on my Android tablet and iPhone, the changes are there.

If I then turn on auto-sync to Dropbox, the problem returns; subsequent updates/deletes revert back.

This bug was reported for mSecure5 by a user named Rand two years ago.

It clearly still exists in mSecure6.

Hi Lynne,

Thank you very much for all of the information you have given here. Real quick, since many users were making use of the Dropbox auto-sync feature in mSecure 5 within the last couple of years, I doubt you are dealing with the same bug. Or, if you are dealing with the same bug, it's because your data and Rand's data got into a state I can't explain, and the modified dates are not working correctly. Regardless, we will figure out what's happening and get everything working the way it should.

Before we do anything else here, can you confirm for me that your information is fully up to date on at least one device? If it is, which device is it?

For the time being, I have disabled sync on all devices and manually updated the records on my tablet and phone to match what's on the PC. This is not a workable long-term solution; the reason I use the same password manager on all of my devices is so that I don't have to manually update each device when I add or modify a record. 

I just made a lengthy post, which has not been "approved" on the following topic:

In a nutshell, as a last-ditch effort, I tried WiFi sync with my computer set as the main server. This is not an ideal solution as my computer is normally on an Ethernet network; I had to disconnect the cable from the back of my computer and then connect to my WiFi network before mSecure would connect to either my phone or my tablet for WiFi sync. 

For this test, I only worked with records that I want to change from the Login template to some other template. With sync disabled, I modified the records on my PC. After I completed the changes (for the umpteenth time as I've been trying to troubleshoot the sync problem for the last four days), I enabled WiFi sync on my PC and confirmed that mSecure recognized the WiFi network connection. As with Dropbox sync and mSecure Cloud sync, as soon as the mobile device connected, the updated records on my PC were immediately overwritten with the old data from the mobile device. I suspect that the problem is that mSecure on the Android tablet and the iPhone does not determine which data set has the newest time stamp and instead simply "assumes" that mobile data is the most current and overwrites the updated data on the PC. Ideally, sync should use the newest data set, regardless of where it resides.

I have not made any updates to any records that were in the original mSecure5 data other than to change the template assigned to the record. I do not trust mSecure to not lose data at this point. 

@Lynne I'm not suggesting anything you are doing now is a workable solution. Syncing should work perfectly, so if it's not, the issue needs to be fixed. I here to help get the problem resolved, so you don't need to try to troubleshoot it anymore, as I'm sure that's becoming more and more frustrating. Somehow your data has gotten into a state where the app is not seeing the modified dates correctly, and I don't have any idea why that's happening. However, I think I have a way we can fix it. Before I can do that, however, I need to make sure I know which mSecure app has all your data intact. It sounds like everything is up to date on your PC, and if that's the case, can you make a quick backup to your desktop?


I've backed up from my Win10 PC.

Hi Lynne,

I may have some good news here. Our developer believes he found the bug that is causing something like this syncing issue to happen, and if it's the same issue, it will be fixed in the next release we publish. Before I sound too certain, can you check one of the records you are trying to edit, and look at the modified date for the record(s) on both your PC and your Android device? Is the modified date on Android at somewhere in the future? If you would, please write down the modified date(s) you find on each device.

Record on PC (Template changed from Login to Travel - Airline): Created 12/11/2017, Modified 3/27/2022

Record on Android tablet: Created 12/11/2017, Modified 10/7/9800

Record on my iPhone does not show any created/modified information.

Interestingly, although I had sync disabled on my PC (and on my tablet when I last looked at it yesterday), as soon as I opened mSecure on my tablet, sync changed to mSecure Cloud and immediately overwrote all of the records on my PC that I had updated yesterday with the data from the tablet.  All of records that I had changed from the Login template to another template reverted to the Login template. I restored my PC records from the backup I made at the end of the day. 

There is a problem with the sync setting interaction between the Android mSecure app and the Windows mSecure app. I set sync method to disabled on both my PC and my tablet. I then closed mSecure on my tablet and then reopened it. The sync method had changed from Disabled to mSecure Cloud, which then changed the sync method to mSecure Cloud on my PC and immediately overwrote the records on my PC, again. The interaction does not seem to affect the iPhone (i.e., sync remains disabled).

Hi Lynne,

Thank you for the extra information. I now know an old bug has cropped up, but I'm not sure how it is happening. If you look at the modified data on your Android device, you see that the date is WAY in the future. The reason the changes are not syncing on your PC is because after the change is made, it's seen that the record on your Android device is newer, and the changes are discarded. Right now, this is the main issue you are dealing with and the reason syncing is not working.

For the other issue with the sync setting getting turned back on, that has been fixed and will be in the next release published to the Play store as soon as possible.

I will be in touch tomorrow after I'm able to talk more with our developer to make sure this is fixed.

Mike Reilley - Several of your users are having sync issues with corrupted modified data.  I wouldn't presume to know exactly how your software works.  However, if I may offer some suggestions, rather than focusing on trying to fix the syncing process, would it be easier to just remove all syncs, and select one set of data in one of the devices used by the user as a Master device.

This Master set should be examined for a few critical values such as the total number of records ("All items" should show a number that is the same as before the version 6 update), that all tags have been properly transferred over from groups ("Tags filter" should show non-zero numbers), and that "Created" and "Modified" dates of records are not too far into the future (by examining a few of the records in the "Recents" list).  After the Master set has been selected, perform a backup of this Master set, just in case.

As for the other devices that the user has, just clear the data either by resetting the mSecure app or uninstalling and reinstalling it back.

After that, turn sync back on and wait for the data to be synchronized.

In my own case, I did encounter the loss of groups/tags as well as date field changes that should not have occurred during the version 6 update.  I used the above method very effectively to fix all my issues and so far they seem to be holding up pretty well.

@JSeow Thank you for the suggestion here. The good news is, we have a work-around for the issue, and it's similar to what you mentioned. When working with the desktop version of mSecure, the way you do it is to turn off syncing, temporarily delete all records, then restore them from deleted status, and then reinstall mSecure on all other devices. This resets the modified dates for the records, and then everything is good. Really, the only difference between what you suggested is deleting/restoring rather than backing up and restoring, which should work too.

I actually just realized the work-around is even easier than this. As long as all of the data in any mSecure app outside of the Android app is up to date, all you need to is reinstall mSecure on the Android device and reset the sync file if you are using Dropbox syncing. If you are using mSecure Cloud syncing, you would also need to turn off syncing before reinstalling mSecure the Android device. So the only tedious part might be making sure everything is up to date on a different device, but it's a fairly simple way to get around the problem.

The thing is, this is a bug that resurfaces what seems like about one time a year, and we are trying to fix it once and for all. I just talked to our developer about it, and he's creating a new Android build that will log information to our system so we can try to find out exactly when the date is getting corrupted. Once we figure that out, it's just a matter of keeping it from happening.

@Lynne I just let @JSeow know we're going to be creating a new build for logging information about when the modified date is getting corrupted. However, since we don't know when or how this is happening, it's not going to be as simple as having some customers install that one build to get information. The problem is, since we don't know when the corruption happens, it's possible it won't happen to you again with any records in the future. So we'll be adding the logging to the next published release in the Play Store, and then we'll try to gather the logging we need as other customers encounter the problem. It's not very efficient, but it's the only option we have now.

One thing to note, we know this bug was not introduced in mSecure 6. It's been around for a long time in v5, and I thought it was already fixed, since no one has reported it for quite some time. Most users are not experiencing this problem after upgrading, so at this point, we don't believe it has anything to with the v6 update. 

You mentioned needing to update the data for a record, and that was the way you found out the syncing was not working. You'll need to edit that record in mSecure on your Android, and then it will sync again, because the modified date will be updated to the time you made the changes. After that, you will be able to sync changes for that record again. Unfortunately, since there's no way to know which records you have tried tried to change and then those changes were reverted, the only real way to make sure your data is up to date is to cross-reference the data in each record on both devices. However, this may be too tedious a task, so you could simply do a spot check on your most important records, and check certain values as @JSeow mentioned in his post above.

After you are reasonably sure all your data is up to date, then you would follow the steps below:

  1. Shut down mSecure on all devices except for your PC
  2. Click "Deleted Items" in the left column of mSecure on your PC, and permanently delete, or restore any records you would like to restore so that the deleted filter shows zero items
  3. Go into the Sync Settings for mSecure on your PC and turn off syncing altogether
  4. After syncing is turned off, since you were using Dropbox syncing, delete the data.mssb sync file in your Dropbox folder: Dropbox/Apps/mSecure 5/userId/data.mssb
  5. After the sync file has been deleted, delete mSecure from your Android device
  6. In mSecure on your PC, select all your records, then delete them all using the batch editor (this is only a temporary deletion, and in the next steps, you'll restore them)
  7. After they have been deleted, click "Deleted Items" in the left column
  8. Select all of the deleted records, then click the green restore arrow in the top right
  9. Now all of the record's modified dates have been updated to the current time
  10. Turn on Dropbox syncing in mSecure's Sync Settings, and a new sync file will be created in your Dropbox account
  11. Install mSecure for Android from the Play Store and sign in to your account

Did that take care of the issue Lynne?

I am having mega sync issues with mSecure 6 and dropbox.  I am using it on several PCs, iPhone and iPad.  I had no issues with version 5.  It is like a sync conflict occurs and blows away current data and reverts to past info.  I have one large note file, that seems to have gone back a week.   I thought I was going crazy but confirmed today it is pretty major.  I can't figure out where the problem is.   I just realized how bad it is and have reverted to a previous backup and had to blow away the data on my other devices without really knowing what I lost.  Please advise on a solution here guys.  I am a big fan from version 3.x, but this is scaring me pretty bad.  Would it be possible for you to capture sync records in a place where we can review sync history?  It is very rough not knowing what has changed and going back over a week.  Is the modified date issue causing this?  If so, do I need to delete all records, restore and then resync to dropbox, or what do you recommend?  I need to fix this.

@Mike Reilley. I am currently going through every mSecure record on my PC to makes sure that the common fields (e.g., Website, Username, Password) are in the same order in every record. A side benefit is that I'm clearing out deadwood in the process. After I finish I'll make a backup and then perform the steps you recommend; probably tomorrow afternoon. I will let you know how it goes.

@Mike I think you are dealing with a bug in Windows, but I can't be sure. If you are, the issue is already resolved in the next release we will be publishing as soon as possible.

Real quick, can you look at a couple of the records you are seeing this problem take place? Check the modified date in mSecure on both your PC, your iPhone and iPad. What modified date do you see on the records on each device?

Login or Signup to post a comment