Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Sync across operating systems after mSecure6 upgrade not working

Overall, I like the look/feel of mSecure6 on my computer (Win10). I like the fact that I can create new templates and reorder fields in the built-in templates. I don't even mind the fact that it's subscription-based.

What I don't like is the fact that sync through Dropbox no longer works. In addition to my computer, I use mSecure on my iPhone and my Android tablet. In both cases, the app notifies me that I'm using a old version (i.e., mSecure5) and directs me to "check the App Stored for an update and install the latest version." Unfortunately, neither the Apple App Store nor the Google Play Store have mSecure6. Without the upgrade, the mSecure records on my computer do not sync with mSecure on my phone or tablet, presumably because the database format has changed. 

Given that you've forced an update mSecure6 for my computer, the least you do is make sure that the database remains compatible with mSecure5 since there isn't an update available (that I could find) for iOS or Android.

Hi Lynne,

Thank you for your feedback. I'm not sure what's happening here, but you should have no problems syncing in mSecure 6, regardless of which feature you choose to use. Are you saying that you think syncing is not working because you haven't been able to download the Android version yet? If that's the case, you should be able to download it now from the Play Store.

Maybe sync would work, if the macOS version didn't force close before even getting open?  I deleted and reloaded from your web site, put in credentials, hit the little lock icon, and poof, force close.   macOS Monterey Version 12.2.1


The new mSecure6 updates finally showed up on Apple App Store and Google Play Store. Both installed and sync is now working across all three platforms.


That's great to hear @Lynne! Please let me know if you have other questions.

@Greg I don't know what's causing the problem you are having, but we'll get things working. Do you have another device running mSecure where all of the data is being displayed and the app is working correctly?

Attempting to sync via wi-fi in ver 6. Worked well across two Win10 laptops, one set as the server, the other as client. Does not work with the android mobile devices; one Lenovo tablet and two Samsung phones. All are now running ver 6 from respective 'stores'.  The Lenovo laptop client can indentify the proper network. The Samsung phones do not, returning a <unknown ssid> error. But all other apps on the Samsung phones access wifi as expected.  All android devices show "Server is unreachable", which was clearly not the case for the Win 10 laptop.

What is different about wifi sync to android devices?

Rand - were you able to sync your Android devices to your main laptop prior to upgrading to v6?  I too am using wi-fi sync and did not face any issues either before or after the upgrade.  The thing to note is <unknown ssid> does not appear to be an error as this message appears on my Android device while it is fully able to reach the server and the connection icon is green.  A second thing to note is that the mSecure app on the server should be unlocked at least once before the Android device is able to synchronize.  You should refer to the knowledge base for further tips under the topic WiFi Syncing.  Hope this helps.

 JSeow - Yes I was able to sync across devices with ver 5. Win 10 laptop is set as main computer/server. mSecure 6 is open and running, unlocked. Then mSecure is launched on android device and wifi sync initiated on android device.

Success.  Wifi must be set to "Private" so discoverable by other devices. Works now.

Mike Reilly: This settings detail should be added to WiFi Syncing topic.

 JSeow - PS: Thanks for the hints. Triggered me to look at wifi settings.

I have mSecure6 on my Win10 PC, Android tablet, and iPhone (day 22 of Premium trial). I am syncing through DropBox.

Using mSecure6 on my PC, I modifying my existing mSecure5 records to change the template from Login, which I used almost exclusively in mSecure5 to new templates to better organize my passwords. I am creating new templates and/or modifying the "canned" templates to fit my requirements. I plan to use the template names as a method for organizing my records (using the Sort By Template display option). I do not have mSecure6 open on either of my mobile devices while modifying the existing records.

When I update an existing record to specify a new template (and make no other changes), the name of the template shown in record appears to update but then when the auto-sync to Dropbox completes, the record has reverted back to the original template name (Login). For example, when I change the template for my password record for CBS from "Login" to "Entertainment" the record appears to change but quickly reverts after an automatic sync. I created a new record for CBS using the new Entertainment template; this worked fine. However, when I then attempted to delete the original CBS record, it would disappear and then quickly reappear flowing the automatic sync. I now have two CBS records, one using the original Login template and one using the new Entertainment template. Similarly, I cannot delete records I no longer need. Again, the record appears to be deleted but when the auto-sync to Dropbox completes, the record is still present.

I have tried disabling sync on all devices, then modifying records on my PC to change the template associated with each record as desired, and then manually generating a backup file. I then delete all the records from mSecure on my PC, deleted the mSecure sync file: Dropbox/Apps/mSecure 5/UserID/data.mssb file, and then restored the records using the backup file. I then set the sync method to Dropbox with auto-sync off and then click the Sync button, which automatically creates a new data.mssb file. I then launched mSecure on my tablet and phone. In both cases, sync was set to Dropbox, even though I had previously disabled sync. Auto-sync was off on my Android tablet; my iPhone had auto-sync turned on as soon as I enabled Dropbox sync. As soon as the device connected and the sync operation completed, the updated records on the PC had been overwritten by the old data on the mobile device.

I also tried setting sync to mSecure cloud, even though I'm not really comfortable storing my data on a proprietary cloud that I can't actually manage.  I encountered the same problem of sync overwriting the updated record in the Windows app with the old data as soon as the mobile device synced. 

Finally, I tried WiFi sync to my iPhone and my Android tablet with my PC set as the main server. This method requires me to disconnect the Ethernet cable from the back of my PC tower and then connect the PC to the WiFi network. I encountered the same problem of sync overwriting the updated record in the Windows app with the old data as soon as the mobile device synced. I was finally able to get the records on all three devices synced by turning of disabling sync, modifying the necessary records on each device manually, and then turning on WiFi sync. 

It appears that the problem with sync through Dropbox has been around for at least a couple of years since I found it discussed at length in the following Windows topic on the mSecure support site:

My guess is that, regardless of the sync method used, when sync on either my Android tablet or iPhone mSecure connects to my PC, mSecure fails to check which device has the most current data. Instead, the app on the mobile device simply uploads whatever data it has to the PC, thereby overwriting the updated record with the old data.

Lynne - First of all, you do not really need to disconnect your Ethernet cable from the PC.  In fact, Wi-Fi sync is a misnomer since the term should really be LAN (local area network) sync.  It works so long as the various devices are on the same subnet.  You just have to check that your PC's Ethernet network profile type is "private" so that it is discoverable by the other devices in your network.

As for your templates issue, I suggest that you examine the time stamp of the records on each device - look at both created and last modified times as well as the dates corresponding to matching records.  It is possible that the ones on your iPhone are somehow "newer" than the ones you edited, and would thus always override "older" records.  This may be due to different date/time formats on different platforms although I cannot imagine such a bug would somehow manifest itself.

@JSeow Thank you very much for helping here! It's always great to see customers helping other customers.

@Lynn I'm hopeful @JSeow's response has helped with the syncing, though I'm pretty sure the issue you are trying to solve is related to the modified date and not the type of syncing you are using. I responded to you in your other thread, so hopefully we'll see some progress on this soon.

@JSeow. Thank you for the suggestions. I am working with Mike to resolve the sync issue.

Login or Signup to post a comment