Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Giving Up on mSecure

I have used mSecure since 2012 as a way to have secure access to passwords I use on my mobile devices. I used another password manager, DataVault, on my Windows 10 computer as the main repository for all of my passwords and sensitive identity information. When I needed to create or update a password that I used on my mobile devices, I did so by first creating or updating the login using DataVault and then emailed myself the new password so that I could manually update mSecure. 


After updating to mSecurePro, I used mSecure on my computer as a more straightforward way to keep the online passwords stored in mSecure for my mobile devices in sync with my main password/vault application, DataVault. Syncing through Dropbox appeared to work flawlessly. Although it was not my main password manager, passwords that I updated through mSecure on my PC were reliably available on my mobile devices. If I needed to create a new login while not at my PC, I could do it with mSecure on my mobile device, knowing that I would have easy access to it once I was at my PC so that I could copy it to DataVault.


It has been several years since there has been any kind of update to DataVault. I've become increasingly concerned about its security and reliability, so have been looking for a way to migrate all of my data to a more modern password manager. Given my very satisfactory experience with mSecure, I hoped that the new mSecure6 would fill the bill. However, in working with the Premium trial version of mSecure6, I have uncovered serious problems with sync, both through Dropbox and through the proprietary mSecure Cloud. Records that were originally in mSecure5 cannot be reliably updated. Changes made to a record using mSecure6 revert to their previous information during the sync operation.


Using mSecure6 on my PC, I modified my existing mSecure5 records to change the template from Login, which I used almost exclusively in mSecure5 to new templates to better organize my passwords. I am creating new templates and/or modifying the "canned" templates to fit my requirements. I plan to use the template names as a method for organizing my records (using the Sort By Template display option). I do not have mSecure6 open on either of my mobile devices while modifying the existing records.


When I update an existing record to specify a new template (and make no other changes), the name of the template shown in record appears to update but then when the auto-sync to Dropbox completes, the record has reverted back to the original template name (Login). For example, when I change the template for my password record for CBS from "Login" to "Entertainment" the record appears to change but quickly reverts after an automatic sync. I created a new record for CBS using the new Entertainment template; this worked fine. However, when I then attempted to delete the original CBS record, it would disappear and then quickly reappear flowing the automatic sync. I now have two CBS records, one using the original Login template and one using the new Entertainment template. Similarly, I cannot delete records I no longer need. Again, the record appears to be deleted but when the auto-sync to Dropbox completes, the record is still present.


I have tried disabling sync on all devices, then modifying records on my PC to change the template associated with each record as desired, and then manually generating a backup file. I then delete all the records from mSecure on my PC, deleted the mSecure sync file: Dropbox/Apps/mSecure 5/UserID/data.mssb file, and then restored the records using the backup file. I then set the sync method to Dropbox with auto-sync off and then click the Sync button, which automatically creates a new data.mssb file. I then launched mSecure on my tablet and phone. In both cases, sync was set to Dropbox, even though I had previously disabled sync. Auto-sync was off on my Android tablet; my iPhone had auto-sync turned on as soon as I enabled Dropbox sync.

It appears that if you turn off auto-sync on the iPhone, there's no way to manually sync. If auto-sync is on, the records that were on the iPhone immediately overwrite the data.mssb file, which then undoes the changes made on the PC. As long as auto-sync is turned off, changes to records do not revert to their previous form. I have not reenabled auto-sync at this time because I'm tired of having changes I make on my PC overridden by the auto-sync.


Finally, I tried setting sync to mSecure cloud, even though I'm not really comfortable storing my data on a proprietary cloud that I can't actually manage. Unfortunately, I encountered the same sync over-write problems I've described above so I went back to Dropbox without auto-sync.


From what I can tell through looking at other posts on the Forum, the problem with sync through Dropbox has been around for at least a couple of years since I found it discussed at length in the following Windows topic on the mSecure support site:


I have submitted tickets and posted on the mSecure Forum about the sync problem. Given the lack of response, it is clear that mSecure is not the answer to my desire to simplify my password security process.

This saddens me. Until the "update" of mSecure5 to mSecure6, I had complete confidence it this product. Now I'm questioning everything.

No problem at all Sharon! It's great to hear everything's working now.

Login or Signup to post a comment