Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Date bug?


On the Windows app, when I use the Birthday template and insert the date / save, the date doesn't save and it goes blank. I'm not sure if this is a general date bug for other templates as well as I haven't tried it, but thought I'd put it out there.

When I use the iOS app, it works perfectly fine on there.

Hi Ai,

Thank you for bringing this to our attention. I just tested this on my PC, and the date is saving when I create or edit a record created with the Birthday template. Are you saying that after you have saved the record, you see it in the middle column, but when you click on it, there is no date stored in the "Date" field?

@Mike, I think I worked out what the bug is after playing around with it more.

On Windows, when you use their date picker e.g. 01/03/16 (DD/MM/YY), upon saving the record your app recognises it as MM/DD/YY and coverts it to 03/01/16 (MM/DD/YY). What I was finding was that when I was picking dates such as 20/12/16 (DD/MM/YY), upon saving it must be recognising it as MM/DD/YY, as 12/20/16 is not a valid date, upon saving I'm getting a blank field.

I'm assuming the conversion is correct on iOS as I can pick any date and it comes out fine. It looks like this is a Windows bug. Not sure if you can confirm that you can replicate that on your end?


I have not been able to replicate the error that @Ai has mentioned.  The date displays properly for me on my PC (noting that the date format on my PC is set to 2022-03-30)...I've attached images.. It also displays properly on my Macbook. On my Iphone though, the date appears as Dec 31, 2016

date1.png date1.png
2.83 KB

@Noella, thanks for your help. The date format on my Windows 11 is DD/MM/YYYY (UK standard). I wonder if that is causing conflict with the mSecure app.

@Ai Ok, this is making more sense now, and even if the date wasn't formatted correctly, you should have been notified somehow. To be clear, you were using the date picker to set the date, and it still wasn't getting saved? Once I hear back from you, I'll talk to the developer and we'll figure out what's going wrong.

@Mike, yes I used the date picker to set the date (there is no other option anyway) and it wasn't being saved correctly (either the DD/MM were turned around or it was blank as it didn't recognise it).

Sorry, as a slight aside but on the subject of dates:

1) I'm not a fan of using MS's date picker, I prefer the old fashioned way of typing it in myself or at least have the option to do so. Not a deal breaker for me and it maybe just a personal preference of mine rather than speaking for the majority. Was just an opinion.

2) Also seems to be a bug with the date picker on Windows where if I choose the Credit Card template and choose the Valid From or Expiration Date (Month / Year Field), the date picker uses a scroll choice with MM on left and YYYY on right, the YYYY on right is not big enough to show all YYYY, it only manages to show YY, example is 06/2016, you only see 06/20. Is there a reason why the date picker is different in that scenario to a full date like the birthday date above? Looks a little inconsistent. Again I would have preferred an option the old fashioned way of just typing it in.

Expiration date on my PC for Credit Cards, shows the first three numbers of the year...I've attached an image..  No issues on my Iphone or macbook

@Ai I will be talking with our developer soon about a couple other fires we're trying to put out, and I will bring up this date bug as well as the other 2 points you brought up. Since @Noella's is showing 3 numbers where yours is only showing 2, I'm guessing the window is able to be resized, and the default setting is just not working for all devices. I'll see if there is way for him to force all 4 numbers to be displayed.

@Noella, thanks again, you've been so helpful!

@Mike, thank you - these are not high priority at all, just minor niggles if they can be looked at when you can.

I have the same issue with a custom template when i use the windows app the dates get deleted as soon as i save the record. If if update the same record in IOS its save fine but if i then go back into the windows app and update any field in that record (even if its not the date field) all the dates in the record get deleted.

Hi Everyone,

Quick update here, I have talked to our developer about the date issue, and it's on his radare to get fixed as soon as possible. We're working on a couple of other bugs that are much more urgent right now, but he should at least be able to start looking into the date issue you all have reported as early as tomorrow.

Also, just as a heads up, depending on how difficult it is to get the issues with dates fixed, it might not be able to get into the next release. We have to get that one out fast to fix a couple of other issues, so it might be a week or more before the date problem is resolved.

@Mike, thanks for the super quick response. No problems from me with the fix for this, not a massive deal, just appreciate its on the radar to be looked at. Thank you and your developers!

I wasn't expecting an update - but certainly appreciate it.  Wonderful support - thanks @Mike

Hi Everyone,

Our developer believes he has the sizing issue resolved where you were only seeing the first 2-3 characters of the year, though the fix is not as elegant as we had hoped. Apparently, Microsoft only allows the width of that control to be changed by changing the width of the date field, so you'll see in the next release what I mean =)  If you still see any problems with the width, please let me know.

The bigger problem with the date getting discarded is not fixed, and he's not able to reproduce what you are all experiencing. He needs more information about what you see in your Windows Locale settings. Would you either or all of your experiencing the date loss be willing to attach a screenshot of your language/locale settings in Windows? It's the screen where you set your region as well as the time formatting.

Login or Signup to post a comment