Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


Moving from Passwords Plust to mSecure Import issue

Good day folks, I'm not happy about loosing Passwords plus at all but when given no choice you do what ya gotta do. 

So I'm here and the first issue to appear is a special import feature for PWP users seems to be only available if we purchase on of the version of mSecure. 

Since Msecure is offered as a trial and that's exactly what I need as I'm going to be talking to a lot of my clients I want to fully vet this transition first. I down loaded from the MS store for Windows PC and the only option I saw to import was from some previous versions of mSecure. Obviously that dosen't help. 

How can we complete this import from PWP? 

I saw no other import options once setup was completed. 

5 Personen haben dieses Problem

I already posted this but it seems it was not sent through . I had all the problems in this thread but I was using windows. I switched to MacBook and did all the same stuff and it worked perfectly . Maybe you gotta borrow a mac or buy a cheep one just for this.  I can now access all the passwords on  android mac and windows 

I contacted PWP about this issue and received:

We are working with mSecure on a fix for this problem and hope to have something very soon. Please be patient while we work this out.


Some workarounds (although you don’t have to try these - we are planning for a fix)


It does appear that the issue is only on Windows so if you have even temporary access to a Mac, you can try to do the import there. Even if you don’t plan on using the Mac going forward, you can just use it for the import, then sync and log into the Windows version and things should work correctly.*2 (This is not a confirmed fix but was reported by another customer). Use a text editor to convert single and double quotes to another character within the exported CSV file - or go through the data in PWP and remove all quotes.


You do NOT have to do this - as I said, mSecure is hoping to have a “real” fix soon. But if you’re up for it, you can give it a try.


If you do either of these workaround and they work sufficiently, please let us know.


We will update this page as well as email you when we have a resolution to this issue

So, as another post said, if you go via Mac it will work. For mere mortals, cross your fingers and hope they fix it.

Thanks John, It would be interesting to see if others that had a mac had a successful import. 

No apple in this household LOL. So can't try, and my clients are all on windows. 

Mike R OP

Excuse me! What solution was that? So far the majority of posters have no solution.

Hi Everyone,

Unfortunately, as you are all finding out, there is a bug with the Windows importer for Passwords Plus. Our developer worked out most of the issues yesterday, and he'll be doing everything he can to get any remaining problems fixed today. This means we'll be getting the build submitted to the Microsoft Store very soon, then it's just a matter of waiting for the review to be certified by Microsoft so we can publish it. We're sorry for the inconvenience this has caused, and the new version will be in the Microsoft Store as quickly as possible.

Mike that's great to hear. Thank you for your teams effort to get this fixed. 

MIke R

Same problem 44 of 360 or so records imported. The CSV file has a "0" in Col A that appears to be a flag that the record contains a new DataVis record. If no "0' then its a continuation of data from the prior record. This import tool was not tested. Still using Passwords Plus.

Ray they are working on it. Hopefuly soon will get a second try on the import tool. 

Who knows we might find more bugs and then again might be a winner. At this point we still have a fair amount of time to get this worked out. 

Mike R

@Everyone I wanted to give you a quick update on the Passwords Plus import issue. I just published to the Microsoft Store, so it should be available in the store over the next couple of hours. If you have the Store app open on your computer, go ahead and close it and wait for about 10 seconds. Next, open the Store app, click the Library icon near the bottom of the thin left column, then click "Get updates" in the top right. If you don't see it the first time, what for about a half hour and then try again. It will be available for download sometime throughout the day.

One thing to mention, before you do the import of your Passwords Plus data again, be sure to select all of the data currently in mSecure and delete it. After it's deleted, click "Deleted Items" in the left column, select all of the records again and permanently delete them. This will get you started from a clean slate when you go through the import process again.
I downloaded the update and successfully imported 576 records. However, I did find one issue where I had the record name as "Work AWS Accounts" and a second record as "Work AWS Accounts II". It imported the same data from the entry called "Mack AWS Accounts" into both records even though the names were different. I'm assuming it is because the names are so similar.

Mike@mSecure, Thank you for your teams effort, I just completed a import and it all looks good, but!!!

I had to turn off syncing then delete the previous records as if it was on if I closed mSecure and reopened to do the import The previous data was in. Turned sync back on after the import. 

Next up today I'll load the Android app and check out the sync, if that works I am a happy camper as wer as close to 50 others I'll be sending your way. 

Thanks Again, Mike Ruth

@Mack It's great to hear the import was successful. I'm not sure what happened with the 2nd "Work AWS Accounts" record, as I don't know of the developer appending "II" to the end of records like this. The good news is, I think you can delete that second record if you haven't already and just leave the first one live.

At any rate, thank you for posting and confirming everything is working!

@Mike It's great to hear your import went well after the release was installed. I don't know what happened with the syncing, but it is something I wish I could reproduce. It sounds like the problem was just that the CSV import of the Passwords Plus data was added to the existing import you did before, and if that is the case, that is normal and not a problem with syncing. For CSV imports, unless it's an actual mSecure CSV file, the new data will be merged in with existing data, so deleting the existing data before importing again was the right move.

At any rate, thank you for the post confirming everything is working, and thank you as well for pointing the other Passwords Plus users our way! It is much appreciated.

@Mike-Msecure  - I guess my original reply was not clear.   The original PWP database had two different records with different data.   However, when the data was imported,  it still created two separate records but each record had the same data (so data from my second record was lost).   Since the record names both begin with the same 17 characters  that may have caused the issue.   

Bottom line, it  was not an extra  or duplicate record that got created, it was a separate record with a different name that ended up with the data contents of the previous record.    Thanks Mack.


FWIW, I have 2 records in PWP with identical names and different data and they imported into mSeure just fine. I also have 3 or 4 records with almost identical names (i.e. xxxxx and xxxxx-1) with different data and they also imported just fine.

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen