Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

base di conoscenza Invia un biglietto

Can't access V4 to import data onto V5.

I couldn't access V4 at all as it said I had to update the app which I did. When I tried to import from 4 to 5 I was asked for my password which I can't remember as I always use fingerprint recognition and don't know the password. Does anyone know how I can reopen my V4 again?

I just used it the other day but now I just get an error "msecure needs to be updated". How incredibly frustrating. I need my passwords! I can't survive without this thing.

2 persone hanno questa domanda

Hi Silvia,

Thank you for contacting us, and I'm sorry for the issue you are experiencing after the most recent iOS update. We have been trying to figure out a way to help our customers through this issue, and our developer was able to get a utility version of the old app built, which enables you to retrieve the password you used in mSecure 4. Do keep in mind that it can only help if you were using Touch or Face ID to unlock the app. If not, there is no way to retrieve the password from the old app.

This version will not be available in the App Store, since it's only a utility version of mSecure 4, created for a single purpose. In order to download it, you will need to download the TestFlight app from the App Store if you don't already have it installed on your devices. 

Should you choose to download this utility update, I will need the Apple ID (email address) you use on your iOS devices. Once I have that, I can add you to the TestFlight list of users who will be given access to this version of the app. Once added, you will get an email invite to download the app from the TestFlight app. The new version will download over the top of mSecure 4.5.4, and it can only be used to reveal your password. Since v4.5.4 can no longer be opened, this shouldn't be a problem, but I do want to make sure you understand all that will happen when the new build is downloaded. In particular, the TestFlight version will have no functionality for viewing your data. It can only retrieve your password from iCloud Keychain on your device, and then display it to you.

Once you have the password, you can write it down and enter it when upgrading to mSecure 5.

Let me know if you have any questions about this process. If you're ready to proceed, download the TestFlight app, send me your Apple ID, and I'll add you to the TestFlight list.

Also, some customers don't want their email address printed out here in the forum. If you are opposed to that, let me know, and we'll have to finish this via email support instead.

Hi Mike. Sounds good to me.

I don't feel comfortable publishing my email on this forum. How can I get it to you?

Hi Silvia,

Go ahead and send an email to "" with "Attention Mike: Apple ID for v4 Utility App" in the Subject line. That will help me identify it more quickly. As soon as I get that email, I'll add you to the TestFlight list, and then I'll continue our interaction via email. 

Thank you! I just emailed you

No problem at all Silvia. I see everything worked from ticket in our support system. Let me know should you need further assistance.

Hi Mike-mSecure,

I'm having the same problem Mike is having.  I have used mSecure since 2008.

I'm receiving the following message: " Needs to Be Updated - The developer of this app needs to update it to work with this version of iOS."

I don't know my mSecure 4 Passwords since I have been using the finger print recognition since it was available.  

Should I email you my Apple ID for V4 Utility?



It seems that Apple has corrupted your data, or App; whichever applies! Now it is time to fix, repair, or replace! Without rev4 data, this is a useless app. I never thought I would say this, but it is what it is: USELESS! Thanks for the memories!

@Don Yes, go ahead and email us at with the subject line, "Attention Mike: Apple ID for v4 Utility App", and send your Apple ID with that email so I can add you to the TestFlight user list. After you're on that, you will be able to download the app and retrieve your password. Also, reply here really quick after you send the email, as that will expedite things as I continue to check activity in the forum.


@Rick I'm sorry to hear about the issue you're experiencing after the recent iOS update. Unfortunately, mSecure 4 is no longer supported, so there won't be any updates to that version of the app. The problem is, at some point in time, older, unsupported apps always run into issues like this, which is why developers have to provide an option so that it doesn't happen. mSecure 5 is that option, as it is the update to mSecure 4 that keeps what's happening in iOS 14.5 and 14.6 from taking place.

In the older version of the app, we implemented an advertisement for mSecure 5, and that was to let our users know that the app was available and that they could upgrade at any time. Along with that advertisement, we provided an option to close it and not show it again in the future. We are finding that a lot of customers have used that option, so they aren't seeing the ad any longer. The problem is, we have no way of contacting our older customers, because the older app doesn't have an account system. Without an account system, we don't have their email addresses. If we did have their emails, we would be communicating with them to provide some explanation on what is currently happening after the recent updates to iOS, to tell them what we're doing to help, and to let them know about the backup in support which is leading to long wait times in receiving responses from our support team.

However, the issue brought about by recent iOS updates are a different story altogether. On all our company test devices, we have still not encountered the issue you and other customers are experiencing, which, though there are a lot of people who have experienced the problem, is actually a very small percentage of our overall customer base. Even had we been able to contact our users via email, we wouldn't have done so before the iOS 14.5 update, because we never knew it would cause this problem. And Apple doesn't send developers notifications that this type of behavior will occur, so there was no way for us to know ahead of time.

Moving forward, we still aren't able to tell for sure the next iOS update will cause the upgrade message to appear. Our developer has even tested on the first beta release of iOS 15, and the old mSecure app runs without any problems. In short, at this time, we do not know what is causing the issue for the old, unsupported mSecure app, but we have provided a solution.

The good news is, if you still know your password to mSecure 4, you haven't lost your data. All you would need to do is install mSecure 5, create a new account or reset an existing account, and then migrate your data in from the old app. You can find out more about this process here:


My password in Rev 5 is RB@bonvoyage69. This is my last attempt to get data back….,you have the info, now fix the problem.

Hi Rick,

I'm not sure what you mean here, but it's not a good idea to post the information you did to your account. Everyone looking at this thread can now have access to it. It's not possible for me to fix the problem, but I can help get it fixed if that's what you mean. I wrote what needs to happen in my last response to you, but here are the instructions again.

In order to migrate your information into mSecure 5, your account has to be in a fresh state. This means you will need to reset your account before you try to sign in to mSecure 5 on the same device mSecure 4 is installed. After the account is reset, the migration will be triggered as you go through the sign in process in mSecure 5.

The first step is to simply delete mSecure 5 from your device. After you have deleted the app, follow the steps in this support article to reset your account:

Next, reinstall mSecure 5 from the App Store app, then sign in to your account using your account's Username (email address) and the new password you just set. After you choose which sync feature you would like to use, you should see the screen asking if you would like to import your data in from mSecure 4.

IMPORTANT: Do not delete the old mSecure 4 app from your device. If that is done, the data stored in the app will be lost. Also, your mSecure 4 data is not connected to your mSecure 5 account in any way, so performing the account reset will have no effect on the data stored in the old app.

Accedi o Iscrivitiper pubblicare un commento