Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

MSecure 4 says it needs a developer update

I suddenly can’t open MSecure 4 on my iPhone because it’s saying it needs a developer update.

1 personne a le même problème

Hi Jessica,

Thank you for contacting us. Unfortunately, mSecure 4 is no longer supported, so there will be no updates to that version of the app. mSecure 5 is the update to mSecure 4 that keeps what's happening in iOS 14.5 and 14.6 from happening. It was never our intention to continue the support of mSecure 4, but at the same time, we didn't want to force our customers to upgrade. The problem is, at some point in time, older, unsupported apps always run into issues like this, which is why developers have to provide an option so that it doesn't happen. mSecure 5 is that option.

In the older version of the app, we implemented an advertisement for mSecure 5, and that was to let our users know that the app was available and that they could upgrade at any time. The problem is, we have no way of contacting our older customers, because the older app doesn't have an account system. Without an account system, we don't have their email addresses. If we did have their emails, we would be in communication about what is currently happening. However, issues like iOS 14.5 are a different story altogether. On all our company test devices, we have still not encountered the issue you and other customers are experiencing, which, though there are a lot of people who have experienced the problem, is actually a very small percentage of our overall customer base. Even had we been able to contact you via email, we wouldn't have done so before the iOS 14.5 update, because we never knew it would cause this problem. Also, Apple doesn't send developers notifications that this type of behavior will occur, so there was no way for us to know ahead of time.

If you still know your password to mSecure 4, you haven't lost your data. All you would need to do is install mSecure 5 and migrate your data in from the old app. You can find out more about this process here:

I tried migrating but nothing happened/not sure if I did it correctly. What are the step by step instructions? Can I do this from an iPad or iPhone or does it have to be from a computer? I don’t remember the last time I backed up MSecure 4 but I use it regularly.
When it’s asking to migrate my data, it’s not asking for my old password so how does it know where to import from?
I just reset again and using iCloud to migrate but it’s not asking for my old password. I get the error message attached.

When you say you just reset again, can you describe for me what you actually did? The last error message you attached means that mSecure 5 is seeing data in your iCloud account, but it can't sync with it because the account was reset. However, this is ok, because what we're trying to do here is have you migrate in from the mSecure 4 app on one of your iOS devices, and the device you should be using is the one you know has the most up to date version of your mSecure data.

Also, in your first post after my response, you say that you tried migrating but nothing happened. Can you explain to me what you did to try to migrate your data?

For now, I want to try to make things as simple as possible, because things are getting to complicated for me to keep track of where to go next. After you answer the questions I asked above, please let me know which iOS device has the most up to date set of data in the old mSecure app. That is the only device we'll use moving forward, unless we need to try something out on the other device, but I'll let you know if that needs to be done.

Also, you asked if the migration needs to be done from a computer. Are you saying that you have mSecure installed on your computer? If you do, are you able to open mSecure on that device and view your information?

Question 1 re: reset: I followed the instructions you provided. I reset M5, reinstalled the app and tried to sync my data but it never asked me for my M4 password. Question 2 re: migration: I tried each of the sync options available in the M5 app to import but none were successful. Question 3 re: which iOS has the most recent M4 data: it’s an iPhone 12 running the most recent software. I don’t have M4 installed on any other iOS device. Question 4 re: a computer: I have M4 installed on an old MacBook but I don’t have access to it at the moment and the data on there is very old. I asked that question just to make sure I wasn’t wasting my time trying to get things to work on my phone if it wasn’t possible.

Hi Jessica,

I'm not sure what could be happening here is you went through the account reset process. That is definitely what needs to happen in order to trigger the migration of data. The only way that won't happen is if the mSecure 4 app was an older version than 4.5.4, which is possible. Since older versions of the app didn't have the migration capabilities, it's not possible for mSecure 5 to see the database file in that context.

I'm going to have you check and see if there is an update available for the older mSecure app. Go ahead and open the App Store app on your iOS device, tap your profile picture in the top right corner, tap "Purchases," and then tap "My Purchases" if that option is available. In your list of purchases, do you see an Update or Upgrade available for mSecure? If so, can you confirm for me that the app's icon is a bright blue color and that it matches the color of the icon you tap to open the mSecure app on your device's home screen?

For the other questions, the sync feature is not going to allow you to migrate data in from older versions of the app. Syncing is only for sharing data between two compatible versions of the app, so it can't be used to send data between v4 and v5. Regarding your Mac, thank you for that information, and since the data would be old, I won't worry about that version any longer. When you do have access to it, you may want to check just to be sure you know just how old the data is.

The bright blue MSecure icon says “open” when I see it in my purchases (no upgrade or update option). I’m pretty sure it’s the latest version because I remember updating it not long ago and am pretty good about doing updates frequently on my most used apps.

Ok, I'm not sure what's happening here, because we are absolutely certain the migration will take place if you have mSecure 4.5.4 installed and you are signing in to an account that was just reset. I'm going to have you try going through the account reset steps again to see if the import/migrate screens are displayed. First, go ahead and delete mSecure 5 from your device. Next, go through the account reset steps again that are found here: Account Reset

After resetting, what happens after you install mSecure 5, then tap the option to "Sign In" to your account? You should receive a new email with your account QR code in it, and mSecure should go to the next screen, which should be the screen asking you which sync feature to use. Go ahead and tap "mSecure Cloud" for now, but you can change that later if needed. The next screen should say something about importing your data. Do you see that screen?

I followed all of your instructions step by step and once again I was not given an option to import data. After selecting MSecure cloud, I just see the screen saying setup is complete. It never asks me for my import login info.

@Jessica I'm not sure exactly what's happening, but the only thing that makes sense here is that the version of mSecure 4 you are running on your device must be older than version 4.5.4, which is the newest version of the old app. In the final release of mSecure 4, we implemented a shared space for the database to which mSecure 5 has access. Unfortunately, versions older than 4.5.4 don't know about that shared space, and in that case, mSecure 5 is not able to access the older app's data.

Most of our customers running into the same problem you are after updating to iOS 14.5 or 14.6 are following the exact same steps, and the migration is working as intended. Because of this, we know if the older version of the app is 4.5.4, the migration does take place. However, there is a small handful of people for which the migration option is not available after choosing a sync option, and what I explained above is the only only explanation we have when this happens.

Do you know if you made any email backups from mSecure's Settings before the problem you are experiencing started? If not, do you have access to your data in any version of mSecure running on any of your devices?

When was the 4.5.4 version released? I have a very old version of my MSecure data on a laptop, otherwise I don’t have MSecure on any of my other devices (an iPad) and I have not done an email backup. Do you know if MSecure data is saved in iCloud? I’m wondering if I downloaded MSecure 4 on my iPad that does not yet have the latest iOS, if my data would be there? I’m traveling and don’t have the iPad with me to test at the moment.

Hi Jessica,

If you were using the iCloud sync feature in mSecure, what you are thinking of doing here on your iPad is a great idea. I would start with trying to install the old app on your iPad, which you will have to do by going to your list of purchased apps in the App Store app. After it's downloaded, go to the Sync Settings, and set up iCloud syncing. If data is stored there from the app that is running on your iPhone, then hopefully it will sync over to your iPad.

Where can i find my old data please

Connexion ou Inscription pour poster un commentaire