Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

File Attachment Limit

Please remove the limit on file attachments - with mSecure 6.1 we have the welcome addition of being able to store any type of file as an attachment but unfortunately a limit of 5 files has been introduced.

2 people like this idea

Hi Ben,

Thank you for the extra information. What you're describing is not supposed to happen. If it were your account running up against size limitations, which aren't applicable to photos, you would see a message telling you the limit was met. Something else is happening here, but this is the first time I have heard it reported.

If you were to create a brand new record and try to add a photo as an attachment, does it let you add it?

I tried that too. I created another entry and tried to add a photo and same thing happens. The application would seems to do it but then the file is not attached.

Hi Ben,

I talked to our developer about this, and he's not sure what's causing the behavior you're experiencing with your attachments. We have a few questions for you, and I'm going to have you send us logging from the app as well.

  1. I checked your account, and it's showing you have more than 5,500 attachments in your mSecure account. Does that number sound right? It's no problem if it is, but it is a lot more attachments than we're used to seeing so we're wanting to confirm with you.
  2. After you save the attachment on a new record, when you go to look at the attachment again, is there any trace of it? What I mean here is, do you see a placeholder for the attachment, which would look like a blank square where the attachment should be, or does it look like nothing was added?
  3. I'm assuming this is happening on your iPhone, but I need to be sure about that before I send instructions for logging. Also, if you are running mSecure on a different device, do the attachments work on it?
Hi Mike, 1. 5,500 attachments seem like a high number 2. It looks like nothing was added . The square with the paper clip is what I see. 3. I have it on some iPads but I don’t use it that often.

Thank you for the followup on this Ben. I just messaged our developer about the new information you shared, and I expect to hear back from him soon. In the meantime, I'm going to have you get logging from your iPhone really quick. To do that, you will need to follow these instructions:

1. Open mSecure

2. Tap the menu button in the top left of the screen

3. Tap Settings

4. Tap Support near the bottom of the Settings screen

5. Tap "Enable Logging" near the bottom of the screen

6. Go through the process of adding an attachment to a new record, then after saving the record, view the details of it as if you were going to look at the attachment

7. Wait for about 10 seconds while viewing the record's details, then go back to the Support page in the Settings

8. Tap "Send Log" and send the email to ""

9. After you have sent the log, respond to this thread letting me know

I'll get the logging over to the developer for analysis after I receive it.

Login or Signup to post a comment