Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Can't Sync - Don't know how to change router

I sync only locally, using Wi-Fi, between my Windows 11 computer (Main mSecure sync device) and mSecure on my iPhone. All was fine until I changed routers. mSecure still shows the old router under Sync Status, and when I try to turn on the Main Computer option mSecure crashes. I've tried turning Sync Automatically off and back on but that doesn't change anything. How can I switch mSecure over to my new router?

Hi David,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. I'm not sure what's happening here, but I hopefully have a way to fix it. Real quick, I'm going to have you turn off syncing altogether, then I'm going to make a change on your account. That will hopefully take care of the problem. Go ahead and open mSecure's Sync Settings, and turn off syncing. After you do that, leave it disabled and let me know. After that, I'll reset the sync settings on your account and hopefully that will take care of the problem.

Okay, turned off syncing on both the computer and the iphone.

Ok, I reset the settings on your account, so I'm hoping things will work now. However, before you open mSecure on your PC, please open the app on all your other devices first, so they can figure out first that the account is no longer set to sync. After you open the app, open the Sync Settings and check to make sure that syncing is disabled. After you do that on all your devices, then open mSecure on your PC and turn on Wi-Fi syncing again.

Did that have any effect on the problem David?

Thanks for your help, Mike. Unfortunately this doesn't seem to work. Below is a screen shot of the Sync Settings after following your directions.  The Sync Status still says Not connected.  I've blocked out the IP and my email address for privacy.


Thanks for your help, Mike. Unfortunately this doesn't seem to work. Below is a screen shot of the Sync Settings after following your directions. The Sync Status still says Not connected. I've blocked out the IP and email address for privacy.


Hi David,

I'm not sure if this went the way I expected. It looks like you have an Asus computer running mSecure, which should be the main computer. What I was trying to do before is at least get things to where your computer won't crash when you try to set it as the main computer. Did the instructions I give you make it so that the app is no longer crashing?

Sorry if I wasn’t clear. It’s not the computer that’s crashing, it’s mSecure that crashes if I try to turn on the Main Computer switch. Yes, mSecure still crashes.

To be clear, I wasn't thinking you were saying your computer was crashing. My confusion is that I cleared all Wi-Fi settings from your account, and you are still seeing that the ASUS computer is the Main computer in mSecure's Sync Settings.

Real quick, do you have more than one PC, or do you have just the one ASUS computer? If you only have the one PC, do you see all your data in mSecure on your iPhone?

I have only the one ASUS desktop computer. It’s actually custom built but has an ASUS motherboard. My mSecure data in the phone from before the router change is still there and accessible, but I can’t sync anymore. Additions and changes that I’ve made to mSecure data on the computer are not being synced.

Does the lack of response mean you're out of ideas?

Hi David,

I'm not out of ideas yet! We'll get this figured out one way or another, even if I have to get the developer involved. From the screenshots, I thought you had more than one computer, because the Sync Settings aren't making any sense. Since they are saying your ASUS computer is the server, I was thinking the computer you are taking the screenshots on was not your ASUS.

Now that I know it's the same computer, I think simply reinstalling mSecure should solve the problem. You may have tried reinstalling mSecure before, but it should be different now because I reset the sync settings on your account. Before you do the reinstall, you'll need to go to the Backup Settings after clicking the gear icon in the bottom left corner and create a backup of your data. Click the gear icon, then click "Backups" in the left column of the Settings screen. Click the button to create a new backup and save it to your desktop. Now, click the start menu, then right-click on mSecure and choose the option to uninstall the app. After it's uninstalled, wait for about a minute and then reinstall mSecure from the Store app.

Did that have any effect on the problem David?

If it didn't fix the problem and syncing still can't be done between your devices, go ahead and go to the Backups Settings again, and choose the option to Restore. Choose the backup you created on your desktop, and restore it. After I hear back from you, we'll keep on troubleshooting to get to the bottom of what's causing this.

Glad to know you're still with me :)

Well, that didn't work. I've attached two more screen captures. The first is with the Main Computer switch off, the second with it on. I've tried turning Main Computer on with Sync Automatically both on and off. No difference; the outcome for both is the second screen shot. Note that although Sync Automatically is turned on in both of the captures below, in the left column it says Sync Method: Don't Sync. (The Sync Automatically switch disappears when Main Computer is turned on; I assume that's by design.)



Hi David,

I'm not sure what's happening here, because now your account is showing that you don't have syncing enabled at all. However, in both your screenshots, it shows you have set Wi-Fi as the sync feature to use for your account. I wonder if it's possible I'm looking at the wrong account.

First, can you confirm that Wi-Fi syncing is currently enabled in mSecure's Sync Settings on your PC? If it is, can you tell me what email address you see in the Account Settings? If you don't want to write that out here in the forum, please send and email to, then post here in this thread letting me know you sent it. I'll respond via email as soon as I see it in the system.

Mike, I didn't remember turning sync off after my last try, so I checked it this morning and found it was off. I turned it back on, including trying to set my desktop as the main computer. As soon as I leave the settings and then go check it again, it has turned itself back off. Or if I just exit the app and then start it again I also  find that it's off. Either way, I it still shows server not available when I try to turn sync on. I've emailed you as requested. Thanks.

Login or Signup to post a comment