Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Totally lost.

Have been using mSecure for years.   All my account and app information and passwords are in mSecure.  It was simple, reliable and provided everything I needed.  Create records, keep track of account information and passwords securely, change fields when necessary.  Now I can’t make an edit, can’t get help and am totally confused.  Very concerned I will not be able to take care of personal business unless I can get all my info out of mSecure.  Think I have version 5,  never had an account password as far as I know.  Just a password into the app and my info.  How do I get functionality back?   


Hi Bob,

I'm not sure what's happening here, but I'll help in any way I can. One thing to mention, I deleted the other posts in the other threads to keep our correspondence here in this one thread. That will make it easiest for me to keep track of all the information you provide.

First, have you been using mSecure 5 or mSecure 3/4 over the past few years? mSecure 6 was just released, and it sounds like you downloaded that new version of the app just recently. If you were using mSecure 3/4, mSecure 6 will show no data unless you choose to import it during the account set up process, and that only happens when you are creating a new account. Your mSecure account was created way back in March of 2017, so I'm pretty sure you wouldn't have got the opportunity to import your data. It's no problem, because it's very simply to import data from the old version of mSecure in v6, so I just need to know which version you were running before.

Next, when you say you have lost access to your records, what does that mean? Are you saying you can't open and unlock mSecure any longer, or are you saying you can't see data after you open and unlock the app? Those two problems are very different in nature and require very different methods of troubleshooting. What do you mean when you say you have now lost access to all your records?

Lastly, do you have access to your information in any version of mSecure on at least one device?

Mike: THANK YOU!   FYI, I am over 80 and not really tech smart.  Just try to understand 

Glad you deleted all other posts. Will make things easier. 
I think I am mSecure 5.  I started with 3.  I , as far as I , know have not down loaded 6.  Down loaded the others, over time via the Apple app. Store.  The data seemed to migrate from one version to the other    

I have never created any new accounts.  

I only create “records” with the pertinent data: enter name, account no.. password, phone numbers in some cases.  Only changes I make is to edit passwords when I change them or phone numbers/account numbers. 

I think I am on V 5.  Can’t say for sure.

This morning I could see my records, even though the format looked different.  I tried to edit a password.  It would allow me to change the password but there was no save option.  

This afternoon NO records were showing and I didn’t see any way to get the list.  I tried every button and icon.  Right now I can not retrieve any records, account numbers or passwords. I see a format, no data. 

Really hope you can help. MSecure has been my password repository for a long time they are not written down any where. 

Thank you 


Mike: just logged in on my iPhone again.   A screen came up that has the heading “Edit Record” it’s one of my entries showing.  Have never seen a screen like that before. Usually a listing of my records appears that I can scroll through and pick the one I want.  Have no idea what to do with this one and didn’t want to lose it.  Not pushing any buttons.  Don’t know what I should tap anyway.  

Mike! Are my replies reaching you.  They don’t appear on my screen.  

Mike: Don’t see my answer to your questions.  Let me try again. 
I think I am, was, running V 5.  Down loaded versions from App Store as they changed over the years.  Data always migrated from previous to new versions.   Have done nothing, that I am aware of,

 pertaining to V 6.  

This morning logged in to edit a record, password change.  Screens looked very different.  It allowed me to change the field, but no “save” button.  Could not view list of records in my app either.  None of the buttons looked familiar.  Format different  I can’t see data, list of records, after I unlock and open account. 
can see a “Edit Record” screen on the iPhone, but nothing else. 

Hi Bob,

One thing to mention, I won't be able to respond to your replies immediately. Depending on other responsibilities I'm working on, I could get back to you very quickly throughout the day, or it might be only be a couple times in a day. I will try my best to get you through the issues you're dealing with as quickly as possible.

After checking your account, I can see that you have downloaded mSecure 6. You may not have mSecure 6 on all your devices, but you have downloaded it onto at least one of them. This means you'll have to download mSecure 6 onto all your devices moving forward, but we'll worry about that later.

For now, it appears that you able to open mSecure on your iPhone and that you able to edit a record. That's great news. The first thing I'm going to have you do is check the version you are running on your iPhone. To do that, open mSecure and enter your password or use Touch/Face ID to unlock the app. Once in the app, if you see the "Edit Record" screen, tap the back button in the top left corner of the screen to go back to the main view where you'll see 5 icons in a bar near the top of the screen. You should also see a list of records, though if you have filters set, you may not see any of them. Now, tap the menu button (3 stacked lines) in the top left of the screen. After the menu slides in, tap Settings. In the Settings screen, scroll down and tap "About mSecure." What version does it say you are running?

We need to take one device at a time, so please don't worry about what's happening on other devices for now. We'll get those in time or as needed. Since it looks like you're able to use the app on your iPhone, this device is the best place to start.

Login or Signup to post a comment