Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Change Password

I went through the support portal and I was able to get the following note "Password successfully updated" I tried to sign in,but it doesn't accept the password. Please Help Thank You

1 person has this question

Hi Catherine,

I'm not sure I understand what you're saying here. Were you trying to change your password, and if is so, did you do that from inside the mSecure app? I checked your "" account, but I'm not seeing that a password change was completed since July of 2017. Are you sure you weren't changing the password for your support account? If you were, your support account, the one you use to sign in to post on the forum, is not related to your mSecure account in any way, so changing that password won't help with the mSecure app.

Are you trying to open the mSecure app on one of your devices, and are you not able to? Please explain to me why you are posting in the forum, and I'll try to help in any way I can.

Yes, I need to find a way to open my account My old phone (Samsung) died and wouldn't charge. I got a new phone. I now need a way to open mSecure 6, As you noted, I have been using mSecure since 2017. I don't wish to lose my info. Starting over would be major undertaking. If you can see my account, please help me. I tried using the original password, but for some reason, I don't know, it's not accepting the password I have been trying to get this worked out for a week,now. PLEASE, PLEASE, PLEASE,Help.. You may call me, if you wish

Hi Catherine,

Unfortunately, we don't offer telephone support at this time, but I am happy to help you here in the forum.

There's no way I can check to see if the password you are using is correct or not. Also, we don't ever get access to our customer's passwords, so there's just no way I can verify or retrieve your password. If you still have access to your old phone, are you able to use it when it's plugged into a power source? I know it won't charge, but if it's plugged in, are you able to turn it on? If so, plug it in and turn it on and try to open mSecure.

Are you able to turn on the phone when it's connected to power and then open mSecure?

I did a RESET. I had to face the facts and move on. Now I'm trying to rebuild the information base. It may be slow but I have most of the payment email, and Google has most of the passwords, so I should be able to reconstruct most of the information. Thanks for trying to help me!!!.
I gave up and did a RESET. Thanks for your help!!!

I'm sorry I wasn't able to help you get your data retrieved Catherine, but it is good to hear you were able to get everything reset to start from scratch. Thank you very much for your time, and please let us know should you need further assistance.

Login or Signup to post a comment