Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Msecure keeps crashing at login with new Macbook

Unable to login on freshly installed msecure desktop app (downloaded from the Mac App store) on new Macbook Air M1. I am asked to enter email & password (touch id is not an option yet), and then msecure crashes as soon as I enter the password.

I recently bought two other new Mac computers (Macbook pro 16 & Mac Mini) and did not encounter this problem on either machine.

Now I wonder if there is a limit on how many machines I can install the app?

Hi Nikolas,

There is no limit to how many devices you can have signed in to your account, so that's not the problem here. Since everything is working on your other Macs, I'm going to have you try doing a simple reset of the database to see if that will fix the crashing.

To reset mSecure on your Mac:

1. Open mSecure on your Mac, and look in the top left corner of your screen. You should see "mSecure" in the menu bar. To the right of "mSecure," you should see the word "Help." You'll click on that in step #2 below.

2. Click Help in the menu bar at the top left of your screen. A contextual menu will appear. Hold down the "option" key on your keyboard, and you should see two hidden options appear at the bottom of the contextual menu.

3. Click "Show Data File in Finder", and a Finder window will appear revealing mSecure's database file, which is named, "mSecure.mscb"

4. Close mSecure

5. Move the "mSecure.mscb" file to the trash

Now you have reset the Mac app, and you're ready to sign back in to your mSecure account:

1. Open mSecure on your Mac if it is closed

2. Skip the welcome screens to go directly to the Sign Up / Sign In screen

3. Click "Sign In"

Enter your mSecure account's email address for the username, then enter the password for that account to sign in to it.

Did that have any effect on the problem Nikolas?

Hi Mike- thank you for the swift reply. I am not getting far however; when I click "Show Data File in Finder" in the Help menu, nothing happens. No finder window opens, no "mSecure.mscb" file in sight. I quit msecure and restarted my computer, restarted msecure, tried again to reveal the database file but no luck. Tried to log into msecure again, same result: Spinning wheel, spinning beach ball and eventually need to force quit msecure.

Hi Nikolas,

Thank you for the movie of what's happening. I was thinking you were already signed in to your account for some reason, so since you haven't been able to sign in, that's the reason you're not seeing anything after clicking "Show Data File in Finder." There's no database file yet, so there is no where for the Finder to go.

Since I have never seen this happen before, can you try simply deleting mSecure, rebooting your Mac, and then installing mSecure again from the App Store app? I'm hoping this is an issue with the installation, and a reinstall will fix it.

If the reinstall doesn't fix it, can you confirm for me that everything is working correctly on your other devices? If you add a dummy record to mSecure on any of your other devices, does it sync over to the other devices?

Login or Signup to post a comment