Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

missing icons in records in German version 6.02


I noticed that in many datasets the icons (that were automatically taken from the url in V5) have disappeared in V 6.0x. If you now edit a data record, you will find two entries for the url: website and Webseite (german). If you now copy the url entry from the Website line to the Webseite line, the corresponding icon is displayed again.

There must be a bug by updating from V5 to V6. Please correct.

Hi Martin,

I'm not sure what's happening here, but something has happened to cause your record(s) to have more than one URL field. I believe the reason the icon is showing up after you move it to the top field is because mSecure is only responding to the first URL type field in the record, so if you don't have data in that field, it's not seeing the url and trying to find the site icon to apply to the record.

Can you explain how the record looked before the upgrade to mSecure 6? In the screenshot, I can see the other field labels are in German, which makes sense, but it also looks like the field label from where you originally took the url is in English. I think what happened is when the data was upgraded, mSecure saw that it was a Login type record, and it added the Login template fields to the record. Did you only have a field named "Website" in that record in mSecure 5?

Hi  Mike

Ok , I understand: If its the first line in the record, mSecure may take the icon from the website. So I have to control in each record, that the url field filled must be the first line...:(

I can't remember if in mSecure 5 there was one or two fields, one in English, one in German. But I remember not having this issue.

What I remarked additionally: there are records only with one url field in English "website" and there are others with two url fields, one as first, one as last. In these ones with one url field it's the English word.

Meanwile I took a look at e few more of my records, and I saw that only these made in mSecure 6 have both url fields in German and English language. The other ones build in V5 have the url field label in English language. But: If I do new one tonight. I get only the url field in German language... I can't understand it.

Ok, that's a little detail only.

I got a answer to my first question. Thanks.

Hi Martin,

I totally understand your confusion here. This is not something I foresaw as being a problem in the new app. Did you by any chance change the template being used for any of those records? What I think might be happening here is when the template is changed, it looks through the fields in the current template for the record, and then if the field of the same name exists on the new template, there will only be that one field with the data in it. However, you have a field that has an English name, which is a different spelling than the German name, of course, so if there's a new template chosen, the field isn't matching, so a new one is created. This would account for what we're seeing, but I don't know if it's the actual cause of the behavior. 

This is really strange behavior that I'm going to have to keep an eye on as we continue development. For now, I think the best to do would be to check your Login template to make sure the fields are named correctly, and that the correct fields are actually present for future records you create. That should at least take care of the problem as you continue to use mSecure.

Hi Mike

There's another oddity: a few of the records taken over from V5 have another icon than the others if the url presents no own icon:

1) german: "anmelden", translatet in english: register (red round icon)

2) german: "Anmeldung", translatet in englisch: sing up (world icon)

If you do a new record, the suggestion is "Anmeldung"

See the attachment, please.

If I want to have always the "world-icon", I have to change in each record the word "anmelden" in "Anmeldung"

and it goes further...

If I change from "anmelden" to "Anmeldung", mSecure 6.02 add a new empty line called "Webseite" in the existing record as first line, the other existing line called "Website" wich was the first line before is now the last line. So I have to copy the content of the url field from the last field to the first field in each such record...

Hi Martin,

What is happening in your last post is what I tried to describe in my last post =)  The "anmelden" template has a field in it called "Website," which is in English. Your "Anmeldung" template has the field "Webseite," which should be the same word in German. Since those words aren't the same words according to mSecure, when you change the template, that field is simply getting retained after the change is made. If the field in the "anmelden" template was named "Webseite," then when you changed the template for the record, you shouldn't see two URL type fields. The resolution of the fields is first based on the name of the field.

Real quick, can you look in your template editor in mSecure's Preferences and try to find the "anmelden" template? What does that template look like?

Hi Mike

there isn't a template named "anmelden" in V6. Unfortunately also my son has updated to V6, so I can't get a lock, if in V5.x there's an template named "anmelden". Fact is, that in V6 there is only a template named "Anmeldung" and all the records with the first line (url) named "Website" doesn't correspond with the template in V6.

I suggest, that's a problem of database import from V5 to V6 in German version.

Look at my print screens.

Instead of changing each record of the type "anmelden" to "Anmeldung" (I dit 67) may be I would better have changed the template "Anmeldung" to substitute the field "Webseite" to "Website", and the problem of the wrong icons would have be away...

Ok, I also know it's a detail, this problem. The dbase of mSecure 6 is working fine, the synchronization also is working fine... that's the most important.

This is a very strange issue, because there should be no way to see a template on a record that doesn't exist in the template list in the Preferences. Is it possible the Anmelden template is further down the list in the Templates tab of the Preferences? In your "msecure8.png" screenshot, can you go to that place on your Mac again and then hover over the list of Templates and see if you can scroll down? Are there other templates below the "Kombinationen" template?

Hi Mike

There is no template "anmelden", also if I scroll down to end of the list.

Oh, wait a minute. I think I know what's happening, and I think you were trying to point it out to me with your arrows. If you create a new record and choose the "Anmeldung" template, does it show up as "Anmelden" under the record's title in the details screen?

Hi Mike

I have now done this with the dataset "test" by using the template "Anmeldung":  The correct "Anmeldung" appears.

Yesterday evening I changed 278 records manually replacing "anmelden" by choosing the template "Anmeldung"...

I have now asked my son, who has also updated from the 5pro version to mSecure 6, to see how things are with him. His old "Anmelden" records are all displayed correctly, and the world icon hasn't changed to the red one. The first line (url) is called "Website", also in his template.

So the whole thing gets even weirder: We have a different template called "Anmeldung": for me the url field is called "Webseite" in German, for him it's called "Website" in English.

My son uses mSecure from version 5, I've been using it longer and have already migrated from previous versions. Maybe that's the reason for the differences.

Even if we haven't solved the riddle yet, for me the matter is closed. Everything else works fine.

Thank you very much for the update on this Martin. While I still don't know exactly what's happening, I do think it's somehow related to a mixup in the translations. I believe it comes down to me not understanding exactly how the translation data is stored for the templates, and if I knew that, I bet I could figure it out. Like you said, though, everything else working as it should, so I'll just keep this on my radar in case we get others reporting something similar.

Thank you very much for your patience through this, and I am sorry you had to go through the process of changing your records. Please let me know if you need further assistance with the new app.

Login or Signup to post a comment