Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Msecure 6 / Windows 11 / no entries after upgrade

 I have a really serious issue I already reported to msecure Tech support and I'm curious to see if other people experienced this.

What happens is :

-When clicking on “All Items” there is no record displayed. Not sure if it's useful, but first time when I open mSecure, there’s no count for any of the entries. After I click on recents, the counts update and I have ~650 entries here.

-search is not able to find records

-the only groups which seem to display entries are: recents and deleted items


I’m using Dropbox syncing, and my account, has previously bough a license for mSecure 5 and was therefore transitioned to an Essentials subscription in mSecure 6.

Hi Vladimir,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. I may have dealt with something like this with one other customer, but I can't be sure. Before we do anything to troubleshoot of fix this, can you let me know if you have mSecure installed on another device, and if so, do you see all your data on that device?

 Mike, thanks for answering. Since I'm relatively despaired, I opened ticket 86625. I however doubt that I'm either explaining correctly, or, there are lots of messages in your TS queue, since the answers I received there are not exactly helpful (suggestions that I experience slowness, which are incorrect). Might want to chech that ticket, but meanwhile, the answer to your question is that yes, I do have Msecure installed on Android, and I see data there. However, I believe this is true because I disabled auto-updates on PlayStore, and that version is still version

Also note that I won't update on Android, since that's now my only source of paswords.

Other points of interest:

-with Msecure (latest available in Microsoft Store now) importing the Android Msecure 5 backup files finishes without error, technically speaking, but the entries are not visible, as it was when I upgraded

-since Msecure Android does not have any export as CSV feature, and on internet there's no reference on how to install Msecure 5 on desktop in Windows, I'm really locked dead now, with almost zero options. I'm saying this because I wanted to export my passwords to import in another Password Manager, but, as it seems, no way to do that.

I am not a conspiracy theorist, or fan of crazy theories, but because this bug and the choices seemed to have been made regarding not having previous versions downloadable, my data is really hostage to your app :D

I really hope via the support ticket mentioned above, or via this forum post I'll be able to recover an export of my entries, otherwise I'll take one day off from work to manually migrate via copy paste my password entries, all 657 of them :(

Hi Vladimir,

I can assure you that we're not holding your data hostage. We would never do that, because it would do nothing but hurt our business. You would have to take me at my word on this one, but even if it did help our business in some way, we would not do something like make it impossible for our users to get to their information. All it would do is erode trust in our company.

Now on to the actual issue, unless I'm misunderstanding someone else's or your post, I haven't heard of this issue yet, and I'm hoping it's a very simply fix. When you look to the right of "All Items" in the top left of mSecure, what number do you see? Does it match the number you see in the top of the menu of mSecure 5 on your Android device?

Hey, not saying you decided to do this, as it would be really absurd, just the fact that effectively I can't transfer currently my data from msecure to any other app and it looks like keeping the data hostage ;) However I realize that hostage would means that you have a gain, so I apologize for the poor choice of words.

The answer is yes, in both Android version 5 and Windows version 6 I have the same password count, 657.

Ok, this is good news, because it looks like the data is there in mSecure on your PC. Is it possible you have a filter set in the app on your PC that's hiding your information? The first thing to check would be if the Favorites filter is turned on at the top of the middle column. We have a lot of customers who have that enabled and no data is displayed. If that's not the problem, just under the search field, do you see a Tag or a Template displayed with an X to the far right? If you do see that, that would mean a tag or template is set a filter, and that could be causing your data not be displayed as well.

Let me know if either of those things helped, and if not, we'll continue working on a solution.

 Coming back to close this thread.

Somehow, after clicking the favorite button, which was not activated, the records appeared.

I think it's a bug of sorts, because the favorite button was not enabled in the video I sent, yet the records were invisible.

Frankly, I don't understand why this happened, but your suggestion did help, so thank you!

You saved me from a disaster

Hi Vladimir,

It's good to hear you're seeing your records again, but I think we need to investigate this a bit further, because if the favorite filter wasn't on, you definitely should have seen the information in the app. When you close and then reopen mSecure on your PC, is the data there right away now, or do you have to click on either the favorite filter or a different filter in the left column to make it appear? Also, if you changed data on another device, is the sync taking place successfully?

Hi Mike,

Answers below:

When you close and then reopen mSecure on your PC, is the data there right away now, or do you have to click on either the favorite filter or a different filter in the left column to make it appear?

Answer: Now I see the data in Windows mSecure build 242 right from the program start. Previously to clicking the favorite, I always started from zero, then clicked on one of the quick filters, and only then the count updated also on All Items. Note that this did not seem to be a time-bound operation: started the app, waited some good seconds, the count did not update, then when clicking on the quick filters, the count updated. This behavior happened on both 239 and 242.

Also, if you changed data on another device, is the sync taking place successfully?

Answer: when changing on Windows, and looking after that on Android, the first time I opened the Android app, what I presume is the sync icon on the bottom left part of the screen started spinning for at least 1 minute, then I did not pay attention to it, and I saw that the changes I did on Windows did NOT sync on Android. After triggering the sync manually on Android, I received the changes. Tried doing another change in Windows, then Android remained at the "syncing data..." stage for something between 2-5 minutes. After finished, I was able to see in Android the changes I did in Windows. Network connectivity should not be an issue, as I tried WiFi and 4G. It looks like that "syncing data..." stage took far more than before.

Hi Vladimir,

I don't like what's happening here. The syncing with simple changes should not take this long to sync. For Android, it shouldn't take more than a few seconds, since it receives push notifications. For Windows, it should sync within a couple minutes of the changes, since it sync via a timer. If the app is closed when the changes on another device are made, then the changes should be synced in very quickly right after opening the app, so having to wait like you have been isn't right.

Are you ok with going through a reset process to see if that helps the issue?

Login or Signup to post a comment