Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

mSecure keeps crashing on my MacBookPro

Avid user, love the app, use it across all my devices.  Became unstable on my Mac this week.  mSecure 5 Version 5.7.2 (165), MacBook Pro, 17 in Late 2011,  High Sierra Version 10.13.6.   Nothing new installed recently.  I've tried uninstalling and reinstalling the mSecure app.  Opens fine then craps out before sync ends or initiate a sync and it craps out, or do a find and it craps out.....   Followed some older discussions and tried deleting all the backup files on the iCloud drive.  didn't solve the issue.  Any hints to a possible solution would be great.

Hi Timothy,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. I tried looking up your account on our server, but. I wasn't able to find it searching with the email address you use here in the forum. I'm assuming you are using either Dropbox or iCloud syncing, but I can't be sure. Can you open the Sync tab in mSecure's Preferences on your Mac, and tell me which sync feature it shows you are using?

Also, on your other devices are you able to open mSecure, and if so, is it crashing on them, or are you able to view your information on at least one of them?

MSecure account is using email all sync via mSecure Cloud Working fine on the multitude of other devices.
Different email for mSecure: All sync via mSecure Cloud mSecure Is working fine on our multitude of other devices. Unable to verify sync method on described MacBook Pro, mSecure crashes in open during initial sync or immediately if I try to open preferences or perform any kind of task.

Hi Mike

I am just having issues on the one MacBookPro.  Since all the other devices are working excellently I would like to just remove and clean install the app back on the macBookPro.  Is there a procedure to accomplish removing the local copy of mSecure so a newly installed copy will login in and pull all new data from the mSecure servers?  

This is also the 3 time I've responded to this topic and I still do not see any of the previous responses.  I'll attach a file to this post just to see if that changes the outcome.

Hi Timothy,

I'm not sure why, but there are other posts you wrote that have to be approved before they get posted. I just approved the other posts now, so I'm hoping it won't happen again.

I'm going to send you instructions for resetting mSecure on your Mac, and then you can sign back into your account to see if that fixes the problem. However, I think something else may be causing this to happen, so if it does keep crashing, then we'll try other troubleshooting.

For now, you can reset the database file on your Mac using these instructions:

1. Open mSecure on your Mac, and look in the top left corner of your screen. You should see "mSecure" in the menu bar. To the right of "mSecure," you should see the word "Help." You'll click on that in step #2 below.

2. Click Help in the menu bar at the top left of your screen. A contextual menu will appear. Hold down the "option" key on your keyboard, and you should see two hidden options appear at the bottom of the contextual menu.

3. Click "Show Data File in Finder", and a Finder window will appear revealing mSecure's database file, which is named, "mSecure.mscb"

4. Close mSecure

5. Move the "mSecure.mscb" file to the trash

Now you have reset the Mac app, and you're ready to sign back in to your mSecure account:

1. Open mSecure on your Mac if it is closed

2. Skip the welcome screens to go directly to the Sign Up / Sign In screen

3. Click "Sign In"

Enter your mSecure account's email address for the username, then enter the password for that account to sign in to it.

That solved my issues on the MacBookPro for now, THANKS!  

THOUGHTS, that particular mac of mine seems to have issues with mSecures attached picture files.  I think it's either or both my attached picture format/size.

Again, love your product, keep innovating and THANKS!!!

Hi Timothy,

It's great to hear that solved the problem. If the app does start to crash again, let me know, and we'll get it fixed.

Regarding attached images, I don't know what could be going wrong. What do you mean when you say it seems to have issues? Also, where are you getting the images you are attaching to your records?

Hey Mike 

In the past, earlier versions of mSecure I've run into a similar crashing issue on that same MacBookPro.  Meaning the crashing would begin after attaching a big (typical iPhone photos as they got bigger and bigger) as compared to a little old jpg file.  I believe my workaround back then was to convert everything to a small size jpg before attaching.  You've long fixed that issue.  But looking at similarities between now and then my guess is something possible an attached pic to the mSecure record is corrupting the db or it could be being corrupted just as easily by the mSecure sync trying to play nice with all the other various googledrive, onedrive, iCloud syncing going on..  who knows.....I'm just guessing.  Anyhow that's why I've always got an extra copy of mSecure on an alternate device and some smart helpful people at mSecure to fix me up when things go astray.  THANKS AGAIN!

Ahh, I see. Thank you for the follow-up on this Timothy. The only thing I can think of that might cause the problems you are encountering is if your iCloud account couldn't save a new backup file that might be too large for the amount of space it requires. This can happen if you are running out of space in your iCloud Drive, but it is a very rare occurrence due to the space allotted in iCloud Drive. Do you happen to know how much free space you have in your iCloud Drive?

Login or Signup to post a comment