Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Unable to validate my Account on my Windows 10 PC after computer reset

I recently had an issue with my windows 10 PC laptop where I had to reset the system and reinstall all my apps.  I reinstalled the mSecure app and I am unable to validate my account after the app reinstall..  I tried everything I can think of from resetting my password and nothing seems to work.  I am using the latest pro version 5 I purchased for many devices and I am  syncing over mSecure cloud.


Here is the issue.  When I installed the app it accepts my logon email address and password.  It then brings up the page “Account Key Required”.   Apparently, it isn’t recognizing “mSecure.msecurekey” on my iCloud drive automatically.  Not sure but from what I read that feature doesn't happen on the PC.  I do have an iCloud drive installed on it. 


So here is what I have tried.


1. I have tired Import Account Key File.  It brings up a window to redirect me to my file folders on my PC.  I then navigate to my iCloud drive and select my “mSecure.msecurekey” file.  I then get the following message.  “Authentication failed  The account key you chose is not able to authenticate you as the owner of this mSecure account.  Please select the correct account key to finish signing in to the account”   I have tried this many times even after changing my password.  I even tried to uninstall and reinstall the app several times with no luck.


2. Next  I tried the second option.  “Import Account Key from Clipboard”  I do exactly like the instructions ask and copy my “Encrypted Account Key” from my email after I send it from another device using the account.  It doesn’t work as advertised going for what is copied and it also directs me my folders on my PC like the first option.  I even tried saving the encrypted key and/or QR code as a jpeg and png and selecting that file.  No luck.


3. Finally I tried “Use Camera”.   Each time I get “Invalid account key”  “The QR code that was scanned failed to authenticate you as the owner of the (my email) mSecure account”.  I have other devices working fine with this account.  No issues on those other devices.  I tried sending out a new email and even changing my password.  Everything works fine on my other devises.  Yes I am using the new key from the password change.


Any help you can give me I would appreciate it.  I am frustrated on my end after spending days on this issue. Please help thanks.


I see from the thread below this issue might be already being addressed with a new release of build 143.    Bad timing I guess on my part to do windows reset.  Hopefully the new release will fix the authentication issues.   I really like the product.   Sorry for starting a new thread as I should have read more through the forum topics first.   I'll let you all know when and if the new version fixes the inability to authenticate on my Windows 10 laptop. 

Hi Geoffrey,

Everything should be fixed in version, which should be in the store now. Go ahead and open the Microsoft App Store app on your PC, then go to your Library and click the Get Updates button. That should download the new version where you can authenticate your account. worked great!   No problem authenticating now.   Thanks for getting back to me and thanks to  mSecure personnel  for resolving the issue so quickly.  

Thank you for the update Geoffrey! It's great to hear everything is working again!

my problem is same but the version I am using is 5.1.151

please provide help for activating this app on my PC

Hi Vipin,

I'm not sure what's happening here, but you shouldn't have any problems authenticating in 5.1.151. Can you explain in detail what is happening when you try to authenticate? Does your device have a camera, and does it tell you the authentication failed after scanning? If you have tried to copy the encrypted account key onto your clipboard, what happens when you click the button to import the clipboard data when authenticating? 

Also, do you have any other devices running mSecure 5 that are signed in to the same account?

I am also having an issue authenticating a new windows desktop which does not have a camera. 

I do not use the cloud so the authentication info is not available there

The authentication PDF does not allow me to copy the key from it and when I click on the QR code, I can only copy it (not save it). But when you click on the clipboard option it instead navigates to open files, but my saved PDF file does not show up in the list of documents to choose from, even with all file types selected. It is definitely there when I just go to look at files.

I have tried resending the authentication email from another device, but it is just the same. 

Please advise how I can authenticate on the new device.

Hi Carol,

You should have no problems copying the data below the "Encrypted Account Key" title in the Authentication Email. The data will look like a bunch of gibberish, which is your account key that's encrypted with your mSecure master password. Start the selection right at the first character of that key then end the select on the last character (if extra characters or spaces are included, it won't authenticate). Then in mSecure, when prompted to authenticate, click the option to "Import Account Key from Clipboard." The steps are mapped out in the video under "2. Import from Clipboard" in this article:

Login or Signup to post a comment