Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Autofill fails to find account when going through app/website


I dont think this is only on iOS (i'm using latest 13.1.3) but right now i'm only using iPhone 11 so that is where i have this problem which is really causing a big problem for me.

Basically i just yesterday created a new record for my app in mSecure. 

Now when i go to the app and press the password it brings me to msecure and shows 0 record found. 

Even if i search i can not find the account i added. Why is that?

BUT if i open mSecure manually and search the account is found. 

I have this issue more and more now. Many sites i visit behave like this too. 

See the attachments. 

Anyone else having this issue? 

Hi Reza,

Thank you for contacting us and I'm sorry about the issue you are experiencing. In order to use our AutoFill feature, you must either use our Login record types for your records or the record type you use must include a URL, Username, and Password field. You can also manually add these extra fields in your individual record. Without these field types, our app will not consider a record to be a login type of record and it will not be included in the AutoFill options.

For example, to fix your "Ledger Live" record, you have two options:

Edit the field type to include the required fields:

  1. Open and unlock mSecure 5
  2. Tap the menu icon
  3. Tap Settings
  4. Tap "Edit Types"
  5. Select the record type you are using for your record
  6. Edit the record type to include a URL, Username, and Password field type
  7. Save your changes

Note that you don't have to fill in the URL and Username if your record type has those fields. Just including those field types will let our app know that these kinds of records are to login somewhere.

Edit the record directly:

  1. Open and unlock mSecure 5
  2. Find the record in question and tap the edit option
  3. In the edit window, tap "Add field"
  4. Add a "URL field"
  5. Give the field a title or label and add a URL (
  6. Tap "Add field" again
  7. Add a "Username field"
  8. Give the field a title or label and add a username
  9. Save your changes

Either option will allow you to use your record to AutoFill your information using our AutoFill feature. Also, please note that adding a URL for the record does help our app identify or associate the record properly. 

Hi Eden,

Thanks for getting back to me. 

I just checked and i already have all the needed fields


For my record:


And even if i have the URL it does not work! I cant remember which of the sites i have this issue with but will update once it happens. I always have URL for the records i add.

So why does the above dont work?

Also why cant i search when it switches to mSecure? That is even worse.  I should always be able to search for it.

The whole search is very inaccurate! Like i have my gmail accounts saved. If i search gmail which i clearly use in the title mSecure do not list it first. first. I have to look among 100 records which use the gmail in the email field. Why does mSecure dont prioritize the Title first? 

Hi Reza,

As previously stated, if a record type doesn't have the three required field types, it will not be included in the AutoFill feature. Your "Phone App" record type looks good on your Windows computer, but perhaps you are using different mSecure accounts on each device or have several different "Phone app" record types? 

We've tested this and this always works:

Here's an example of a random custom record type I created:

Note that I added a bunch of extra fields just for the heck of it. The important field types are the ones I labeled "Website," "Username," and "Password." I then created a record for this "Other" record type and only added a title and password to it like you have:

Now, when looking for records in the AutoFill feature, this record shows up:

I am for sure using the same account. Thats the reason i bought mSecure to use it on all my devices.

And i have for sure all the fields as you said on the phone since its the same record.


I'm glad it works for you but it does not work here. Did you try with the real Ledger live app? 

I did not try it with the real Ledger Live app. Unfortunately, I'm not sure which app it is. I'm guessing it's this one: 

However, I don't know how to use it. It doesn't seem to have any standard login or sign area and seems to rely on importing info instead? 

One thing we can try is disabling and re-enabling the AutoFill feature to see if that fixes things here: 

  1. Open the Settings app on your iOS device running iOS 12 or 13
  2. Scroll down and tap "Passwords & Accounts"
  3. Tap "AutoFill Passwords"
  4. Under "ALLOW FILLING FROM" disable mSecure
  5. Wait a few seconds and re-enable the feature

That will refresh or re-do the list of records in the AutoFill section. Try using the Ledger Live app afterwards and let me know if your problem remains. 

This is how the login looks like (attachment). I did what your asked and it's a improvement. It still don't find it automatically but I can find it when I search.

Hi Reza,

I'm glad that disabling and re-enabling the feature improved things for you. The only way to have the AutoFill option automatically find the correct record is to provide a URL for that record. The URL for that record should usually (90% of the time) be the name of the app. So if your app is called Live Ledger, add a (I know this isn't a real website, but it's the name of the app so it'll work) URL to your record and mSecure will know to associate that record with the app or website. Alternatively, mSecure should ask you if you'd like to update the record and associate the record with the website when you find it and selected from the list of records in the AutoFill section. If you do that, mSecure will automatically update the URL for the record for you.

Thank Eden, I will try that trick.  With this info i am happy with the solution. Thanks!

The other problem i mention is the way search work in general. Somehow i think the search is not really working correctly. 

As an example i have saved my google email account in mSecure. The Title is "Gmail reza". 

If i search for that mSecure list 30 items where the real record with that exact Title is in the end of the result list. 

All other items have withing them the login as but not in the title. 

So why does mSecure not respect the title of the record as first priority?  

Its good that it can search for other fields and list them but it should not mix the result. For now i have a trick where i but like 444 in the end of the record to be able to find them but this is a workaround only. 

Any update Eden? 

Hi Reza,

I'm sorry about the delay in my reply. You are correct that mSecure does not prioritize record titles. When searching, mSecure simply show any record that contains all or part of your search. In your example, I would simply name your record "Google Reza" and that would make the record much easier to find. Provided that you don't have a lot of other records with "Google" in the title or fields. We understand that this isn't ideal and are working to be able to provide more advance search options and search filters in the future. 

Hi Eden,

That is exactly what i do now but its getting annoying when you have hundreds of records and the list grows when you search. Its fairly simple to divide the result in 2-3 or whatever part based on result. I remember doing it even back in the days when i did programming. 

Hopefully this gets done soon. I havent seen any major update for a long time so maybe you guys are working on something...

Thanks for the help Eden . We can close this now i guess.

Login or Signup to post a comment