Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

I reset password and followed all the steps

Hi I followed all the steps to delete account data in order to reset the password.  I removed the app for Mac then installed it again and the app does not recognize my new password.

2 people have this question

Hi "talk to a real person",

After resetting your mSecure account:

  1. Reinstall mSecure 5 on all of your devices
    • If using a Mac computer and previously signed in to your account, please follow these steps as well:
      1. Open mSecure 5
      2. Click the Option button on your keyboard
      3. Click Help in the top menu bar
      4. Select the "Show Data file in Finder" option
      5. Close mSecure 5
      6. Remove the mSecure.mscb file (move it to the trash bin or click command+delete to remove it)
    • If previous using iCloud or Dropbox syncing:
      • Delete the data.mssb sync file
        • Dropbox (Dropbox/Apps/mSecure 5/accountID/data.mssb)
        • iCloud Drive (iCloud Drive/mSecure/accountID/data.mssb)
  2. Sign in to your mSecure account using your new Account password and proceed with the on-boarding process to start using mSecure again.

did this and it does not recognize correct password and email I am cutting and pasting.  my iPhone has username and password correct but not working on any of my other devices even when signing in the first time.


Try inputting your information manually without copy/pasting the information. Also, I don't understand what you mean when you say that your iPhone has username and password correct but not working on other devices. Does that mean you have access to mSecure 5 on your iPhone but not the other devices? Perhaps you are not using mSecure 5 on your iPhone? I'm not sure.

My wife’s MacBook Pro using macOS 10.14 suddenly stopped working with username and password. So I went onto my iPhone and the Face ID allowed me to continue to use mSecure using version 5.6.4. I know I have the right password because I went into change password on my iPhone because when I cut and paste did my same password it said you cannot use the same password. So I know I had the right password. The Mac computer wouldn’t work! I reset my password and deleted the mSecure apps and started over again when it asked for my username and password it wouldn’t work! I reset my password three or four times and for whatever reason on the fourth time when I deleted and reinstalled the Mac after deleting the.MSB i’ve only thing I could think of is I got the fresh username and password to sign in and instead of looking at the intro I hit skip intro and then my fourth new password worked. So I reinstalled and deleted on my other four devices and I’m back up and running but I really hate do you poor reset password system. Luckily my iPhone never stopped working and when I registered the four other devices I had a QR code from on my iPhone . The bottom line is when I was on my iPhone and I change my password my new change password didn’t work on the other three devices even when I delete it and start it over again
I did submit a support ticket But after trying to reset the passwords and I also reset my account I have no idea which step work and I hope the support ticket people might provide some additional insight

We have no real issues with our account reset process. However, it sounds like it is not what you should have been using. An account reset is only for when you have forgotten your account password, have no access to the app via Touch ID/Face ID, and(or) have lost access to your QR code. Otherwise, you can easily change the account password within mSecure 5 itself:

1. Open and unlock mSecure 5

2. Tap the menu icon

3. Tap Settings

4. Tap Change Password

You’ll have to open and unlock mSecure 5 on the other devices using your old account password, mSecure will then take you back to the lock screen, and you’ll then be able to unlock the app with your new account password. You'll have to follow this article if you have forgotten the old account password and are trying to use mSecure 5 on Mac or if you are simply having password issues on the Mac after changing the account password.

One of my 8 devices is still not excepting my password! It worked once but now when I try to re-login it says incorrect. OK I only went to the account reset process when I tried 4 times to change the password and I was able to successfully change the password with my iPhone using 5.6.4. However none of the devices when I correctly deleted everything was able to take advantage of this new password. So I did account reset. 

What is the maximum number devices I’m allowed to have? I’m still having trouble with one of my computers I hand typed in the username and password and it says incorrect! I have two iPhones, two iPads, 2 Apple watches, and 4 macs. That’s for a total of 8 devices. By deleting mSecure from all the devices except one successful iPhone I was able to erase the MSXB file and type in username and password for 7 of the computers and re register with a qr code. The 8th one I was able to successfully type password in and it said account activated and I thought it was weird it didn’t ask me for a QR code it said “authenticated“. 

Then this morning when I came back to that that computer the username and password says incorrect! This computer does not haveFace ID. So your comment about changing the password is very easy to do from my iPhone but the computer is not accepting the manually typed in password a second time! I am not using cut and paste. However last year hundreds of times I cut and paste it successfully so I’m a little bit irritated by that requirement or suggestion by you guys. I think one of the things that’s crazy is you change your password on one device 

But you have to make sure that you save the old password and login on the second device. But I was making sure I did that and it didn’t seem to work. I found that it was quite irritating that the password “hint “ text was not updating and when I change the name of the hint I see that my computers are not sync ing So I have my 8th device locked out. I successfully deleted mSecure and logged in with old and new password yesterday and then today it says incorrect! Locked out Mark (sent from iPad)

Hi Mark,

I'm really confused about things here. We have no limits on the number of devices you can use. I use about 20-50 devices (mostly for testing). I suggested that you manually enter your password simply to make sure there was no issue here when copy/pasting the information. It is not a requirement. Simply a way to try to eliminate possible issues. 

Unfortunately, or fortunately, what you describe as happening isn't something anyone else seems to be experiencing. I do not know the state of things for you here, but I think it might be good to do a sort of restart to see if we can figure out what is causing your issues here and fix it.

  1. Go through an account reset:
    1. Please note that an account reset will remove your information from our system and have you start over. However, it seems that it's best to do that in this case. We can always restore your information from a manually created backup file or one of the auto-backup files mSecure 5 creates.
    2. Make sure to manually input the new account password and password confirmation. Please double and triple check your inputs
  2. Uninstall mSecure 5 on iOS devices and do this on all Macs:
    1. Open mSecure 5
    2. Click the Option button on your keyboard
    3. Click Help in the top menu bar
    4. Select the "Show Data file in Finder" option
    5. Close mSecure 5
    6. Remove the mSecure.mscb file (move it to the trash bin or click command+delete to remove it)
  3. Sign in to your mSecure account on one single device
    1. If needed, restore from a backup file (let me know if you need help with this)
  4. Once you are signed in in mSecure 5 on your first device. Close the app and unlock the app using only your account password a few times
  5. Restart your device and try unlock the app again. You should be able to do this countless times without any issues. The password does not change at any point unless you change it elsewhere so the password you created in step one will work no matter how many times you close and re-open the app or restart your device
  6. After some testing on the single device, install mSecure 5 again on all other devices and sign in to your mSecure account one device at a time

Ok, deleted msecure and deleted msc and the first two times logging in I carefully typed password and it said incorrect.  The third time I was allowed in and restored the data.  Here is the email I got it just said activated and did not ask for QR code.  iMac is Sierra 10.13.6.  I signed out and now the fourth time I try to sign in I CAN NOT get in.  in says incorrect password.  I am really at a loss and think it must be this old computer?  Signed frustrated.  

On Feb 12, 2019, at 9:34 PM, mSecure <> wrote:

New Sign In
Your mSecure account was signed in to recently.
Feb 12, 2019 at 9:34:36 PM
Mark iMac
If you are aware of this activity, you can disregard this notification. No action is needed. However, if you do not recognize this sign in to your account, please follow the instructions in the link below Immediately. Your information in mSecure could be at risk.
If you have any questions, please contact our support team via our forum or email at

Please do not reply to this email. It was sent from an address that is not monitored.

Copyright © 2018 mSeven Software LLC. All rights reserved.
Lake Oswego, OR 97035

Still have same issue.  deleted msecure and mscb and first two tries said incorrect password.  Third time it worked.  I restored data and then when I did your step 5. and now it is locked out incorrect email and password.  I am on iMac Sierra 10.13.6.  I wonder if it is a old Mac that is giving this msecure issues.

I don't understand. Did you follow all my steps? If you went through an account reset, and remove the database file, you'd have to sign in to your account using your account email address and password. mSecure 5 on that device would then create a new account key/qr code and you would only have to unlock the app using the account password afterwards. Once signed in, you are never asked for an account email again. You only need the account password to unlock the app. How are you getting the option to enter in your email address after already signing in? 

I should note that with the release of mSecure 5.5 and above on iOS and Mac, mSecure 5 will now save your encrypted account key on your iCloud Drive (if iCloud Drive is enabled). This makes it so that mSecure 5 will first look for your encrypted account key on your iCloud Drive to authenticate your account. If no information is found or the current encrypted key is not valid, it will then display options to authenticate your mSecure account using your QR code instead. Otherwise, you will be automatically authenticated using your encrypted account key on your iCloud Drive.

I would still like to know why you are having to sign in using an account email and password often though. There is no reason that should be happening. You only need to unlock the app with your account password after signing in with your account email address, password, and authenticating your account initially. It would also be good to know if you followed all of the steps I outlined for you.

locked out on new iPhone incorrect password and user name. . . sometimes it works and when it doesn't it eats an afternoon figuring out.  

Comments to this discussion are now closed!