Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Have I been hacked? iPad & iPhone apps indicate that my password was changed (I didn't change it)

Oh lordy!  A few minutes ago I tried to use my iphone app (fingerprint) to open mSecure.  It didn't open but instead gave me a message that the password was changed on another device.  I have not changed it.

Tried it also on my iPad.  Didn't open, same message about password changed on another device.

Tried it on my Windows10 laptop.  Didn't open, same message.

I sent a message to mSecure with a link which allowed me to log on to the mSecure website, but there were no other instructions about what to do next.

I'm guessing that perhaps I'm supposed to send a message by posting a new topic?

Needless to say, I'm very worried!

2 people have this problem
It’s been more than 24 hours since I notified mSecure of my problem. I was sent a password so I could see my ticket (which is how I got here). Nothing but crickets since.

Yes I had the same problem it disabled my finger print and said my password has been changed by another device

Hi everyone,
Unfortunately, we are experiencing issues with expired login sessions at the moment. Our system is 100% protected and secure. However, customers who have been signed in to an account without reinstalling the app or having to go back to the full sign in process for over a year, will be have expired login sessions and will need to sign back into the app. Unfortunately, our app is not handling that process properly at the moment because it is giving users the message we provide when a customers changes their account password on a device. Additionally, iOS and Android users will have to use their account password to unlock the app and have to set up Touch ID/Fingerprint access again afterwards: mSecure 5 -> Settings -> Enable Touch ID/Fingerprint

We are working on fixing the issue so that others do not experience this problem. I'm sorry about the worry and inconvenience this might have caused.

The account password doesn't do it for me... the only saving grace is I still have my old 4.x  software still, ad can use it.

Hi James,

Thank you for contacting us and I'm sorry about the issue you are experiencing.  If you have forgotten your account's password, you can learn how to reset your account here:

mSecure 5 is a completely separate app. You could have set up an account with the same password as the previous version. However, you could have also created a completely separate password. If you go through an account reset, you can change the account password in mSecure 5 and start over in mSecure 5. This will not affect mSecure 4 or below in any way and will allow you to go through a migration process as well.

Comments to this discussion are now closed!