mSecure Support

Knowledge Base Forums Submit a ticket

Told me password had been changed on another device, but it had not been

Problem fixed itself, but reporting to see if anyone else has seen this and for the devs to be aware.


Last night, I used mSecure 5.x (most recent version) on one of my two Windows machines.  Call it "Windows 1".  Paying bills and such and was just looking up passwords.


This morning, both my wife and I tried to access mSecure on our iPhones with the same results:  We used touch ID to get in, it showed the list of items for a moment until it synced with the cloud and then it backed out of the list and put up a splash that said that the password had been changed on another device and that I needed to login with the new password.  It happened to both of us within about 10 minutes of each other.  Since the password had not been changed, this caused some serious consternation...


After I was able to, I went back to the Windows 1 machine and logged back into mSecure using the same old password as before and no problem.  I then did a manual backup just in case...  I then went to my other Windows machine - "Windows 2", which hadn't been used in several days, opened mSecure and logged in with the password - again, no problem.


I then went back to my iPhone and logged in with the password no problem.  Had to reactivate touch ID again.


It seems as though something hiccuped somewhere.  Has anyone seen this?  Wondering if there was anything I could have possibly done to cause it, but to be clear - I did not change any password on any device.


Thanks


1 person has this question

Hi Kent,

Thank you for contacting us and I'm sorry about the issue you are experiencing. Thank you for reporting this issue. I see that the email address you are using on this forum has not had a change of passwords so I'm not exactly sure what caused this issue. When developing or testing, I know I've run into this notice when I've switched between different kinds of builds (test, qa, production, etc.). However, I have not experienced this issue with the production version. Generally, the issue is caused by having the different builds use the same app id on Apple. We've recently changed that internally, but since you wouldn't have access to any additional builds of mSecure 5, I'm not exactly sure what would have caused your issue.


I'll document this as an issue for us and have our developers run through a few things to see if we can figure out what would have caused you to experience this.

I have had exactly the same issue on my iphone this morning.  After recovering from the initial panic, I deleted the app from my phone and reinstalled it.  This resolved the issue for me.

Also had this issue when I typed my password on Version 5.5.3 of mSecure on a MAC computer.  I retyped my password and it let me in without doing anything else.  Tried it on other devices but did not see the message anywhere else. It did not repeat on the MAC.  Only time I saw this.


mSecure, you still have a problem.  The exact same thing happened to me as Kent described just this morning on my iPhone and I have not changed my password on any device.  I also can not log back in, clearly my known password does not work.  What do you suggest?  And what about my Data?

I just had a variant of this happen (note that I started this thread as an Apple issue).  I was on my "windows machine 2" from my original post above and last night, received the same message.  I closed mSecure, reopened, re-logged in, and it did not give me the error message the second time.


It happens when the app tries to sync.  I imagine that's when it erroneously determines the password changed on another device.


FYI: Running the most recent version of the app on all devices, syncing with the mSecure cloud.

Today, I got this response from mSeven, oddly it was not attached to this tread:

Hi everyone,

Unfortunately, we are experiencing issues with expired login sessions at the moment. Our system is 100% protected and secure. However, customers who have been signed in to an account without reinstalling the app or having to go back to the full sign in process for over a year, will be have expired login sessions and will need to sign back into the app. Unfortunately, our app is not handling that process properly at the moment because it is giving users the message we provide when a customer changes their account password on a device. Additionally, iOS and Android users will have to use their account password to unlock the app and have to set up Touch ID/Fingerprint access again afterwards: mSecure 5 -> Settings -> Enable Touch ID/Fingerprint

 

We are working to fix this issue. Sorry about the panic and inconvenience this might have caused.


And shortly thereafter this final comment:

Important note: no account password was touched or changed here. If you are having unlock problems, it's going to be because the account password you are trying to use isn't exactly what should be used. Please use this guide to go over possible account unlock or sign in issues: https://m7software.freshdesk.com/support/solutions/articles/36000019923-forgot-your-msecure-account-password-


One more...

Another user on another board posted this:

patrick

 

Good Day,

 

Today I got response from mSecure, but it was not yet a fix. And I was still unable to login to my iPhone with my known password. 

 

I had a suspicion it was reaching out to the cloud to see the 'password change on another device' error, so I disabled wifi and put phone in airplane mode so no Internet access. Closed the app on the iphone, restarted app and Aha. I was able to login to mSecure with my known password, and it did not prompt me for the 'new' password. Able to access the app as normal while phone was off internet access.

 

However, enabling wifi and/or cell use again causes the same issue as before. So this is not a fix, but just a rather inconvenient workaround to at least temporarily access your data until a fix is completed. Also, proved my known password was legit, I wasn't crazy :)

 

The above is my experience, not advice, just hope it may help someone else who was effectively locked out such as me.


Thought this might benefit some of you and other readers.


Final comment...

Once I figured out what I meant with my very cryptic password hint, I finally entered the correct password.  I was back in.  All my data was still there.  Seconds later the same reset occurred, but now I had my password.  I logged back in reset my password, turn on my touch ID again and everything is working again.


I took some other provisions to not get stuck like this again.


Good luck to those that come after me!

Let's use this topic for discussions on this issue moving forward: https://m7software.freshdesk.com/support/discussions/topics/36000003667


Comments to this discussion are now closed!