Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Missing Icons

I use my laptop as the "Main Computer" to sync devices to. When I sync my phone to it, only about 2/3's of the icons show up. I have tried manually syncing many times, but they do not update on my phone to what I have on the computer. One phone is missing 42 icons, the other is missing 58 icons. Everything else seems to have synced fine. Any ideas what I need to do?


1 person has this problem

Hi Benjamin,

Thank you for contacting us and I'm sorry about the issue you're experiencing. I'm not sure exactly what is happening here. There is a icon issue on our Android version that will be fixed soon in the next mSecure 5 update. However, i'm not sure if that's the issue here. 


You can check to see if that's the issue by uninstalling mSecure 5 from your Android, deleting the Icons folder from the mSecure5 folder in your device's internal storage. (Internal storage/mSecure5/icons), and reinstalling mSecure 5. After a Wi-Fi syncing is complete, you should hopefully have all the icons sync in as they should. If not, the icon issue I mentioned earlier will be fixed very soon.

 Hi

Just to say that I also have this problem of missing icons (some, but not all!) when I wifi sync my Android phone (a Samsung Galaxy core prime running Android v5.02) to my main computer that is running Win10.

 I should have added that all the 'stock' default icons of msecure appear on my Android phone, but only some of the edited icons (i.e. icons from your server or custom icons) appear after the sync with my main Win10 computer

It's the exact same for me as it is for John. I have a Note 8 running Android 8.0.0 trying to sync up with Windows 10. Let me know if you need any other information from me.

Interesting fact: With mSecure5, Windows 10, and Android 10 I am again experiencing this described behavior: Only a portion of the icons which are visible in the Windows app appear on my Pixel 4 phone, after syncing...

I've tried to re-assign logos in the Windows app, and do a sync again, but this doesn't work, too.


What am I doing wrong?

Hi Andrew,

I'm not sure we were ever able to reproduce the issue originally reported here, so we'll have to do some investigating. The site icons are downloaded from our server, and that is controlled by the URL entered into the Website field for the Login record. If the URL matches a URL for a site icon we have already downloaded, then the icon will be downloaded to the device. This is a clarification to help understand that one device version of mSecure is not actually syncing the icons over to the other devices. The only thing that has to be in place for the icons to download is the URL in the record, which will be synced between devices.


Real quick, can you tell me the URL you have entered in for at least one of the records where the icon is not showing up on one of your devices? Also, which device is showing the icon and which device isn't?

Hi Mike, thanks for the prompt reply! Again, the issue happening was with mSecure 5; with this version I thought I can just choose an icon, and alo use self-created icons.  I would expect that it's not depending on the login-URL... Actually, I was experiencing this behavior not only with logins, but with all other sorts of  entries, like e.g. notes, etc.



Hi Andrew,

Just to be clear, all of your icons are showing up correctly on your PC, but some of them are not showing up on your Pixel 4. Is that correct?


Originally, I was thinking you were only talking about the dynamically downloaded site icons for Login records, like the one you should see when you type in google.com into a Login record's Website field. After saving the record, you should see the real Google icon downloaded from the website. However, it looks like the problem is actually happening when you try to change the icon using default icons shipped with mSecure or when you try to add a custom icon as well. Those two features are different than the automated downloading of site icons. 


To keep things simple, I want to tackle just one issue at a time. It gets too complicated trying to work on more than one feature =)  After we make some headway with one, we'll talk about the other icon issues as well.


Real quick, let's try creating a new test record using the Secure Note template, then have you change the icon for that record using a built-in icon that ships with mSecure. Since it sounds like the issue may have something to do with syncing, I'm going to have you create the record on your PC so it will sync to your Android device. Open mSecure and click the Add Item button in the top left of the left column. Choose the Secure Note type, then add a Title to the record, something recognizable like "TEST", then add some characters to the Notes field. After you do that, click on the record's icon to change it. In the icon picker, select the left tab to change the icon to a different default icon. You can choose any of them, but make sure to remember which one it is. Save the record, then open mSecure on your Pixel and wait for the record to sync over.


Does the record have the correct icon that you set on your PC?


Login or Signup to post a comment