Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

Can only edit an item on Android phone on first use

Came back to MSecure after a long while away.

Installed it on my iPad and Android (v9) phone.  Syncing both with Dropbox.  

MSecure on the iPad is working well and looking great but on the Android phone it will only edit an item the first time you open up MSecure.

On the phone.  If you start MSecure you can edit an entry successfully but if you try to edit the same entry again it will not edit it.  You have to close MSecure and restart it and it will then edit the entry (only once).

Apologise if there's something I'm missing here but it seems like a repeatable bug.

Latest version of MSecure on the Playstore and using Android 9

Hi Robert,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. Unfortunately, I'm not understanding what you mean here when you say it won't edit the record a second time. Are you saying that after you edit the record one time, nothing happens when you tap the option to edit the record again? It could mean that you're actually not able to get into the record's edit mode, or it could mean that you are able to edit it, but the sync never takes place to get the changes over to your other devices running mSecure, or it could mean something else. Either way, this is not a known bug, so I don't know what could be happening, but I do need more information from you before we can start any troubleshooting.

Hi Mike - I'll try to explain this as thoroughly as I can. On my Android phone. I start up MSecure, and edit an item, lets say the item is my login to a forum called "Reddit" I type "This is a test" in the notes field. The app says "Saving modified record" and at the bottom of the screen the app says "Record modified succefully" I can see the modified notes field and all is well. Good so far. I go back to my list of items and choose this "Reddit" item again and clcik the pen icon to edit the item and add "This is another test" to the notes field. I click the tick symbol and the app again says "Saving modified record" and at the bottom of the screen it says "Record modified succesfully" but it hasn't. The notes field I can see does not contain the new text. The app hasn't frozen the phone hasn't locked up. I can scroll through the MSecur entries. If I select another item say a contact entry and try and edit the mobile number field MSecure despite saying it has modified it succesfully it actually has not. If I then close the MSecure app down and open it up again it will edit the first entry I try but will note edit any other entries. Note that MSecure on my iPad is fine its just the app on my Android phone. Regards Rob

Hi Robert,

Thank you for the added details. It sounds like you are running into an older bug that has been fixed for at least a few releases. I need you to check version of mSecure you are running. Please open mSecure, tap the menu button in the top left corner, tap Settings, then tap About mSecure at the bottom of the Settings screen. What's the full version number listed there?

Also, to be clear, I have looked at this on my Android device, and I'm having no problems saving multiple changes to my records. I believe this issue is related to the modified date not getting set correctly, and if that's the case, it should be that you're running an older version of the app.

Hi Mike Did what you asked - my version on my Android phone is; mSecure 6 (version Regards Rob

Hi Robert,

Ok, that is the newest version of the app. I'm still not sure what could be happening here, but we have a couple of options. Before we do anything to try to fix the problem, however, I'm going to have you check the "Last modified" date before and after you try to edit a record two times. Go ahead and restart mSecure so it will be able to edit a record. Next, choose a record and before editing it, record the "Last modified" date you'll see after the last field on the record. Now edit the record, save it, then record the "Last modified" date again. Now do those steps a second time when the record should not get saved, and send me the 4 recordings of the "Last modified" date.

Hi Mike OK here are my results. Started MSecure; Created a Record; Last Modified = 21 June 2022 23:06:13 Edited the record; Added "Test" to notes field = "Test" did appear; Last Modified = 21 June 2022 23:06:44 Edited the record again; Added "Again" to notes field = "Test Again" did appear; Last Modified = 21 June 23:07:01 (Thought at this point I was going mad) Listed all the records and choose the new record Efited the record again; Added "MAD" to notes field = "MAD" did not appear; Last Modified = 21 June 23:07:01 It seems after editing a record you have to list the record set and then try to redit the record you previously edited. To be honest Mike I think this is a bug but it doesn't seem consistent (being a Delphi dBase developer in the past these were always the worst kind). I have seen it not edit the record immediately you try after adding the record, sometimes you have to list the record set and then go back to the record. I understand the frustration as on your Android device the software seems clean. But, and you'll have to take my word for it, it doesn't work here. Surprised other people haven't reported this. Regards Rob

Hi Robert,

I'm definitely not saying there isn't a bug here. The problem is, we actually don't have anyone else reporting the issue you're running into, and I can't reproduce it. When it comes to this type of situation, the only thing I can do is try to get as much information as possible to try to reproduce the issue, and if I can't, it's then possible we could send you a debug version, but we're not there yet.

Real quick, when you say "It seems after editing a record you have to list the record set..." are you meaning that you have to do something on the main view to display your records a certain way before trying to edit it again? Can you explain that in a bit more detail so I can try it on my device?

Hi Mike Sorry if I wasn't clear. But simply this; Sometimes this problem only seems to manifest itself when after editing a record you click the <-- back facing arrow to go back to the display of all records. But not always. I've just opened MSecure on my Android phone, clicked on the top record in my list of Email Accounts with a last modified date of; 22 Jun 2022 19:01:27 Edited the Notes field which did it correctly giving me a LMD of; 22 Jun 2022 19:07:23 Stayed on the record (did not hit the back facing arrow to return to the list of records) edited the record again but this time the edit did not take place (although MSecure said it had edited successfully) and the LMD is still; 22 Jun 2022 19:07:23 For the past few minutes MIke I've tried editing this same record - sometimes it does but most times it does not. Thought it was when I was adding to the record not deleting from it but no either way most times the edit does not take place. Tried not just the Notes field but the Username field as I thought it might be field dependant but the username field doesn't edit (most times). It's got me really baffled thinking it's something to do with my phone as you've others using the same version of MSecure. Just wish you could see it happening. I am due to upgrade my phone soon, possibly within the next month, and will reinstall MSecure then and report back. But why this is happening just to this unit is I suppose kind of interesting, I haven't hundreds of entries so I'm not mad about this as I say I've just come back to MSecure. I'm going to check the free space on this phone and free some up possibly it's some user space flag that MSecure doesn't like. Will report back. Regards Rob

Hi Robert,

Thank you for sticking with this one. I just ran further tests on my Android device, and I did run into something that might be related to this, but I'm doubtful. I noticed that when the notes field gets too long, some of the data gets cut off in the Details view for the record. Is it possible the notes you have in the records you are editing is long enough that the new data you're saving is just not getting displayed in the Details view, or is that you edit the record, scroll all the way down to where you added the note and then don't see the data you entered? For me, I have been testing this with very short notes until now when I started adding multi-line information and saw the display problem.

Hi Mike No don't think that's the problem here my note field entries are only short - probably no longer than 30 characters when I'm entering test data. Related to the free space issue I thought there might be in my previous post. I freed up some space on the phone and I thought initially the problem was gone, I edited the same record 4 times successfully but on the 5th attempt the edit wasn't recorded. (Changed note field data) The free space is only around 2GB so will delete some further items and try again.

Thank you for the update Robert. I'm not sure what's happening here, because I have not seen the problem occur once in probably 20 edits (or so). I think the next thing you should do is simply reinstall mSecure if you haven't done that already. It may be that something happened during the install and the app could be damaged. I don't know how likely that is, but stranger issues have been fixed by reinstalling the app.

Hi Mike Freed up more space but still having the issue. OK will reinstall the app and try that. Regards Rob

Connexion ou Inscription pour poster un commentaire