Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Soporte mSecure

mSecure 6 - Records do not update when using auto-sync through Dropbox

I am a long-time mSecure user. I have mSecure6 on my Win10 computer, Android tablet, and iPhone (day 23 of Premium trial). I am syncing through DropBox, the sync method I have used successfully since purchasing mSecure Pro. I am also using automatic backups, again to Dropbox.

Using mSecure6 on my Win10 PC, I am attempting to modify my existing mSecure records to change the template from "Login," which I used almost exclusively in mSecure5 to more descriptive new templates to better organize my passwords. I plan to use templates as a method for sorting my records (using the Sort By Template display option). I am creating new templates and/or modifying the "canned" templates to fit my requirements. I do not have mSecure6 open on either of my mobile devices. 

When I update an existing record to apply a new template, the record appears to update and then quickly reverts back to the original, unchanged record when the auto-sync to Dropbox completes. For example, when I change the template for my password record for CBS from "Login" to a new template named "Entertainment - Streaming," which has two fields: Username and Password, the record appears to change but when the auto-sync to Dropbox completes, the record has reverted back to show the Login as the template. If I create a new record for CBS using my new "Entertainment - Streaming" template, it works fine. However, I cannot delete the original CBS record or, for that matter, any records I no longer need. Again, the record appears to be deleted but when the auto-sync to Dropbox completes, the record is still present.


If I turn off Dropbox auto-sync, delete the mSecure sync file: Dropbox/Apps/mSecure 5/UserID/data.mssb file, modify or delete a record, and then click the Sync button to manually sync to Dropbox, the problem does not manifest. The data.mssb sync file reappears. If I check the record on my Android tablet and iPhone, the changes are there.

If I then turn on auto-sync to Dropbox, the problem returns; subsequent updates/deletes revert back.

This bug was reported for mSecure5 by a user named Rand two years ago.

It clearly still exists in mSecure6.

@Lynne That all sounds good. I also have some good news about the bug you're dealing with. We believe we have a solution that will fix the issue on our end. We still haven't found the actual cause of the corruption, but we do think we can patch the issue so that customers will no longer be affected by the problem. The release won't be available at least until tomorrow or over the weekend, so if what you are doing now is fruitful, I would keep at it.

@Mike it would be fantastic to have a fix for this.  I am going to ask a dumb question, but I don't see the created or modified date for any records on my iPhone.  I see it plain as day in Windows.  Am I missing something I need to do, to see that info?  While in an entry on the iPhone I look at the top and bottom and have also have gone into edit mode and don't see the info anywhere.  I am sure I am just missing it, but please let me know where it should be.

@Mike On iOS, you have to tap the button in the bottom right corner with the three horizontal dots in it. That shows you more details for the record.

The fix for the issue some are experiencing with the modified dates will take an update on all platforms. The first to be published will most likely be the Android version that is the actual cause of the issue to begin with, then the other platform releases will follow as quickly as possible.

@Mike Reilley I completed the steps you described to reestablish Dropbox sync on my Android tablet. Everything seems to be working, with one small "weirdness": some of the icons that I had used from the cloud (e.g., Box) did not transfer; instead the record on my tablet had the default "cloud" icon from my custom "Cloud Storage" template. The weirdness is that for records that used icons from the cloud (e.g., AirBnB) and were based custom templates that had the circled ? as the icon in the template, the icon from the cloud stayed put.

Dropbox sync is working on my iPhone as well, without the icon weirdness.

Thanks for your help getting a workaround for the sync problem. I look forward to seeing the update when it comes through.

@Lynne This is great news, though I am sorry you had to go through any of this. After the next release on all platforms, the bug should be entirely fixed. In this one small way, it's good the bug resurfaced, but I know this type of thing is a very bad user experience. Thank you very much for your patience in working through it.

For the record icons, you should be able to set these, though I'm not sure why they didn't get set automatically after the reinstall of the Android version. For either one of the records, go ahead and edit it, then tap into the URL or Website field. Type in a different URL, then tap into a different field, and you should see a site icon get displayed at the top of the edit screen. If it doesn't get displayed, you may have tried a site that doesn't have a site icon saved on our system, but that's OK. Now type in "" or "" and then tap into the next field.

Did the icon update? I checked these two sites on my phone, and those icons should get set on your records, because they did on mine.

@Mike thanks for the help locating the modify date information for IOS.  So, I have a prime example.  I have a Windows 10 laptop next to my new Windows 11 laptop.   Both Windows versions are showing a modify date of 4-1-2022 on a single record, but my phone is showing a modify date of 4-3-2022.  What is causing this?  All three say all changes are complete with no changes when I run a manual sync operation.  Now a new issue I don't understand.  I am using the OTP field on a few records and am most excited about it.  I am finding that the number provided on the new Windows 11 laptop is incorrect, but my Windows 10 laptop and iPhone are correct and show the exact same number.  I look at the field detail and they are exactly the same.  What is causing this?  Should all my devices show the exact same number?  I even created a second OTP field with the same data and I am seeing the same number twice on all three machines.  The Windows app build is on both laptops.  Again, I restored from a backup on one PC and purged data on all devices to force a fresh sync from the Dropbox data and I still seem to have issues.  I don't have Android in the mix.  Just Windows and IOS devices. 

Hi Mike,

With regards to your first question, if there is no Android device in the mix, you won't need to worry about the modified dates not lining up, and those not being the same should be fixed in a future release. There are actually a few different modified dates in the system, and we have found that the wrong one gets displayed in certain circumstances. If there is a discrepancy, you can check the data real quick, or you can make a quick change to a record, and if the either all data is the same or the sync takes place, everything is good.

For the second issue, the different platforms implement OTP field in a different way, because the same libraries can't always be used. The main thing to know is whether or not the field's data works to authenticate you for the account your signing in to. When you use the field OTP field data on all your devices, are you able to sign in to your account? I know the data is different, but please try to use it real quick on all platforms.

Mike, good to know on the first issue.  I haven't seen the major data sync issue since I purged all devices yet.  Hopefully, that stays that way.  So the password generated on the Windows 11 computer is a different number than all other devices and does not work.  It seems like my other devices are all displaying the same number.  I think what you are asking is if it works and the answer is no.  Any suggestions?  


Ok, I think I may see what's happening here, but I still have questions. On my PC, I have the OTP field showing in the middle column, and that code is getting cached so that after it refreshes the OTP code in the right column (if I have the record selected), the number is no longer in sync. In other words, I see something like 600*215 under the title for the record in the middle column, but I see something like 782*105 in the record's details. The 2nd number is the correct number, which matches the OTP code I see on my iPhone. 

Does that sound like what you're seeing on your devices?

@Mike so I assume you are calling the middle column the listing of records, otherwise, I am not following.  So here at my office, I am on my Windows 10 desktop.  I don't see anything in the middle column.  I don't get the OTP unless I select the record.  then once I do I see the OTP and the countdown of the OTP.  My Windows 10 desktop both at home and at work match exactly my iPhone.  With both the OTP and the countdown clock.  My new Windows 11 laptop will have a different number and I believe a slightly different time, but honestly, I don't remember for sure.  Bottomline I only see the OTP in one place that I can find.  

@Mike I believe you are using the Windows app shrunk down to 2 columns, which is intended, but I typically think about the app being used in 3 column mode, probably because I use the Mac version most of the time. For Windows, if you grab the right edge of the app and expand it, you'll go to 3 column mode and if you contract it, it switches to 2 column mode, something unique to Windows. At any rate, it's obvious you aren't seeing the same thing I am =)

I just tested again, and I'm seeing something else that may lead to what's happening on your devices. If I click on a record on my PC and on my iPhone, I see the countdown for when the code will refresh. On my PC, it's up to about 3 seconds off from the iPhone. I can't tell yet if that number is growing or not, but if it is, that would account for why the numbers would get out of sync at a certain time.

Can you check a record on both your PC and phone and let me know if the countdown clock is out of sync? If it is, about by how much is it off?


Sorry for the delay to get back to you on this.  I finally did more checking.  Every IOS and Windows 10 device is fine, but with my Windows 11 Pro laptop, the OTP is not the same and doesn't work.  The time is also different from all other devices meaning the rotating time is off by several seconds.  Any ideas on this as I really need this fixed.

Hi Mike,

Unfortunately, I don't know what is causing this to happen. Whenever I set up a One-Time Password field on my devices, everything syncs the way it's supposed to, and the field just works on all my devices. The only thing I can think of doing here is setting up the 2FA again, but this time, make sure to set it up on your Windows 11 Pro laptop. After doing that, the field should sync over to the other devices, and everything should work.

Did that have any effect on the issue Mike?

Hi Mike,

I would suggest you take a look at the Current Date and Time of your Windows 11 PC under Settings, Time & Language, Date & Time (top-most line).  There is a chance that the time is somehow not synchronized to the times on your IOS and Windows 10 devices.  You should also check to see when the last successful time sync was carried out - just a few lines down, under Additional settings, Sync now.  Just click on "Sync Now" to start a time sync.  Hope this helps.

@JSeow That's a great tip I don't think I would have ever thought of! Thank you very much for sharing it here. If the time is out of sync on the devices, that would definitely cause the issue Mike's running into here.

@Mike, were you able to check the time settings on your devices?

Iniciar sesión o Registrarse para publicar un comentario