Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Soporte mSecure

msecure 4 not working on ios 14.6

I know this is a problem  a lot of people are having. Has anyone found any solutions to this? Like others I have 100s of passwords and other data on there which I can't get access to. The lack of support and interest from msecure is not acceptable.

I have been in touch with Apple and it is not possible to downgrade the ios.

Is it possible to restore your phone to another iphone which is running ios 14.4 or lower so you can at least get the data out?

Or is it possible to transfer the app + data to another iphone which is running 14.4 or lower? I have seen a couple of mentions of a program called MobileTrans that can do this - has anyone had any success with this?

One thing I don't  understand is another member of my family is running msecure 4.5.2 and it is working on ios 14.6. Is it possible to get this version from somewhere?

One of the articles on this forum says when you set up a msecure 5 account it asks you if you want to migrate your data across. But it doesn't do that. Why not?

I have raised two tickets and the only response i have had is to refer me to an article which is no help at all.

3 personas tienen este problema

Hi Rick,

Thank you for contacting us, and I'm sorry for the time it has taken to receive a reply from us. We're backed up in support right now, so response times are significantly higher than normal. I'm not sure if you have read about what's happening in iOS 14.5 and 14.6, so forgive me if this is old news to you. It needs to be explained, because there is a lot of information that isn't correct being spread in different contexts.

Thank you for contacting us, and I'm sorry to hear about the issue you're experiencing after the recent iOS update. Unfortunately, mSecure 4 is no longer supported, so there won't be any updates to that version of the app. The problem is, at some point in time, older, unsupported apps always run into issues like this, which is why developers have to provide an option so that it doesn't happen. mSecure 5 is that option, as it is the update to mSecure 4 that keeps what's happening in iOS 14.5 and 14.6 from taking place.

In the older version of the app, we implemented an advertisement for mSecure 5, and that was to let our users know that the app was available and that they could upgrade at any time. Along with that advertisement, we provided an option to close it and not show it again in the future. We are finding that a lot of customers have used that option, so they aren't seeing the ad any longer. The problem is, we have no way of contacting our older customers, because the older app doesn't have an account system. Without an account system, we don't have their email addresses. If we did have their emails, we would be communicating with them to provide some explanation on what is currently happening after the recent updates to iOS, to tell them what we're doing to help, and to let them know about the backup in support which is leading to long wait times in receiving responses from our support team.

However, the issue brought about by recent iOS updates are a different story altogether. On all our company test devices, we have still not encountered the issue you and other customers are experiencing, which, though there are a lot of people who have experienced the problem, is actually a very small percentage of our overall customer base. Even had we been able to contact our users via email, we wouldn't have done so before the iOS 14.5 update, because we never knew it would cause this problem. And Apple doesn't send developers notifications that this type of behavior will occur, so there was no way for us to know ahead of time.

Moving forward, we still aren't able to tell for sure the next iOS update will cause the upgrade message to appear. Our developer has even tested on the first beta release of iOS 15, and the old mSecure app runs without any problems. In short, at this time, we do not know what is causing the issue for the old, unsupported mSecure app, but we have provided a solution.


With regards to the issue you are experiencing, the only thing that makes sense when the migration process is not triggered when signing in to an mSecure 5 account that's in a fresh state is that the version of mSecure 4 installed on your device must be older than version 4.5.4. That version is the newest version of the old app, and in that final release of v4, we implemented a shared space for the database to which mSecure 5 has access. Unfortunately, versions older than 4.5.4 don't know about that shared space, and in that case, mSecure 5 is not able to access the older app's data.

Most of our customers running into the same problem you are after updating to iOS 14.5 or 14.6 are following the same steps to migrate, and it is working as intended. Because of this, we know if the older version of the app is 4.5.4, the migration does take place. However, there is a small handful of people for which the migration option is not available after choosing a sync option, and what I explained above is the only only explanation we have for when this happens.

In response to your question about downloading v4.5.2 specifically, the only way to do so is to uninstall mSecure 4 and then re-install it from your list of purchased apps in the App Store app. That would install the newest version of v4. The problem is, if you do that, the data stored in the app will be deleted, so we are not recommending any of our customers try this unless they know absolutely for certain they can restore from a backup after they perform the reinstall.

Do you know if you made any email backups from mSecure's Settings before the problem you are experiencing started? If not, do you have access to your data in any version of mSecure running on any of your devices?

Thanks Mike for your response. As I understand what you are saying, if my version of msecure 4 is older than 4.5.4 (which it probably is) then the migration option to msecure 5 is not available. Is that correct?

I do not have any backups. I used to back up to dropbox but it stopped working a while back and I wasn't able to restart it. I have my phone backed up  on icloud and my laptop and figured that was sufficient to guard against losing my phone or the data on it. I didn't count for the app ceasing to be supported.

Can you make the last version of msecure 4 available to download so people in my situation (of which it sounds there are a lot) can upgrade and have a chance of recovering their data. I think it is pretty unreasonable that this has happened without any warning. It has major repercussions for me and my work. There is a lot of information on there other than just passwords which will be very hard to replicate.

Please consider this, even if only for a limited time.


Hi Rick,

I think we have a new option to get this issue resolved. Our developer was able to get a utility version of the old app built, and it should create the shared app space that is missing between your mSecure 4 and mSecure 5 apps. Do keep in mind this app is only useful for two purposes: 1) For retrieving your password via Touch or Face ID, which was developed for a different issue some users were facing; 2) For creating the shared app space to enable the migration feature. You will not be able to view or interact with the data stored in the app.

This version will not be available in the App Store, since it's only a utility version of mSecure 4. In order to download it, you will need to download the TestFlight app from the App Store if you don't already have it installed on your devices. 

Should you choose to download this utility update, I will need the Apple ID (email address) you use on your iOS devices. Once I have that, I can add you to the TestFlight list of users who will be given access to this version of the app. Once added, you will get an email invite to download the app from the TestFlight app. The new version will download over the top of mSecure 4.5.4, and it can only be used to reveal your password. Since v4.5.4 can no longer be opened, this shouldn't be a problem, but I do want to make sure you understand all that will happen when the new build is downloaded. In particular, the TestFlight version will have no functionality for viewing your data. It can only retrieve your password from iCloud Keychain on your device, and then display it to you.

Let me know if you have any questions about this process. If you're ready to proceed, download the TestFlight app, send me your Apple ID, and I'll add you to the TestFlight list.

One thing to mention, if you don't want to have your email displayed in a public forum, you'll have to send me your Apple ID via email. You can reach me at, and be sure to add "Attention Mike" in the subject line, as that will help me locate your email more quickly. Also, go ahead and post a quick comment here letting me know if you sent the email, which will help expedite the process.

Thanks Mike, that sounds promising. I've sent you an email.



Hey Rick, I found your email and just sent you a response. Should you run into any problems, go ahead and respond to the email.

I have encountered this same problem! I have a backup from just 6/11/21, but it doesn't matter because I can't get into version 4 OR version 5 (I know my password, but version 5 won't recognize it and won't let me create a new account because it says that email/user is already taken [exactly]).

Help! Could you email me at so I can provide you with my Apple ID info, etc, to do this TestFlight utility option?

Thank you.

I have tried to add my comment that I need the same help, but then it's not showing up for me in the thread. I am going to try again.

My email address is - could you please email me so I can provide my Apple ID?

Thank you.


Were you able to get your problem resolved? I have the same problem. :(

@Emily In order to migrate your information into mSecure 5, your account has to be in a fresh state. This means you will need to reset your account before you try to sign in to mSecure 5 on the same device mSecure 4 is installed. After the account is reset, the migration will be triggered as you go through the sign in process in mSecure 5.

The first step is to simply delete mSecure 5 from all your devices, and if you have a Mac computer signed in to this account, stop here and let me know before proceeding. IMPORTANT: mSecure 5 has to be completely reset on ALL your devices. If this is not done, it can lead to very bad consequences.

After you have deleted the app from all your devices, follow the steps in this support article to reset your account:

Next, reinstall mSecure 5 from the App Store app, then sign in to your account using your account's Username (email address) and the new password you just set. After you choose which sync feature you would like to use, you should see the screen asking if you would like to import your data in from mSecure 4.

IMPORTANT: Do not delete the old mSecure 4 app from your device. If that is done, the data stored in the app will be lost. Also, your mSecure 4 data is not connected to your mSecure 5 account in any way, so performing the account reset will have no effect on the data stored in the old app.

Mike - I am in a similar situation . . .

I have mSecure 5 on my Mac & iPhone - which are synced - but mSecure 4. something on my iPad.  The iPad has now stopped working . . .

Can I create a new mSecure 5 account on the iPad (with a different email, etc) and then import the mSecure 4 passwords.  Once imported, can I then backup from that mSecure 5 and import into the mSecure 5 I have on my Mac & iPhone?

I should note that the passwords in both are different - one was personal and the other was business.


I am having the same problem re. my iPad, except that I am already using mSecure 5 on one device, just not my iPad. I am note sure what version of mSecure was on the iPad.

What is the best way to deal with this??

@Stephen Unfortunately, while you can create a new account and import the data in from the mSecure 4 account on your iPad, the new account will not be linked with the account on your Mac and iPhone, which I think you already know. So, you can gain access to the data in the iPad mSecure 4 app, but the new account would turn into a free account, and you would not have the ability to easily merge the two data sets. Does that make sense?

Dear Mike,

I would like you to add my email to the list that can have a code to access Test Flight for the same exact reason that a previous customer name Rick has contacted you.
I read all the thread between you and him and i am going now to write a post to mention that i have sent you this email.
Any hell will be appreciated as i am encountering the same problem as per Rick, in fact i have the same Msecure version and with new IOS 16 it does not run anymore.
Thank you so much!!!

Dear Mike,

I would like you to add my email to the list that can have a code to access Test Flight for the same exact reason that a previous customer name Rick has contacted you.
I read all the thread between you and him and i am going now to write a post to mention that i have sent you this email.
Any hell will be appreciated as i am encountering the same problem as per Rick, in fact i have the same Msecure version and with new IOS 16 it does not run anymore.
Thank you so much!!!

Iniciar sesión o Registrarse para publicar un comentario