Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Soporte mSecure

Login failure on MacPro desktop....

I  cannot logon to mSecure 5.5 that I recently installed on my MacPro running OS 10.10.5. 


I know the password is correct as it is the same one I used on mSecure 3.5.7, I just tried it on the older version, the password works just fine, but not on mSecure 5.5.


How do I reset the password on mSecure 5.5?

Hi Mike,

No, I used the restore function. But after the next restart of the app I was back to square one: mSecure doesn't accept the new password. The old one works fine. Fun side note: The password hint did change to the new one I created with my password reset on my iPhone.


Please let me know how I can reset mSecure on my iPhone so that I can get the two devices syncing again. Also interesting: It didn't do any backups since the problem in February.

Hi Michael,

The restoring of your data has nothing to do with the password you use to unlock the app. The password to unlock the app is your Account password, which we know is messed up right now due to the bug I mentioned earlier. Until we get your account reset, your iPhone will only open using your new password, and your Mac's mSecure app will only open with the old password. Again, restoring a backup will not have any effect on the password that's needed to unlock the app.


What I'm doing now trying to make sure you're data is safe before having your reset your account. That's why I wanted you to try restoring from the most recent backup. The next thing I'm going to have you do is create a new backup on your iPhone, and then see if you see that backup in mSecure's Backups Preferences on your Mac. If that works, then we'll know you can restore from that newest backup you made, and you'll be ready to reset your account. It's a bit confusing to try to explain beforehand, but it all works in the end and should make good sense when I send you the instructions.


To create a new backup on your iPhone:

  1. Open mSecure and unlock with your new password
  2. Tap the menu button in the top left corner
  3. Tap Settings
  4. Tap Backups
  5. Tap "Backup Now" to create a new backup
  6. Make sure you see the backup at the top of the list


Now, on your Mac, you'll check to make sure you see that backup which should now be stored in your iCloud Drive account:

  1. Open mSecure on your Mac and unlock with your old password
  2. Click "mSecure > Preferences" in the menu bar at the top left of your screen
  3. Click the "Backups" tab


Do you see the new backup you just made on your iPhone in the Backups tab of mSecure on your Mac?

Hi Mike,


Thanks for your instructions. Everything worked fine I do have a new backup from my iPhone and I see it on my Mac.


What are the next steps?

Hi Michael,

This is all good news so far. Now that you have a new backup from your iPhone, it will be pretty simple to get everything fixed up. I was going to have you reset your account, but I actually don't think that will be necessary in this case. I think all that will need to be done is to reset mSecure on your iPhone, because after doing that, you'll be able to set up mSecure on that device with your old password. After that, you will be able to change your password to the new one, and everything should be good moving forward.


The first thing to do now is restore the new backup on your Mac. To do that, simply go to the "Backups" tab in mSecure on your Mac, tap the new backup that was created, and click the button to restore it.


As long as you were able to successfully restore your data in mSecure on your Mac, you can now simply reinstall mSecure on your iPhone. Again, only do this if you see all your data in mSecure on your Mac. After reinstalling on your iPhone, it's possible you'll need to scan your Account QR Code from the Account Settings of mSecure on your Mac. If that's needed, simply open the Preferences for mSecure on your Mac, then click the Account tab. Click "Reveal Account Key" and you should be able to scan that code to sign in.


Were you able to get the backup restored on your Mac and reinstall mSecure on your iPhone Michael?

Hi Mike,

I could restore the backup on my Mac, but I had to type in the new password to do so. So somehow there is still something mixed up. Afterwards I deleted the app on my iPhone and reinstalled it. It asked me about my account and I only could login with the new password. It didn't ask me about the QR code, but out of curiosity I tried to check it out. As soon as I click on the tap account the mac app crashes (see Report).


Also weird: When I type in my old password I see an error "invalid username/password", but it still unlocks.


Sync still isn't activated on my Mac. On my iPhone it is activated, but it doesn't create a backup automatically. 


Report.rtf Report.rtf
45.2 KB

Hi Michael,

Ok, something is very strange here. If you were able to sign in to your account on your iPhone using your new password, that would mean you are not running in to the bug I mentioned earlier. In this case, I'm pretty sure all you need to do is reset mSecure on your Mac. The thing is, I've looked back on our correspondence, and I'm not sure how we ended up here. The good news is, it's a much better place than I thought, so there's no harm done, but if all that was needed was a reset on your Mac, I ran you around in circles a bit.


Before I have you reset mSecure on your Mac, I'm going to have try disabling the sync feature for mSecure on your iPhone. This will confirm whether or not mSecure is able to communicate with your mSecure Cloud account. Please follow the instructions below:


  1. Open mSecure on your iPhone
  2. Tap the menu button in the top left
  3. Tap Settings
  4. Tap Sync Settings
  5. Tap the row at the top, then choose the option to disable syncing (NOTE: nothing happens to your data when you disable syncing, and it will be turned on again shortly)


After you turn off syncing, please do not turn it on again until I send further instructions. I need to check your account now to make sure the change was processed correctly.


Also, after you turned off syncing, did the change stick in mSecure? If you go back to the Sync Settings, do you still see it's disabled?



Hi Mike,


I just turned off syncing on my iPhone. I also restarted the app and the change was processed correctly.

Ok, it looks like everything is working correctly on your iPhone's mSecure app, so I apologize for not analyzing this correctly from the beginning. You have all your data intact in mSecure on your iPhone, so you should simply need to reset mSecure on your Mac using the steps below. After you do that, then you can turn on syncing again in mSecure's Sync Settings and everything should work.


Here are the instructions for resetting mSecure on your Mac:


1. Open mSecure on your Mac, and look in the top left corner of your screen. You should see "mSecure" in the menu bar. To the right of "mSecure," you should see the word "Help." You'll click on that in step #2 below.

2. Click Help in the menu bar at the top left of your screen. A contextual menu will appear. Hold down the "option" key on your keyboard, and you should see two hidden options appear at the bottom of the contextual menu.

3. Click "Show Data File in Finder", and a Finder window will appear revealing mSecure's database file, which is named, "mSecure.mscb"

4. Close mSecure

5. Move the "mSecure.mscb" file to the trash


Now you have reset the Mac app, and you're ready to sign back in to your mSecure account:


1. Open mSecure on your Mac if it is closed

2. Skip the welcome screens to go directly to the Sign Up / Sign In screen

3. Click "Sign In"


Enter your mSecure account's email address for the username, then enter the NEW password for your account to sign in to it.


Were you able to sign in after resetting the Mac mSecure app? Also, were you able to start mSecure Cloud syncing again, and is everything working?


Iniciar sesión o Registrarse para publicar un comentario