Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Request to Downgrade back to 5.x Pro

I don't mind paying for upgrades per major version but not a monthly plan/yearly plan.

Example 4. x to 5. x

I logged into my computer today and noticed that 6.0 was installed on my machine automatically without my permission.  I understand that since I paid for 5.x Pro I get the stripped-down features of mSecure 6.0 for free.  What this tells me is that once 7.0 comes out my data will be a hostage to upgrade or lose my data.  No Thanks!

I don't do monthly or yearly plans because they stack up easy and I can't keep track they always end up charging me at the worst possible time and I occur a $32 bank fee.

I would rather pay by the version so I decide when to update, AKA: (When I get paid and think your software is worth it.)  With this new pricing plan, you are taking this out of my hands.  So I am forced to take it back by finding another software to use.

I never upgrade to the cutting edge until all the bugs are worked out...  For Example the 6.0

- The Record Editor Fields do not align up correctly on larger screens.

- The Light and Dark Options are Crap compared to 4.x and 5.x versions...

- Forced Premium Trial - No Way to Cancel out of it.. Adds extra crap in the way that I don't need.

- Several of my Records Crash the Software on PC but works fine on my Apple Phone.

I loved your software with my experience 4.x and 5.x and have suggested it to many of my students in the Army where I teach 25B (Information Technology Specialist) MOS.  No Referral because of profiting rules.... but I was glad to recommend it. 400/700 Students a year for the past 4 years. (Your software was a great example of easy it could be to keep up with tons of passwords, without having to recall any of them...)  Many people use one password for everything and a huge security risk.

With the new pricing plan, I will not be referring anyone else and I will not be using your software past the trial version.  I also will be sending past students to ditch the software once I find a suitable solution.  Even if I have to learn C++ and QT ( Open Source and build it myself.

I am so pissed off I could scream!!!

You could have at least given me the opportunity to upgrade when I wanted to instead of being thrust into bug-ridden software and forced to swim.

5 people have this question

@Msta Are you seeing these problems in mSecure 6, or are you referring to mSecure 5?

As another piss3ed off mSecure5 Pro user, for all the reasons previously stated, I want to ask Mike where the discounted pricing for current users can be found.
You have handled this so poorly, I too didn't receive any pre-release email.
So far I can only see full price options available on the App.
I have checked the app installed on Windows, Android and MAc devices.

How do we get the 50% discount you mentioned here?

@mike I reinstalled v5 and couldnt Update, because v6 wasnt available for me in the play store. Apperently the login didnt work anymore in v5. Today the v6 Update arrived. Now I am seeing the problems from my previous post in the updated v6 app.

@Msta It's good to hear you were able to download v6. I'm not sure what you mean when you say, "you are seeing the problems from your previous post in the updated v6 app." Can you explain what you are seeing? If I can understand the problem, I should be able to help.

Just a heads up, if you login to your mSecure account there is a 50% discount available to all V5 Pro users.

I would agree with most of the existing users of Version 5 here who have voiced there anger over the method you've employed to upgrade users to V6 without the opportunity to at least asses the new software before losing access to V5.  To assume your customer base would be happy to transition to a new version of the software at your behest is simply rude and  arrogant. 

What really alarms and concerns me more is that you have the ability and capacity to remove a paid software license from customers computers without their knowledge or consent.  I wouldn't be surprised if your company faces some legal actions as a result.  Your software is supposed to make your customers feel secure in its use with probably their most valuable information.  Instead with this action you have destroyed your credibility and for many, any confidence that existed in continued use of your software.

Mike et all, Ok, I now seem to have made a little progress with the mobile device missing updates that were needed.   In the App Store for mSecure you see only the 'Open' option but it you click on the mSecure name or maybe the icon it then displays the "Update"option.  Not at all obvious and not sure if this a mSecure or Apple issue.  It needs to be made far more clearer to people.  I have now managed to apply the App to my Apple Watch 7 but I need to understand what determines what appears on the watch as I only have two entries.  Maybe there is a flag on the mSecure itself but I have yet to find it.

You asked me if the problems I described a few thread posts earlier relate to v5 or v6. My answer is v6

@Brian It's not up to us as a 3rd party developer on how the updates get pushed out to to users. We either create a new version of the app that causes all sorts of issues with users, or we make an update to the app and do everything to honor long-standing customers. Why do you think we have taken something away from you? As has been said in the emails we have sent out to our customers before v6 was shipped, and as has been said in I don't know how many posts here in the forum, and as has been said in multiple pages on our website, nothing has been taken from you. If you have a v5 license, you get an Essentials account at no cost in V6. Can you please explain to me how it's unfair or that we're doing something wrong when you get a new app, with new features, don't have to pay an upgrade fee, and you don't lose any functionality that you had before? What am I missing?

@Robert Unfortunately, we have been seeing that the update feature in the App Store is working differently for different people. Some simply open the App Store app, and they see the option to Update right when they go to the mSecure page. Others, have to tap the Open button, and still others don't get the Update options after doing that. We honestly don't know exactly how the App Store is doing what it's doing. Everyone should see the Update option immediately upon opening the mSecure page, but that's not what's happening.

For the Apple Watch app, some items will go onto the watch automatically, because we thought those would be the most useful types of records on the watch. If the record isn't on the watch, then you need to edit it, scroll down, and then tap the options to add it to the watch app. After you save the record, it will show up on the watch.

@Msta As you may be able to tell, we're experiencing a very heavy load of requests, and I'm not even sure right now where you previous post is. One issue is fixed, which is good news, but there is something else going wrong, and it would be helpful if you can describe it real quick here so I can help as quickly as possible.

@mike I suggest that I re-post my earlier post here . The problems have all occurred in the v6. I had the misfortune of having to completely reinstall Msecure 5 when the sync havent already worked due to the switch to v6. Now the playstore updated my App to v6. The problems all occurred when I tried to log in to the App v6 with my account after the Update: 1. the login button and the registration button are swapped (in German). If you click on login you get to the registration form and vice versa. 2. after the registration I am not asked for the security key but I could simply log in without security key or QR Code (security problem ?) 3. after the login the app asks me for a backup folder. When I then select the msecure5/backup folder the hint appears that I am only allowed to specify the msecure5/backup folder. Then It shows the hint that I should give the app the rights to access the folder. There I clicked on agree. The app starts normally. 4. I can only scroll down to the heading "synchronization, backup and restore" in the settings menue. The menu items below are not accessible. So I can't see if the backup folder is set up correctly. 5. All menu items under the Sync, Backup and Restore header are inaccessible to me. I would like to use Android Autofill. When is planned to show this option to me ? 6.Also, the linked apps in the "Login" entries have disappeared. 7. The app creates a new "kennword" field, because apparently the entries between msecure 5 and 6 do not match. One time the kennword field is stored with a capital "K" one time with a small "k". Also sometimes there is a field named like the German version "Kennwort"

@mike.  All now appears be working - i.e. the update and the watch queries.  I have two outstanding tickets concerning the way I misread the flash message on the auto-update to version 6 and I am sure this will be dealt with in due course.  These don't have a ticket number as such but are titled 'Upgraded to v6' & 'Version 5 to 6 confusion'

Agreed with most here, this didn't go smooth, and now I have an Android phone with a working secure app that can't sync to my mac book because that app just force closes.
I'm not going to waste much more time on this.  Looking elsewhere. I stuck with you guys for a long time, and I got screwed.  Your coders need some more schooling!

macOS Monterey Version 12.2.1 - Went to your website, that asks me to open the apple store, and re-downloaded the app, soon as I enter my password, which I confirmed on Android it just force closes.  I didn't want to get here, to say this next part, but you're sucking swamp water! 

@Msta Thank you very much for reposting the issues you are having, and I apologize for you having to do that. I'll answer your questions one by one below:

1) I will talk to our developer about this, but I'm not sure what you mean when you say they are swapped. Are you saying that the button labeled Login (in German) is actually leading you to the page where you Sign Up for a new account?

2) If you are registering for a new account, you will not asked to be authenticated using your QR code. Since you're creating a new account, you'll get a new QR code, which will be used for authentication later when you sign in to the account again.

3) It sounds like setting the backup folder is working as it should.

4) I don't know what's happening here, but I have not had any other customers tell me they can't scroll the Settings page down. I don't know how it's possible your device is keeping you from scrolling, and I don't know how to get information on what would be causing it to happen. From what you are describing, the app isn't crashing, correct? When you are in the Settings screen, are you able to scroll the screen at all, or is just simply locked in place no matter what you try to do?

5) The Android Auto-fill feature is enabled in the settings you can't see, so this related to issue #4.

6) I don't know how the linked apps would have been removed, but again, that's not something I have heard from other customers. It could be that some very strange things happened during the upgrade, and it might be best to try to reinstalling mSecure and restoring from a backup of your data made in mSecure 5. Is that something you would like to try?

Login or Signup to post a comment