Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

msecure 6 and i cant login !!! it just times out on windows 10


 i just updated to msecure 6 and bought a 1 year license. now i am not able to log in anymore!!!!

it is just freezing. there is just the "lock" picture without any password line. thats the total horror!

i need my passwords immediately!!!

9 people have this problem

Peter, see the paste few comments from Mike (4 and 5 days ago as of today 4/12) 

Just a quick update on the freezing issue on the splash screen. It is a very difficult bug that's being caused by a framework we don't have control over. The initialization we're calling is causing the app to fail, and mSecure is given no error to handle. Since there is no error thrown, the app simply crashes silently.

We have a work around for what's happening until we get more data on how to handle the problem. As of now, we have not been able to find the true solution we're searching for, but it should come in the future. When you get the new version that will be submitted either today or tomorrow, it will start avoiding the analytics initialization. It does take at least one cycle of crashing for the fix to be implemented, so you may see the crash one more time after downloading the new version. After that one crash, however, you should not see it happen again.

After the app is submitted, it will go through the approval process with Microsoft, which can take anywhere from 1 to however many business days they take for the review. It will be released as soon as possible.

All working now. As of 14 April 2022.

Thank you for confirming the fix @John!

It's still not been fixed for me, my one is freezing after syncing and stays frozen on the passwords page.

Have you downloaded version

Peter, yes (although it was automatic) and is now working as expected!

Hi Jerry, pleased to hear that. Msecure is type of app that we all need and because of the type of information we enter, it is almost imperative that it is available 24/7. The reason we use it is because it is impossible to remember all those things.

yep i am on version

i have tried literally everything and it still doesn't work. i get past the password page and as soon as i get to the list of all my accounts etc it freezes up and nothing is responsive.

The reason the issue is still happening is because you haven't updated to mSecure yet. Your computer will only download the update automatically if you have automatic updates turned on for the Windows Store app. In that case, it should happen automatically. Alternatively, you can open the Store app on your PC, click the library icon near the bottom of the thin left column, then click "Get updates" in the top right.

After seeing your second post, I now understand you're dealing with a different issue than the rest of the users are dealing with in this thread. Your issue is that the app is non-responsive after unlocking. The others were dealing with an issue that made it impossible to unlock the app at all, so that's where my confusion stems from. For what you are dealing with, we're still trying to figure out the cause of it. However, you should only experience the non-responsiveness for about 15 to 20 seconds, and then the app should work normally. That's not saying the behavior is normal or ok, it's simply saying the app should still be usable.

After you open mSecure on your PC, let it sit for awhile until you see the cursor start blinking in the Search field. Is the app functional after it sits for awhile after you enter your password?

Login or Signup to post a comment