Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

Knowledge Base Forums Submit a ticket

Beta Version Crash IOS

Whenever I try to delete a custom template the app crashes - when restarting the template is still there so not deleting. It works on my MacBook but not IOS apps.

@Jon It's good to hear things are working better for the auto-fill, but we still have a mystery here. We didn't do anything to fix or break anything in this area of the app for beta 2, so this is a more complicated issue than it seems. Also, I haven't experienced what you are describing with the Face ID working only about 50% of the time, and we don't have any other testers reporting this. So something else is wrong here.

Just to be sure, when you say Face ID is working only 50% of the time, are you saying it's doing the same thing where mSecure just closes after it tries to read your face?

One more thing, did you try going through the steps I wrote out in my last response? At this point, the first thing we need to do in troubleshooting is simply reset the iOS Password AutoFill feature.

@Geoff Thank you letting me know how many records you have in the app. I think this could have an affect on the what's happening when you search for data. I would like to have you try resetting mSecure to see if that will help. Can you let me know which sync feature you are using?

Mike, Yes I followed your steps about the auto fill problem. That seemed to fix it. As for the other issue with face id i am saying with this second beta version i have experienced intermittent issues with mSecure not opening due to the program not recognizing my face id for my password to open. I dont have a problem in any other app. I didnt have a problem with it in version 1 of the beta. I have hard reset my phone. Like i said it isn't happening every time but is happening.

@Jon It's good to hear that things are working now for the password auto-fill feature. With regards to Face ID, I'm still having a hard time understanding what's happening. With both Face and Touch ID, mSecure doesn't have anything to do with the authentication process. From a high level, the process goes like this:

  1. You open mSecure, and mSecure asks iOS to authenticate you
  2. iOS does it thing with Face/Touch ID
  3. iOS responds to mSecure one of two responses: you are authorized or you're not
  4. If you are authorized, iOS sends back the data mSecure needs, and the app is unlocked. If you are not authorized, then mSecure doesn't unlock.

The important thing to understand is that mSecure has nothing to do with the authentication process. In short, mSecure isn't responsible for recognizing you. That is all handled by iOS. Now, it is theoretically possible for mSecure to hiccup at the point where the authentication data is returned from iOS after you are authenticated, be we have never experienced that before, and no one else is reporting the same behavior you are describing.

Can you try to describe in a more detail what you mean when you say mSecure is not opening due to the program not recognizing your face id? How are you making the determination that your face is not being recognized?

I am still having problems with the program crashing after a login record has been created. It saves the record but the program crashes every time. Thoughts?

Hi Jon,

Our developer has viewed the crash reports you sent, and he's trying to figure out what could be happening. We know that a bug related to what you and one other customer are experiencing was fixed in beta 2, but whatever is happening here is more difficult to weed out. We hope to have it fixed in beta 3, and if possible, provide a work-around in beta 2.

Both IOS App and MacBook Air are still very slow to input any text in search bar. I have 1000 records but this was never slow with previous version

Hi Geoff,

We have run into this problem as well, at least on our Mac computers. I have not seen it happen on my iPhone or iPad though. Have you tried to do anything at all to troubleshoot the problem by chance?

No haven’t tried to troubleshoot. Any suggestions for me to try?
It’s very slow on all my devices, iPhone 12Pro, iPad Pro MacBook M1, iMac. Also my wife’s devices iPad, iphone12 on a separate mSecure account, with less than 200 entries. I am happy to troubleshoot but not sure how under these circumstances

@Geoff I'm not sure how to troubleshoot this either, so I'm going to have to get our developer involved in this. Can you send an email to our beta email address with a brief description of what's happening? Our developer will see that, and then we can try to figure out what's going wrong. The email address is simply:

Ok - have sent email explanation

Thank you Geoff. I did see the email, but I don't think our developer has been able to view it yet. He will be processing any beta emails we receive as soon as he can.

I am still having a problem using Chrome with password authentication. I select the appropriate record and mSecure loads it into the appropriate boxes on the form. But when i hit login (or whatever the progression button is named) it says there is a problem with the password. I can clearly see that the password is there and if applicable I use the show button to verify the password is indeed there. Now if at this point I erase only the password and run mSecure again and it puts the password in the form again this time it works. Thoughts?

@Jon What you are experiencing is not uncommon. The problem is, there are sites that use different types of mechanics for getting data auto-filled into fields. Depending on the frameworks they are using, it's possible the injected password is not being seen by the site. The thing is, if the password is correct, the actual injection code isn't even being handled by mSecure. mSecure is simply handing data back to iOS when asked for it, and after it's handed off, iOS and Chrome take care of the injection.

I can take a look at the site you are referring to just to make sure it's a consistent problem, but, again, if the injection is not happening, that's not something mSecure is doing or can fix. What is the site you are working with?

Login or Signup to post a comment