Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


Msecure 6 bug - Adding and Removing fields

Hi All,

I think I found a bug with Msecure 6.  I've tried this on both the Desktop version, as well as the IOS version (iPad), and both appear to do the same thing.

If you Edit a template and add a field, and tell it to show in the main menu, all works fine, however, if you go back into the template editor and tell it to hide the field after it's been created, it doesn't seem to hide the field.  

Even more of an issue though is if you go into the Template Editor and add a field, and then save it, and then go back into the template editor and delete the field and re-save it, the record on the main menu (list of passwords) still shows the field you deleted.  The record still shows up on the other devices as well.  It's as though you aren't actually modifying or deleting the field you just created.  Once created, you can't get rid of it from the main menu even though the template editor shows the field gone.  If you click on the record in the main menu, the field still exists there as well, even though it no longer exists in the template editor.

Ok.. Looks like user error, not a bug.  Here's what i've discovered in case others notice the same thing.

When you edit a template, you are essentially just setting defaults for new records.  When the record is created the Template no longer has any bearing, so you have to modify the record itself if you change the visibility or want to delete a field.  If you double click on the icon to left of the field name in the record, you can adjust the visibility from there.  You would also want to remove the field in the record if you no longer need it.

Now that I know this, I actually kind of like the feature.  

Hi Geoff,

Thank you for contacting us about this. The way records work in relation to their templates is much different than in previous versions of the app. In older versions, the records were tightly coupled to its type or template. In mSecure 6, this is no longer the case. Once a record is created, it's detached from the template it was created from. This means that in many cases, you will see the type of behavior you are seeing. However, there are also places where the developers added functionality to fix up the records, like when you first add the field you added to the template. The app when through each record that was build from that template, and added the field. That functionality had was added, but the field removal functionality was not, I suppose because it was thought that most won't be adding and then removing a field.

To be clear, this is not a defense of functionality. It's only an explanation. I'm sure this functionality will be updated as we go, but for the first release, this is how things work.

Thanks Mike for the explanation.  

I'm just patiently waiting for the Android app to be updated here in Australia and i'll be happy.  Really liking it so far on the desktop and iPad.

Mike, that’s for the explication on templates. I had this question. 


I noticed that when I look at my records, the fields are all in different order then what the template was. I did nothing to change their order.  If the fields that exist are not in the order of the template and I edit the record, I do not see all template fields.  If the record is in the order of the template and I hit edit I see all template fields even the ones that are blank.  This is very confusing.  I did not reorder any of my records.  Why are all the records in different order?  When editing why do I not see all blank template records even if the fields are not in template order?  This behavior does not make sense when you said that the newly created record is detached from the template.  It is common that when I create a new record I fill in the minimum information and intend to go back later to fill in the rest. If the fields do not show up that is a lot more work on my part.  Can you please explain.  Also, I wish all my records to be in order of the template. How do I fix this?


This behavior I can see on the Mac version and the Windows version.

Hi John,

Unfortunately, I'm having a hard time following exactly what you're saying. I think it's because the order of the fields don't impact how the record is related to the template. There is no relationship to the template after the records is created, so it's hard to say more than that in response to what you saying here. There are some changes that will continue to be made to the way fields get displayed in relation to the record's template, but for now, the changes you make to templates will not always do what you think it will. I know this is confusing if you're coming from v5, but it's just the way it is right now and cannot be changed until sometime down the road.

The main thing I need to know is what happens when you create a new record from a particular template. Do all of the fields show up in the order that you see in the template?

With regards to the order of the fields in the record, I'm not sure how or why they would have been changed. However, I just checked on my Mac, an if you edit the Template and change the order of the fields, your records should reflect the new order. This is a way you can reorder everything even if it has been changed due to something I'm not able to explain.

Hello Mike, thanks for the response.  I’ll try one more time.  It is confusing to me also.  I’ve had mSecure since 2009.  I have modified templates long before version 6.  I put mSecure version 6 on a Windows 11 PC, a Mac laptop, and an iPhone.  All with the latest updates.  After installing version 6 on the Mac I was going down through my LOGIN records.  I noticed that the fields were in different orders from each other. They were not all the same.  When I hit edit I only would see the fields that had data. All blank fields from the template would not show in edit.  This was different from version 5.  When I did the same with the PC version, the fields were in different order like the Mac but when I hit edit I would always see all fields from the template, even the blank ones.  So the Mac and PC version were acting differently.  I started trying various things. I noticed on the PC if I went into a LOGIN record and dragged the fields from an entry in template order for one record then on the Mac if I edit that record I see all fields even the blank ones.  This is what I hope to see.  So bottom line If I go through the PC version and drag all fields in template order I can then see all fields on the Mac when I edit.  STRANGE I agree.  Is there a way or reorder the fields to template order without editing each record?  This would fix my problem on the Mac not seeing all fields when I edit.  Like I say I don’t completely fill in all fields when I first create a record.  I need to see all fields when I edit.  Perhaps not everyone is seeing this behavior but it is what I’m seeing.  I believe the PC version is acting correctly with the exception that the fields may be in different order from one record to another.  The Mac version has the order problem but also will not display blank fields when editing unless they are in template order.  I hope this is clear and you can respond.


On my Mac I cannot edit the templates. When I do then hit OK the mSecure exits and  Problem Report for mSecure appears. I can modify a template on the PC version.  Nothing happens with the field order in my records.

Hi John,

Ok, you mentioned one thing at the end of your email that's going to make it impossible to help, because if mSecure is crashing when you try to save a template change, then that's going to cause even more confusion. You should be able to reorder the fields for a template, and then see them reordered in your records.

Real quick, does mSecure crash when you try to edit every template, or is it just happening when you try to change the Login template?

Mike, when I open mSecure on my Mac and I edit ANY template.  I can make a change or not make any change. If I select OK the program crashes.  If I select CANCEL it does not.  It does not do this on Windows 11 PC.  I tried on an older Mac and it also crashes on all template edits.  Old mac is Intel and newer mac is M1 mac. Please advise. 

Mike, on my old Mac I uninstalled mSecure. I made sure everything was removed.  I reinstalled it.  I can now on that Mac edit a template without the program crashing.  Strange that is did this on two macs.  I have not yet reinstalled on my newer mac. I’ll wait in case you want to gather data for any reason.  This may have fixed all what I was blabbering about.  I’ll check things out after you let me know I can reinstall on the other mac.  I had created a ticket for the crash a few days ago. Nothing has happened with it yet. 

@John Oh, this is great news! If we were having widespread issues with the template editing, I would definitely take you up on your offer to dig deeper into this. However, since a simple reinstall fixed the problem on the older Mac, and we're so buried in support, I won't be able to do that at this time. As long as you have all your data intact on other devices, I would go ahead and do the same thing on your newer Mac. Let's just try the reinstall to see if that fixes the problem.

Mike, I had the old mac working I then deleted the new mac and reinstalled.  After that both mac’s cannot edit a template without the program crashing. I thought it was my data file.  I removed mSecure from all devices.  I removed all of my data files and only had them on external memory.  I reinstalled mSecure on my new mac and it worked fine with a new empty database.  I modified only the LOGIN template and the program did not crash.  I entered data into the LOGING. I then went back to edit the template and the program crashed.  It appears to me that on my Mac I cannot modify a template or the program crashes.  At this point I have no clue.  I cannot make mSecure to work on either mac with modified templates. Even starting over from scratch did not work.  Modifying a template and adding data makes the mac unusable.  

Mike, I narrowed down the bug. I think. If I take my current full database with modified templates I can stop the crashes by sorting my data by NAME.  When this is done there is no crashes.  If I sort my data by TEMPLATE then I get crashes.  On a mac sort your data by TEMPLATE. Then go to edit a template. You don’t have to make a change just click on OK.  See if you get a crash.  I hope this helps to fix this.  

Nice work John! While I can't reproduce the crashing exactly, something is still going wrong when I try to edit a template when the app is sorting data by template. I think the difference is the MacBook I'm using is running Big Sur, so it can respond a bit differently in certain situations. When I try to change the name for the template, however, the Save button doesn't do anything, so I think that will lead our developer to the problem. I have alerted him to the issue, so I hope it will be fixed in the next release.

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen