Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


msecure 6 and i cant login !!! it just times out on windows 10


 i just updated to msecure 6 and bought a 1 year license. now i am not able to log in anymore!!!!

it is just freezing. there is just the "lock" picture without any password line. thats the total horror!

i need my passwords immediately!!!

9 Personen haben dieses Problem

Hi everyone. as of last few days, same problem as everyone else and thanks for the reset suggestion. However this only works once, just so you all know. You can log in once only and all is fine and hopefully the sync to another device will work for you (mine did immediately with no problem) so no data lost. However it does mean you only get one shot at running mSecure then have to go through the reset every time after that first login.  Frustrating, to say the least, as you have to go through the whole setup q's and a's procedure each time after carrying out the Windows reset suggestion.

I am particularly frustrated as I reinstalled a whole new W11 setup, partitioned disk/s, reinstalled etc. etc. etc.  and took a whole 2 days to finally et all my files back thinking it was something to do with Windows. Then ran mSecure and it all worked..............but................only the once, as described. Then blank screen and key logo. It doesn;t freeze btw; you can hit "x" and log out.

rebooting and turning off has no effect in fixing the issue.

I also restored various image backups so took an age, only to then discover this forum.

So, I look forward to my free upgrade to pro/premium when this is resolved for wasting 2 days of my life!

Hope this helps.


PS: personally, the best work-around is NOT to use Windows at all and just get your password info from your phone/tablet which continue to work and sync (in my case iOS).


It has been a busy week, and we are going away for the weekend.  I will get back in touch on Monday or Tuesday, will be glad to use the logging build to assist in nailing this down.

Thank you for your willingness to help with this @Stephen. After getting logging from other customers, we think we have narrowed down what's causing this behavior. We still don't have any idea why the problem is only surfacing on a select number of our users, but we hope to have a strategy in place to fix the problem. We just submitted a new test build, and when it's ready, users who would like to help with this issue will be able to download it. I'll look forward to hearing from you Monday or Tuesday, and if we haven't confirmed the issue is fixed, then it would be great if you can download the latest build to see if we can get better information from you.

@Everyone We hope to have this issue solved soon, and we have a new non-production build that can be downloaded from the Store app. If anyone is interested in helping, please let me know, and I'll send instructions on how to get access to the new build.

Currently it only operates for one session.  I reset the app and log back in but when I close it... it needs to be reset before it will start again.

@Dana That is the behavior everyone's been experiencing, and we think we know why it's happening. Would you be interested in downloading a beta version to help confirm that the new build fixes the problem?

Yes, I'd try it.

Encountered the same issue.  Doing the Windows App reset seems to have fixed it for me for now on Windows 10.  I have closed and reopen several times and still get prompted for credentials and can log back in and access data.

Further to above, although I now have access, I am getting the warning that I onlky have x days left on my Premium Trial, even though I have upgraded to Annual premium.

Trial.png Trial.png
5.46 KB

Same problem after using version 6 for a short while. I don't even remember being asked to update to V6, this was automatic from V5 Pro. This lack of response from support takes me back to when I first used mSecure some years ago and had problems. I am sure I am no different to other users who rely on this and use it many times per day. Can anybody recommend a good alternative? Especially if records can be exported / imported

@Clive The issue you're seeing with the trial is a display issue that is fixed for the next release. For now, if you go to the Account Settings then back to the main view, you should see the trial message go away. Also, it would be best to check in the Account SEttings to make sure your account says it's a Premium account. If for some reason it doesn't, please let me know.

@Peter Have you sent in an email or posted in the forum without a response? This one from you I see is 4 hours old, so I feel like I got to you pretty quickly. We don't work over the weekend, so some of the posts on Friday are just now getting answered. What is the lack of response you are referring to?

The lack of response I refer to, in my personal experience, is from a previous problem. The immediate problem for me (others seem to have had exactly the same problem for weeks) is that we can't login on the windows desktop - no password is requested. I have just received an email, as above, which suggests I go to 'Account Settings', How, pray, do I do that when I can't login?

I am experiencing what sounds like the same problem, but on Windows 11.  Where/how can I download the beta that fixes it? 

Hi Jerry, I am not aware that there is any fix at the moment. Like others I am still unable to access my data

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen