Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


cant login...entering password and it just times out....

I've tried reinstalling....but still the same.Seems to be happening on both my iphone X's and ipad ...but not my mac

Hi James,

Thank you for contacting us and I'm sorry about the issue you are experiencing.  I'm going to guess this is with mSecure 5? Is this happening when trying to unlock (only use your account password) the app after already having signed in or this happening when you try to sign to mSecure 5 after installing or reinstalling the app?

I cant login

Hi Reddy,

What happens when you try to sign in to mSecure? Are you seeing some type of error message? Also, what has let you do this place where you are trying to sign in to mSecure? Are you upgrading from the older version of mSecure, or have you upgraded devices? Please provide as much context as possible, and I'll help in any way I can.

I know my password, etc. I can't log in on my new device. This happens all the time.

@Christine Thank you for contacting us, and I'm sorry for the issue you are experiencing. I'm not sure what you mean here. If you know your password, and you were using mSecure 5 on your old device, you should have no problem signing in to mSecure on your new device. What do you mean when you say you can't log in on your new device? Does it tell you that your username or password is incorrect? If it doesn't, what are you seeing when you find out you can't log in?

Also, do you still have access to your old device, and if so, are you able to open mSecure and view your information on it?

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen