Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

base di conoscenza Invia un biglietto

decryption error

After entering the data on my windows 11 pc running msecure, when i synced with my apple watch through my iphone i am getting decryption error with no title.

As per your instructions i uninstalled the msecure app from my iphone and reinstalled it and then tried, same error is repeating . but one entry i entered in my iiphone for testing , this entry is reflecting in my windows msecure without any errors..

is there any solution?  if not please refund my amount.



Hi Sivakumar,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. While I'm not entirely sure what's causing this to happen, I'll be able to help you get the issue resolved. The only thing I see on your account that might be an indicator of a problem is that you changed your password for your account on March 27th. That shouldn't be a problem, but it's possible something went wrong in the process.

Real quick, can you tell me on what device you changed your password for mSecure?

Accedi o Iscrivitiper pubblicare un commento