Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

base di conoscenza Invia un biglietto


I had been logging on with face recognition.  When I tried to open the app today it didn't go to the face ID screen, but rather asked for my password.  When I entered the password as I remembered it, it said it was invalid.  Then when I went to the next page, it said all my data would be lost if I reset.  If I have remembered my password wrong how can I get a new password without losing all my data.  If my data gets erased, the program is no longer of any use to me and I will  have to reconstruct all my passwords on this or another app.

   Is there a way I can go to facial recognition since the app should remember that?  Is there no way to confirm my identity so the password can be reset?  It seems like a  circular route when it I have to know my password to work through misremembering it.

Hi Cameron,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. I'm not sure what could have caused this to happen, but we don't have any known bugs that cause the Face ID feature to become disabled. There are only a few things we know will cause the Face ID feature to become disabled.

First, it is possible an iOS update occurred, which can reset the security information stored in iOS's "Secure Enclave." That is not something that happens often, but it has been reported.

Second, if the Face ID feature is changed in iOS, all third party apps have to have their Face ID feature reset. A change would be turning off and turning the feature back on and deleting or adding a new face to the system. The feature being disabled in for third party apps is on purpose in this case, because if it didn't work like that, someone could get hold of your phone in an unlocked state, add their face to the system, and then they would have access to any app that unlocks via Face ID.

Third, mSecure can be removed from having permission to use Face ID in iOS's Settings. To check that it still has permission, open the Settings app on your iOS device (not the settings in mSecure), scroll down and tap mSecure. In the screen that slides in, check to see if the Face ID toggle is turned on. If it isn't, turn it on and then see if you can use Face ID to unlock mSecure.

Face ID was enabled for msecure. I turned it off, then back on.   A page came that said "change password".  I selected a new password but when I logged out and tried to log in with the new password, it was denied.  I am very frustrated

   The Face ID is enabled.  How can I get from the password log in page to the Face ID Page?

Did my comment go through?  Face ID was enabled for msecure.  I toggled it off and back on.  A page came on asking for change of password.  I entered and repeated a new password.  I tried to log on and it said "Incorrect password"  I am very frustrated.

Hi Cameron,

I'm not sure what you mean here. Are you saying you went to iOS's Settings and saw that the Face ID permission was already on for mSecure, then you turned it off and back on again? If you did, that's not going to help here. The reason I had you check that permission is to make sure it was turned on to begin with, because there are times when that toggle gets turned off and we don't know why. If the toggle was on when you first went to the Settings app, then mSecure has always had permission to use Face ID, and turning it off and on again won't help.

The bottom line here is that mSecure has to be able to use the password you are entering to decrypt the security information stored in the app. If it can't do that, then there's no way for it to decrypt your data.

Real quick, when you open mSecure, after the lock screen has been displayed for about 10 seconds, do you see the hint you set for your account?

Mike I have the same issue with is not showing the option to turn on Face ID in the Msecure app.  It use to work before, but now it's not there.  I did a re-install of the Msecure as you suggested to Cameron - but that didn't change anything. I have the premium account as well.  I still have the old (4) version of MSecure on my iphone as well..and this one has the option for Face ID.

So if I go to settings on my iphone - then tap on Face Id & shows the old version of mSecure as the app that has requested to use Face ID ...I have attached an image for you..  If I log into the old version 4 of mSecure - there is no option under settings to turn on or use Face I am at a loss as to why it would appear under the listing for Face ID & Passcode on my iphone ???

I'm suspecting that the latest upgrade to IOS software for Iphone has bungled this all up ....

I was able to resolve the issue by turning my passcode on for my I can see Use Face ID in my mSecure app. Now working properly...bizarre

I suspect the problem is Apple’s! (mSecure, as other apps, which must use Apple’s mechanism to capture biometrics, seems faulty.) I am a bearded old man, which is to say, problematic wrinkles for TouchID, odd hairs+wrinkles for FaceID. I have found firmly that the iOS/iPadOS login (from lock screen) proceeds easily through many odd angles of hairy face and wrinkly finger. (Heck, my fourth “finger” is set up as the heel—lower palm—of my right hand. Handy for my easy chair.) But *apps* expecting biometrics aren’t as lax. Such apps include mSecure, a locked Note, CreditKarma, and several others. They get much pickier and won’t accept the very same biometrics—especially FaceID—as readily as the OS itself! So I’ve gotten used to *typing* a password often, instead of using—and repeatedly retrying—biometrics.

@Noella I haven't head this fix the problem you are running into before, but I am glad to hear you were able to get everything working. The one thing I need to make sure of, however, is that you are not now stuck with entering your password to open your phone. There's nothing in mSecure's implementation that would cause your iPhone to have to use your passcode when opening the device. mSecure simply uses the interface Apple provides in authenticating users via Face ID. On a high level, mSecure asks the system to authenticate the user via Touch ID, iOS pops up the Face ID dialog, the user is authenticated or not, and that response is sent back to mSecure (and all 3rd party apps work like this). So mSecure is not responsible for anything happening in the authentication process.

Also, mSecure can't cause the OS to make the user use a passcode to open the app. Whatever is happening with the passcode has to be getting required by iOS for reasons I'm not aware is ever required.

Real quick, are you saying that you now have to use a passcode to open your phone?

No I don't have to use a passcode to open my phone. Everything is working great once again. For whatever reason the option for "use Face ID" had disappeared from mSecure (new version). I should have been clearer when I said I had to turn on passcode for my iphone - I had to turn on passcode under the settings option on my iphone for "Face ID & Passcode".  As you can see from the attached image, it is now turned on.  Once I had done that - then the option to "use Face ID" appeared in mSecure.  What I still find odd though is that the option for the old version of mSecure appears as another app that can use Face ID...I've attached the image to show you what I'm referring to.  I find it odd, as version 4 does not have face ID ability - so why it appears in this list is beyond me.  I turned it on just to see if it would work somehow - but obviously it does not.  

So I do not have to enter a password to open my iphone - I only have to enter a passcode to access the settings for Face ID & Passcode.

Hi Noella,

Thank you for the followup, and it's good to know that everything's working as it should now. Again, I'm not sure what happened exactly, but I do know mSecure isn't requiring you to set the passcode for your device, which I only bring up to make sure you know it isn't a known bug.

With regards to the Face ID being available in mSecure 4, that's a little bit difficult to explain. While the option in mSecure 4 will always say "Touch ID" in the Settings, that version of the app does still support unlock via Face ID. iOS only supports Touch ID OR Face ID on a particular device, and both are similar features that use the same interfaces for third party apps. When you turn on "Touch ID" in v4's Settings on a device that supports Face ID, iOS simply uses Face ID instead. Where the confusion comes in is that the last version of mSecure 4 was released before the Face ID feature existed, so it can't delineate which type of authentication the device has. So mSecure 4 is able to unlock via Face ID, but it still shows "Touch ID" in the Settings.

Well that explains it...I tested it and it works exactly as you say...for mSecure 4.

So, I went to my iphone settings...then went to Face ID & Passcode...I scrolled down and where it said "Turn Passcode Off"... I did.

Then I scrolled up...and where it says "use FACE ID for:...Other clearly shows to use FACE ID for mSecure version 4 and for Version 6.

So now I go to mSecure...I have to enter my password to enter into mSecure...I go to "Settings"...and now there is no option there to use FACE ID ...I

have attached the screenshot to show you what I see now...

Hi Noella,

This is a very strange thing that's happening, as both apps should function in exactly the same manner. I don't know why mSecure 6 is not showing the Face ID toggle. Real quick, I want you to check a different location in iOS's Settings to see if the mSecure 6 has permission to use Face ID. This time, open the Settings app, but do not go to the Face ID section. Simply open Settings to the home screen where you'll see your profile photo at the top, then scroll down on that first page all the way to the bottom section where all your installed apps are listed. Find mSecure 6 (the app with the dark icon) and tap it, and you'll see a screen like I'm attaching.

In the mSecure screen like I attached, does it show the Face ID toggle is turned on? Please attach a screenshot so I can make sure we're in the same Settings location on our devices.

Attached is the image you request by scrolling down and tapping on mSecure 6 app...

Also attached is the image of mSecure 6 settings page that does not show an option to use Face ID

I've also attached a screen shot showing that Passcode for Face ID & Passcode is turned off.... In order for FACE ID to show as an option in mSecure I have to have this turned on...

Accedi o Iscrivitiper pubblicare un commento