Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

base di conoscenza Invia un biglietto

Windows 10 mSecure 6 "object not found" preventing sync

I posted this as a support ticket, but have not seen a response in there for 10+ days, so I'm trying the forum instead.  At the time of the upgrade to mSecure 6 I was running mSecure 5 on my iPhone, iPad, and relatively new Windows 10 laptop.  Things were syncing across all 3 devices via the mSecure cloud as expected.  However, now that all of these have been upgraded to mSecure 6, my laptop's mSecure 6 is not successfully syncing via the mSecure cloud.  It gives me an "object not found" error every time the application is started or when I tell it to sync.  I can keep making changes and adding more records (and I have) and they are retained on the laptop's local mSecure 6 installation.  My iPhone and iPad versions are syncing just fine with each other, but are not getting any of the adds/updates made on the laptop (which is where most of my changes are made).  And the laptop is not getting updates made on the other two devices.  I'm losing control of what info is "right" on which device.

Has anyone else experienced this "object not found" error?

Any ideas on how can I troubleshoot what "object" is not found?  I'd be willing to put in some work to get things fixed up and fully working (I work in software development so I can deal with complex resolutions if needed), but I have no idea how to proceed based on such a vague message.  If it was just a matter of deleting something, or even multiple somethings to resolve that error I'd be happy to do that.

I was one of the users who lost my mSecure 5 groups when the initial upgrade occurred, so I bit the bullet and starting adding tags to hundreds of my passwords, so now tons of them are showing that they were updated.  Hence, at this point on my laptop it is hard to even know WHAT real data (passwords especially) other than tags were updated since there is only a single update date per record that I see.

By the way, in case it matters, I had an older laptop that also had mSecure 5 on it but I do not use any more.  I even went as far as resurrecting it and updating it to mSecure 6 as well, but this did not solve the "object not found" issue on the primary laptop.  It makes me wonder if I may have previously installed mSecure older version on even more devices that I have since forgotten about.  I hope THAT is not the issue.

Help/advice greatly appreciated.

Hi Andy,

I'm sorry for the long delay in responding. It's been incredibly busy after the v6 release, so our response times have become much longer than normal, but things are calming down now.

The issue you're running into is something that happened occasionally in mSecure 5, so it's not unique to the new version. That being said, it could still have been caused by the update, so we just need to get things reset so the sync error doesn't occur.

The first thing I want to do is make sure you were able to get your v5 groups retrieved. If you weren't able to do that yet, and if you haven't gone through the process of updating the tags on your records, then I would like to help with that first. It's possible the process of retrieving the tags might actually fix the "object not found" error.

Also, having the older app running on other devices won't cause the error you're seeing. The problem is getting caused by mSecure not being able to find an object that should be available, and since it can't find it, it's throwing the error message. If the older app is running on a device, it will simply tell you an update is needed once it finds out the account has been updated to v6.

I am not aware how I can re-import my groups without restoring from a backup.  That's not really viable since my last mSecure 5 backup would have been before I added new passwords and changed others.  At this point (2 + weeks later) I'm not even sure what I have changed, but certainly 20+ records (I have nearly a thousand entries stored).  Since I added tags when the groups did not come in, hundreds of records show they are changed.

Is there another way to restore my groups that you have available?

To be clear, losing my groups is the last of my worries.  I just want to be able to reenable the sync (resolve the "object not found" error).

What is the best path forward?


Hi Andy,

In v6 there is now a merge feature when you restore from a backup. What you can do is simply find a backup from before you upgraded, and then when you restore from it, make sure the toggle is in the "Merge" position. That way, all the data you have added since the update won't get overwritten.

One thing I would do just to be extra cautious is make a quick backup on your PC before restoring your data. That way, if something completely out of the ordinary happens, you can restore from that backup. You can make a new backup by clicking the gear icon in the bottom left corner of the app, and then click Backups in the left column of the Settings. Click the Backup Now button to create a backup and store it anywhere on your PC.

To restore from a previous backup, in that same screen in the Settings, click the option to restore from a backup, then locate the backup on your computer and restore from it. Be sure the toggle is in the "Merge" position, and you should get your groups back.

Also, my hopes are that this will fix the "object not found" error, but if it doesn't, we'll continue working on it.

I do not think I have a recent backup made with mSecure 5.  I had been relying on the fact that it was stored in the cloud to be a backup to my local instances.  I searched my computer for *.msib, *.mscc, *.msim, and *.mSecureBackup and all I could find (other than one created by mSecure 6 on 4/1/2022) was an msib from mid 2019 (or other ones even older).  It would have been nice if the upgrade made a backup, but that ship has sailed...

I could recover a file or folder from my Carbonite backup if that would help, but you'd need to tell me what to recover and how to make use of it since it would not be one of the above file types.


I attempted to do a restore (with merge option) from my 2019 backup, but that failed with a dialog box that showed "Restore Error.  Error: Data was not restored. Object not found."  Since I used to use DropBox to sync before switching to mSecure Cloud, I have an mssb file in my dropbox account from late 2019.  But I do not see mssb in the acceptable list of files to restore from.  How else can we resolve the object not found error?


Over the weekend I painstakingly reviewed all (nearly 1000) of the entries in my Windows 10 laptop vs. on my iPhone and recreated any on the iPhone that were missing or obviously discrepant.  I then uninstalled mSecure on the Windows 10 laptop and reinstalled it from scratch.  Since it did the initial mSecure Cloud sync I am no longer seeing the "object not found" error.  So I think I am back to working correctly.

But if this issue repeats I would be hard pressed to stay with mSecure as a long term solution.  It would be far better to know what the "object not found" error really means (as in what record(s) are causing it) so it can be resolved quickly without all of this fuss and before multiple devices get out of sync with each other.  Or provide some kind of troubleshooting tool that can be run when the error first occurs to help self-resolve it.

Meanwhile, I have spent so much energy on this issue that I am not excited to even try the new "premium" features before they expire.  I wish the trial period could have been activated later.


Hi Andy,

Real quick, mSecure 5 had an automatic backup feature, and it only stored those backups locally on your computer. Do you know if you had that feature set up? If you did, you would be able to see a list of backups stored in whatever folder you set for storing them in mSecure's Settings. If they exist, you'll find them opening the app, then click on the gear icon in the bottom left corner, then click "Backups" in the left column. Is the auto-backup feature turned on, and if it is, do you see a list of backups in that screen?

I have something else to try with the 2019 backup you tried to restore from, but I don't want to give those instructions until I find out if you have more recent backups to choose from.

I had a prior issue where mSecure 6 on Win10 wouldn't launch.  I sync to mSecure H.Q. and have also run mSecure on iOS.  I uninstalled and re-installed the app on W10.  After logging in, all data was restored.  I only lost the records that had been entered locally on the PC.

Now, mSecure 6 on W10 reports that the PC won't sync. Cryptic "Object not found".   Changed records are not being synched out of the PC.

Before doing anything, I documented recent changes on the PC side that have not been synched to mSecure H.Q. or my phone.

Instead of uninstalling the app, I effectively deleted PC's mSecure database by renaming the folder below to something else.


* Launched mSecure.  It crashed.

* Launched mSecure again.  Restarted like it was a new install.

* After logging in, all data was restored.  I had to re-enter records that could not be synched from the PC.

* I think I've used mSecure from the start.  I understand it is more complex, but it is also more unstable.  I'll document other issues later.






Hi Craig,

You're running into a known issue that is affecting just a small handful of customers. We're working to get that issue fixed with logging in the app, but I won't be able to get that information from you unless you run into the issue again. If you do, please let us know, because I can get logging from you that will help lead us to resolving this bug.

Also, for clarification, when you delete the LocalState folder like you did, you are deleting quite a bit of files for mSecure including the database file. This is why when you restarted it, it was like a new install. There was no database, so that makes sense. This is actually how reset the app when I'm testing as it's much simpler than reinstalling the app from the Store. However, I don't know why it crashed after deleted the LocalState folder the first time you opened it. Perhaps it was still open in the background and didn't know what to do when it lost the LocalState folder. I'm not sure, since I wasn't there to see what transpired, but everything after that crash worked as it should.

Noticed this morning as I opened mSecure on my windows laptop, that the program was syncing and "object not found" displayed in the bottom of the window...I've attached an image to show you ...

If I close the program, and then re-open it, the same message appears. I'll try re-booting my laptop and see if that clears the error.

Re-booting computer had no effect...the error message still appears. If I create a new record using my iphone, I can see the new record appear on my laptop - so it appears to sync properly...just don't know why it is displaying "object not found"

I can create a new record on my laptop - but it does not sync over to my iphone or my macbook

@Noella It's strange that this issue is only now showing up on your PC. It's a bug we have already fixed, but it's not yet been published to the Store. I just responded to an older email of yours that I missed in our system, so I'll get your email for the Microsoft Store when I hear back from you.

Beta version has resolved this issue! Thank you

No problem at all @Noella!

Accedi o Iscrivitiper pubblicare un commento