Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

base di conoscenza Invia un biglietto

All data lost in unwanted upgrade to 6

Today I started up mSecure, to see this:


Somebody had better fix this, pronto.


Each platform's app stores determine how updates are delivered to devices. We as third party developers don't decide to put a new app on your device, and then hit a button to make it happen. If you have automatic updates turned on on your PC, then updates will take place without your knowledge, and there's nothing we can do to stop it. mSecure 6 is natural upgrade to mSecure 5, so the Microsoft Store downloaded the update to your device automatically, and it installed over the top of mSecure 5.

Onto the issue you're dealing with, I don't know why you aren't seeing your data. This isn't a known bug, but things like this can happen in an update. Do you have your information available in mSecure on any other devices? Also, do you know if you were using the auto-backup feature in mSecure's Backups settings?

 > We as third party developers don't decide to put a new app on your device

You obviously DID decide to upload a new app to the store.  What was mSecure 5 has now been overwritten by a trial of mSecure 6 Premium. This is not a simple update to 5. Yes, I get it, after 30 days Premium will revert to "Essential" or whatever it's called, which apparently has similar feature to 5. Still not 5.

You of course had the choice of deploying mSecure 6 as a separate app that we could opt into if we wanted to. You chose not to do that and instead decided to delete the app I paid for and push a new one.  Even if the new app is the most fantastic gold plated app ever, that's absolutely not what I expected.

And part of the reason to even hold that expectation is precisely for the reason that unfolded -- all of a sudden absolutely critical data was no longer accessible.

As it turns out, after either some number of restarts of mSecure, or some time of mSecure running, the All Items list has now populated. I infer that mSecure ran some background process, perhaps to convert mSecure 5 datbase to a new mSecure 6 format.  Or perhaps it was trying to phone home for some reason and it took a long time to succeed, or eventually timed out. It should not, because as far as I know I have all cloud features disabled.  But who knows. 

I see  in other posts that others have encountered the same issue.  Clearly whatever is the cause did not reveal itself in testing. Which, again, is why you don't push new applications overwriting old ones without opt in.

@Graham Here is what I posted in reply to your other thread...

What do you mean by forced replacement? mSecure 6 is an update to mSecure 5, just like mSecure 5.8 would have been an update to mSecure 5.7. It's the same app in the store, so when an app gets updated, the user either downloads the update manually, or, if they have automatic updates turned on for the app store, the update will happen automatically. There is no way we can make the update happen or stop it from happening. It's completely out of our hands.

For further clarification, if you didn't have automatic updates turned on, the V6 update would not have been downloaded, and we do not have the ability to force you into the update. We, as third party developers, cannot in any way force any update or any app to be downloaded onto your computer or any other type device. It's absolutely impossible, because neither Apple, Google or Microsoft allow it to happen. We can only submit updates to our app, and after it is approved by those companies, they will deliver it to the customer based on their app store guidelines.

In the emails we sent, we were telling all our users that mSecure 6 was coming, in large part so that you could make sure to turn off automatic updates if you wanted to. That way the upgrade would have never been downloaded to your device. We were trying to communicate to you to let you know what was in store in the upcoming weeks, and also let you know that you would get the update for free.

I understand that for a handful of our users, you have experienced some problems after the update, and we're going to help in any way we can. We never want that to happen to any of our users. But you should not erroneously claim things about a company that simply aren't and absolutely cannot be true. Again, to clarify even further, we are not allowed by Apple, Microsoft or Google to force anyone to download an update or one of our apps. It's literally not possible.

... and I replied in that other thread: ... where I show that the announcement emails did not say anything about disabling automatic updates to prevent mSecure 6 from installing.

You're correct, the emails didn't mention that you had to turn off the automatic updates, because that's not mSecure's feature to control. It's simply the way the app stores function.

 @Mike; I have the same issue as Graham, and it was reported since it appeared, and in addition I created a TS ticket again (after receiving the email asking us to raise a ticket of our questions are still not solved.) Still not solved.

So, just to summarize, due to what looks like incomplete testing, I still do not have access to 99% of my passwords in Windows. I would categorize this as a critical bug, still no reply, still doesn't work after any number of restarts of msecure 6....I disabled manually auto-update on my Android phone just to gain access to my password history.

While you' re technically correct regarding auto-update being the responsibility of app store , in all my year of using app stores, I never needed to disable that functionality until msecure 6 :)

I'm almost in the situation to build an application of my own, just to make sure I can rely on it. Password storage is really critical.

Adding that my years of using app stores go exactly when app stores were invented. I'm one of the rare developers of apps for Windows Mobile CE (for fun/usefulness, not production). What I want to say is that I'm not a newbie in this area.

@Vladimir Real quick, with regards to the updating of the app, I cannot say what is happening on yours or other user's devices, I can only say that we cannot force an update to happen on anyone's device. Since you may have some knowledge of a particular feature that Microsoft, Google or Apple expose to make something like this possible, we are not aware of such a feature, and if we become aware of it in the future, we would not use it to force our users into downloading an update for mSecure.

With regards to the issue you are having, I don't know what's causing you to not have access to the majority of your passwords. Are you saying that when you open mSecure and look at the number to the right of "All Items" that you see only about 1% of the number that was there before the upgrade? Also, do you have access to your information in any version of mSecure running on at least one device?

 @Mike: I believe the answer to your question would be apparent once you look at the movie I uploaded to ticket 86625, after second 34. You will see that the count for All Items gets updated from 0 to 657 very strange only after clicking on any of the quick filters.

I am adding here the link to the case, for your ease of use.

I am also a fan on continuing the discussion on that ticket, and update this thread once we diagnose what's happening.

I noted there that this behavior manifests also in version 242.

And yes, I have access to my passwords only on mSecure 5 that I still got because I decided to disable auto update on Play Store. However, I use many passwords on Windows via copy paste, so that doesn't help me very much in Windows.

@Vladimir Thank you for the link to your ticket. I will respond there now via email as you requested.

Accedi o Iscrivitiper pubblicare un commento