Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

base di conoscenza Invia un biglietto

Cannot disable Main, get error message 'Cannot modify user'

Using Wifi Sync, my Main device's IP address changed and my devices no longer sync. I tried the suggestion to disable and re-enable my Main device, but when I attempt to disable Main, I get the error message:

'Cannot modify user [text string]'

What does this mean ? I attempted to search for the text string in msecure with the msecure search, but get no matches. Can you recommend how to debug and correct this error ?

1 persona ha questo problema

using msecure v5.7.2

Hi Jay,

Thank you for contacting us. This error message means that somehow, the app has become disconnected to your mSecure account. We run into this issue from time to time, but we're not sure yet what causes it to happen. The fix is pretty simple, but before I can give you instructions, I need to know in which of your device's mSecure apps is all your data fully up to date?

When I switched from iCloud syncing to mSecure Cloud I also received the message: 'Cannot modify user [text string]'.

So I tried to revert back to iCloud but still receive the error: 'Cannot modify user [text string]'

So now I'm stuck - connected to mSecure Cloud on my main machine (with the mS data) and connected to iCloud syncing on my iPad. I'm unable to make any progress as the main machine reports the error with anything I try to do.

msecure v5.7.2

Hi John,

I'm sorry to hear about the issue you're experiencing here. I believe you are using a Mac computer for your main machine, but if that's not correct, please let me know. What you'll need to do is simply create a backup of your data, reset mSecure on your Mac, and then sign back in to your account. That will get everything synced back up correctly between the app and your online account.

To make the backup, open mSecure on your Mac, then click "File > Backup" in the menu bar in the top left of your screen. Navigate to your desktop, and save the backup there. 

Only if you were able to create the backup file and save it on your desktop, follow the instructions below to reset mSecure on your Mac:

1. Open mSecure on that device, and look in the top left corner of your screen. You should see "mSecure" in the menu bar. To the right of "mSecure," you should see the word "Help." You'll click on that in step #2 below.

2. Click Help in the menu bar at the top left of your screen. A contextual menu will appear. Hold down the "option" key on your keyboard, and you should see two hidden options appear at the bottom of the contextual menu.

3. Click "Show Data File in Finder", and a Finder window will appear revealing mSecure's database file, which is named, "mSecure.mscb"

4. Close mSecure

5. Move the "mSecure.mscb" file to the trash

Now you have reset the Mac app, and you're ready to sign back in to your mSecure account:

1. Open mSecure on your Mac if it is closed

2. Skip the welcome screens to go directly to the Sign Up / Sign In screen

3. Click "Sign In"

Enter your mSecure account's email address for the username, then enter the password for that account to sign in to it.

After you have reset the app and signed back in to your account, click "File > Restore" in the top left corner of your screen, navigate to your desktop, and then open the backup file you just created.

Did that fix the problem?

Mike, sorry for the delay in getting back to you. Yes, it worked easily. Thanks for the very clear instructions.

No problem at all John, and it's great to hear that took care of the problem. Let me know should you need further assistance.

Accedi o Iscrivitiper pubblicare un commento