Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

mSecure fails to launch on Windows 11

Ever since I upgraded to the new version of Msecure on the MS App, It shows the launch screen and nothing else happens.

Ever since I upgraded to the new version of Msecure from the Microsoft store, at least once a day on my Windows 11 computer, Msecure shows the launch screen and hangs.
Msecure works fine on my iphone.

When this error on my Windows 11 machine occurs; (which is now daily), I have to uninstall the Msecure app, reboot my system and then reinstall the app from the Microsoft app store.

As I have a valid license for this product (purchased before the latest Msecure update), this defect/bug/limitation is getting old. 

Please fix this defect and send me a tool to fix my system.

Hi Donna,

I think you have written to us about this either in another forum post or via email. We are currently in the process of fixing this bug, but it's been very difficult to figure out it's cause. It will be fixed as soon as possible and published to the Microsoft Store.

All working now. Suddenly the splash-screen bug problem stopped . Hooray!

That's great news @John. I'm guessing the updates was downloaded onto your PC, so you should be in good shape moving forward.

Yes just checked version and guess it updated automatically. I hadn’t noted what version was before but anyway it miraculously just went back to normal so guess the latest version you mentioned “does” fix the problem, as you say. “C’est la vie”.

@Mike...I'm still on the beta version on my update to coming across from Microsoft Store

@Noella You should be able to download from the Microsoft Store. The way their system works is that the user should get access to the highest version number that's available in the different channels. You have access to the beta channel and everyone has access to the production channel, so you should get the update. What happens if you close the Microsoft Store app (if it's open already) then open it, click the Library button in the bottom left and then click "Get updates" in the top right? Does it show an update available for mSecure?

@Mike  Version does not show as an update for me. I am still on the beta version  The method you describe is the normal way that I have been checking for updates to my apps on my PC.... and it does not show the update available for mSecure.  So it appears that I do not have "access to the production channel".  I also tried rebooting my PC...the only thing I did not try was to remove the app and then go back to the app store to see what was available. I was leaving this as a last resort until I heard back from you in case there was something you wanted to verify on your end with the beta version.

@Noella I'm sorry this hasn't been working right. I'm still not sure what's going wrong, but I removed you from the beta group. I wanted to keep you in there for future testing, but we'll just have to add you back in when there are newer builds available. After removing you from that list, are you able to get 258?

@Mike...yes... now I am seeing the update to on 258.  Any time you want me to test, I'm available.

Everything is working perfectly!

Connexion ou Inscription pour poster un commentaire