Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

Msecure V6 Desktop for Windows

I have been trying for days to get any kind of help relating to a problem with the desktop version for msecure on my Windows 11 PC.  I have submitted several tickets but apart from an automated response that is all I have heard.  The programme literally just stopped working.  I have tried to redownload from the Microosoft store as it suggests but that just tells me that I already have msecure.  There is nothing to click so I can't get any help at all.  I've attached a screenshot.  I use the desktop version constantly so it is extremely frustrating but the worst part is there is no-one who is helping.  In the past when I have had problems the support has been fantastic so not sure what is going on.  I appreciate that you are busy but a week to answer a question is unacceptable

1 personne aime cette idée

I am having the exact same issue as others with the hanging of the splash screen under windows 11.  Is  Msecure going to provide a solution to *all* its paying users, or should we all start asking for a refund?

Same issue for me in Windows 10 Enterprise edition. 

Now I have to consider how to get my passwords onto my work PC but I thankfully have mSecure installed on an iPad, iPhone and Mac. I'm thinking I'd better make some kind of backup in case the whole damned thing goes bye-bye!

Just a quick update on the freezing issue on the splash screen. It is a very difficult bug that's being caused by a framework we don't have control over. The initialization we're calling is causing the app to fail, and mSecure is given no error to handle. Since there is no error thrown, the app simply crashes silently.

We have a work around for what's happening until we get more data on how to handle the problem. As of now, we have not been able to find the true solution we're searching for, but it should come in the future. When you get the new version that will be submitted either today or tomorrow, it will start avoiding the analytics initialization. It does take at least one cycle of crashing for the fix to be implemented, so you may see the crash one more time after downloading the new version. After that one crash, however, you should not see it happen again.

After the app is submitted, it will go through the approval process with Microsoft, which can take anywhere from 1 to however many business days they take for the review. It will be released as soon as possible.

@Mike The issue is only in Windows, and it's just localized to the initialization of Microsoft's Analytics. The entire system isn't going "bye-bye."

Hi.. I was facing the same problem, and minutes ago it started working again for me.

@Everyone The approval for version went much faster than I thought it would, so it's now published and available in the Microsoft Store. Please check the Store app for the new version, and the issue with mSecure freezing on the splash screen should be solved.

@Khalid I'm assuming you now have version, but if you weren't able to download it yet, we have had reports that the freezing comes and goes on some people's PCs.

Mike, it's showing for me still, but it's working.   

Mike, I confirm have download ver and the app is now working with windows 10 i.e. open app and get log in box - much appreciated in the rapid turn around in fixing this and keeping me informed well done. Martin

Thank you for confirming the fix @Khalid and @Martin.

I just started having this problem today. I use MSecure desktop very often. Thinking it was a problem with the trial, I subscribed on my phone. Desktop still not working. Tried to redownload from Windows store, seemed to be stuck. When I checked my apps list it was there saying "downloading" twice. So I deleted 2 entries. Then miraculously it is listed again, with an "open" button. When I clicked that it opened the program, and I actually think it bypassed the password screen, and went straight to my list now that I think about it. Once I closed it, now it is back to not opening from my shortcut or from windows 10 store app list. This is a major problem, I use the desktop far more than the phone.

@Danielle I'm not sure I'm following what's happening here, and I'm not sure if what you're dealing with same issue described in this thread. When you open mSecure on your PC, what happens? Do you ever see a field to enter your password, or do you only see a dark gray screen with the mSecure logo on it? 

I have the same issue as previously described (no place to input password). Also, when I try to do anything in Microsoft store, it may say any of these things in random order: checking product files / almost ready / downloading. But nothing seems to come of it. I assume since there was an update that the Store is trying to do that, unless it was the update that broke mine.

@Danielle You're dealing with an issue that was fixed in the build that is now in the Microsoft Store. Please check for updates in the Store app, and make sure you have that new build. It should fix the problem you're dealing with here.

  • Well, if you'd read my comment you'd know it was having a hard time updating. It did eventually complete the update to the new version and it is now working properly.

Connexion ou Inscription pour poster un commentaire