Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

mSecure 6 Crashing on MacBook Pro

Hello - I have tried to install mSecure 6 on my MacBook Pro 16 (2021) and it continues to crash after attempting to sync over iCloud. I have tried the method of deleting mSecure and reinstalling, as well as deleting/trashing the data file in FIND via the option key in the 'Help' menu method. PLEASE HELP!

5 personnes ont le même problème

Hi Michael,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. Before we do anything to troubleshoot this problem, do you have access to your information in mSecure on at least one other device? If so, what type of device is it, or what types of devices are they?

Same problem here on a Macbook Pro M1 14”. Msecure 6 works fine on my iPhone and iPad iOs. On my Macbook it just directly crashes after login. After a reinstall, it crashes during the first sync (Msecure sync)

Yes, mSecure 6 works find on both my iPhone 12 Pro, and my iPad Pro 11inch, and I am able to access all of my saved passwords. it crashes on two of my Macbook Pros (16inch and 15inch)

...I should also say hat the crash occurs during the first sync attempt (roughly as it reaches item number 200)

Is there any update on my problem?

I am still waiting for a solution too. Same problem, Msecure works fine on iOs but on MacOs it directly crashes after login.

Same for me Mac Book pro (intel / Mac OS 12.3), msecure crashes after auth. (both fingerprint and pwd.

It's extremely annoying!!! 


I am also having the same problem of Msecure crashing after login on Mac Mini running OS 12.3. The app works on all other iOS and PC devices.

After reading one recommendation, I tried setting up another administrator account on  my computer, and reinstalled the app under that user name. I actually got the Msecure to open but when I tried to sync, it crashed again and continued to do so at subsequent re-logins.

Please help!

Having the same issue. Followed the steps to delete the files in the main folder, and the iCloud backup files. It starts fine but before completely syncing, it crashes. 

Works fine otherwise on Windows platform, iOS and iPad.

@Everyone I'm sorry for the long delay in responding. It's been incredibly busy after the v6 release, so our response times have become much longer than normal.

We don't know why this crash is happening, and it only seems to be affecting a small number of users, which is strange. We can get this fixed, but we need to get logging information to figure out what's causing the problem. Before I talk about logging any data, have any of your tried simply turning off syncing altogether? You may not be able to get to the Sync Settings in the Mac mSecure app, but if you have another device running mSecure, then you could turn it off on that device. Syncing is an account-wide setting, so that it was turned off will sync over to your Mac mSecure app. After turning off syncing, does mSecure still crash?

Hi Mike - thanks for helping us with this issue.

So I logged into my VM (Windows 11) and launched the application and it worked (as usual as no issues with Windows as reported).

I disabled the sync.

Went to the MAC side, launched the app, didn't work. Open the files folder and deleted the local copy of the database, and relaunched the app and it worked fine but showed 0 records.

I went back to the VM, enabled the sync and it showed it's syncing and finished on the Windows side.

Went back to MAC, showed it's syncing and finished syncing all records with no issue or crashes.

Locked the app, and then used the finger print to log back in, and no issue or crashes.

I shut down the app, turn it back on and it started with no issue or crashes. Looks like this is the solution.

I will report back if crashes happen later.


Can't find the local DB copy, where is it stored ?

searched in  "~/Library/Containers/com.mseven.msecuremac" folder structure.


Mike - So I tried your solution from your post suggesting turning off the sync setting account wide, and that stopped my MacOS devices from crashing after deleting the data file and re-signing in for the last time. However, as soon as I turned back on sync (from my iPhone), the Mac based apps crashed on both of my MacBooks (one is 16" 2021 M1, one is 16" 2019 i9). 

I also tried Ahmed's processes to the tee, and still no luck. 

Reposting as I think my previous comments were lost.....

Mike - mSecure,

I tried your solution of turning off syncing from another device (used my iPhone) and tried restarting mSecure (from a fresh install point, after deleting the data file).....This seemed to stop the crashing on both of my MacBook Pros, with both starting up normally, but with 0 record. Once I turned syncing back on however (from the same iPhone), the app on BOTH MacBook Pros crashed again. 

Connexion ou Inscription pour poster un commentaire