Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

Ver5.7.2.1300 cannot see backup files

I'm an Android user.  Got a new phone and installed mSecure5 today.  I have been using mSecure4 previously.  Ver5 does not see the prior backup folder from Ver4.  As a workaround, I manually copied a Ver4 backup file to the "Download" folder.  When I navigate to the "Download" folder where the backup file is, Ver5 says "Empty Directory", which makes it impossible to perform a restore.

Is there a trick to getting Ver5 to see the Ver4 backup file?

Thank you!!


Hi Gary,

You should have no problem at all restoring from a backup file in any publically accessible folder on your device. You can use the instructions in this article to make the transfer: Transfer information from mSecure 4 to mSecure 5 on your mobile device

mSecure 5 uses the default file explorer features in Android, so you can simply tap the Restore option in mSecure's Settings, then navigate to the folder where your backup file is stored.

Mike, I know how to navigate to the prior installation folder. I have been building computers since the days of dos when we ran memmaker thinking it was helping. MSecure5 says Empty Directory. When I browse my phone using my pc, I can see the msecure directory created by version 4. I was also expecting to see a MSecure5 directory. There is no such directory. Is ver5 installed in a different root folder? Thank you.

I'm not sure what you are needing here. My last post was an attempt to help you get your data restored, but now I'm not sure what you are wanting when you talk about directories. When mSecure is installed, it's installed wherever Android puts it. I'm actually not sure about how to find that. mSecure 5 will create a folder for itself in the public directory space, and that folder should be called "mSecure5." That folder is where mSecure 5 places it's local assets, like photo attachments, backups, custom icons and site icons. You will only see data in that folder after it's being used for awhile.

I'm sorry  I'll try to be more clear.  When you upgrade from Version4 to Version 5, you conduct a Restore once Ver5 is installed.  I installed Ver5 from the Google Play Store.  Everything went fine up to that point.  I opened Ver5 and, of course, there are no entries.  I went to the Restore option and the "url" at the top of the screen indicates I am at "mSecure5/backups".  I browed up 1 level, then up 1 more level so that I can see a directory called "mSecure".  This is the folder created by Ver4 and I know there are many backup files in there, but Ver5 says "Empty directory".  I have used Ver4 for years and I use it almost everyday.  The  mSecure directory is not empty.  It has numerous backup files in it.  As an attempted alternate method, copied my latest backup file from the Ver4 "mSecure"  folder into my "Download" folder.  I then re-launched Ver5 and browsed over to the "Download" folder.  Ver5 says "Empty directory" even though a backup file is there.

I have performed the Restore function previously while using Ver4.  It's super simple to do and it takes less than 1 minute.  I tried installing Ver5 on 3 different phones, all OnePlus variants (Oneplus 6, OnePluse Nord, and OnePlus 8T).  I get the same problem on each phone.  I then installed Ver5 on an old Samsung Galaxy Note 4 and it works.  It allowed me to browse folders and allowed me to do a Restore from a Ver4 backup file that I placed in the "Download" folder.  In summary, Ver5 works on the Note 4, easy peasy.  Ver5 does not work on any of the OnePlus phones.  The Note 4 is running Android 6.  The OnePlus phones are running Android 10 and 11.

Thank you.

Hi Gary,

Interestingly, I think we have another customer dealing with something similar here, and I believe it's a brand new issue that has arisen with a recent OS update. First, can you let me know what type of device you are using? Also, what is the version of Android OS the device is running, including all numbers and decimals in the version number.

When transferring the data from the old mSecure app, the process should be very simple. It's just a matter of creating the .msim backup file, then restoring from that file in mSecure 5. However, something seems to be happening on at least one Samsung device where mSecure isn't able to see the data stored in certain directories. When using the file explorer app on your device, are you able to find a folder named "mSecure5" the root of the device's SD Card? It should be in the same directory that you see the Downloads folder in. If you see an "mSecure5" folder, open it and let me know what see in the folder.

I'm sorry.  I'll try to be more clear.  I installed mSecure Version5 on 3 different OnePlus phones. (OnePlus 6, OnePlus Nord, and OnePlus 8T)  Version5 will not work on any of those phones.  They run Android 10 and 11.   mSecure Version 4 works flawlessly on all 3 devices.  Version 5 will download from the Play Store and will install and launch without a problem on all 3 of the OnePlus devices.  Of course, there are no entries in the app right after a fresh install of the app.  The Restore function in Version 5 does not see my old backup files from Version 4.    The "mSecure" folder created by Version 4 has many backup files in it, but when I browse to it during the Restore process in Ver5, the app says "Empty directory". 

Just for fun, I installed Ver4 on an old Samsung Galaxy Note 4 and restored my data.  That went fine, easy peasy.  I then installed Ver5 on the Note and did a Restore of the Ver4 backup file.  It worked just fine.  Easy peasy.

In a nutshell, Ver4 works on every device.  Ver5 does not work on OnePlus devices.

mSecure version 5 is not creating any new folders on the OnePlus devices.  I browsed my phone sand there is no "mSecure5" folder.  This is odd because the app is clearly installed and sorta functioning.  It does create an "mSecure5" folder on the old Galaxy Note that is running Android 6.

The OnePlus 8T is running Android 11 with Oxygen OS  The OnePlus Nord and OP 6 are running Android 10.

Hello Mike,

Ik do have the same issues as stated by Gary. I've got a new mobile, Samsung S20+ with OS Android 11 en One UI 3.0.

I migrated Msecure 5 from my old S8 to the new one. Signed in with my Msecure account and tried to syncronize Msecure. That did nothing. Then I tried to restore a backup, which I had made on my old S8 en copied to Dropbox. But when I want to copy it to the directory \Msecure5\Backups on my new one, the directory Msecure 5 do not exist. 

Next I deleted the Msecure5 App, restarted the new mobile and installed Msecure5 from Play store. After signing in and authorizing my account to the device, syncronizing still does not work. Also no directory Msecure5 on the device. Then I created the directory mSecure5\Backups on the root of the internal storage and copied the backup file to that dir. Unfortunately  restore do not find any file in that directory. Even if I copy the backup file to the documents dir, restore do not find the file and reacts with 'empty directory'.

Whats next???

I have submitted a ticket at 12:40 CET today.



Thank you for following up here in this thread. We are getting more and more information about what's happening here, but we are still not sure of the cause. I have spoken with our Android developer, and his main priority now is to weed out what's causing the issue, so we hope to have a release with a fix very soon. As of now, the only work-around we know is to restore data on a different device not running the latest versions of Android, then sync the data over to the newer device using mSecure Cloud syncing. Do you have a different Android device not running the latest OS, or do you have a computer you can install mSecure on?


Same thing goes for your situation, but it looks like you are able to restore your data on an older device. After restoring the data on the older device, go ahead and set up mSecure Cloud syncing to sync the data over to mSecure on your newer device. It could some time for the sync to complete, as that is another side effect of the problem, but it should finish successfully.

Mike,  thank you!!   I can confirm this temporary fix works.    I was able to sync to mCloud with the old Samsung and get the data to my new phone.

Hi Gary,

That is great news! I have a couple more important notes as you continue to use mSecure before a fix for this issue is released. The one thing we do know is that no data mSecure stored locally is able to be written to the device's internal storage. So things like site icons for your Login records and auto-backups are not working. Also, as you have probably found out, it's not possible to create a manual backup either, which is also failing because mSecure can't write data to the internal storage.

All that to say, if you have a desktop computer or another device you can install mSecure on, that would be a good idea. Your data is stored in the mSecure Cloud as long as you leave mSecure Cloud syncing enabled, but since we don't know all of the problems this issue is causing, it would be best to keep your data updated on a different device until we are able to release a new version with the needed fixes.

Hi Mike. I'm using on Samsung Note 20 (Android 11), and I'm facing the same problem where the app can't detect the backup file that I have transferred from my old phone.  The only message that I got was "Empty Directory". Hopefully this can be resolved soon!

Hi Mike, I also have the same issue, the new app does not read from existing folders and does not create the mSecure5 folder or new backup files. I'm using mSecure version on Samsung Note 10+ (Android 10).

Connexion ou Inscription pour poster un commentaire