Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

password no longer works - Mac

I am using v 3.5.7 on a Mac.  Yesterday went to use software and my password no longer works.  I get an error message.  I know see using this support site that there are newer versions available.  So once I can get into my account I would like to know the best way to update versions without having to type everything back into it.  Thx  Doug

Hi Doug,

Thank you for contacting us and I'm sorry about the issue you are experiencing. mSecure 5 is the first and only version of mSecure to use and account system. mSecure 3 does not have any kind of account system. It simply uses a device specific login password to protect your information locally on your device. Do you have mSecure 3 or 4 on on another device where you information is available and accessible? I ask because if you have forgotten your mSecure 3.5.7 Mac password, you will need to reset the database file and create a new login to be able to use it again. If you have the information on another device, I can provide you with steps on how to do this and sync in your information from another device or restore your information from a backup file.

Thanks for getting back to me. I have not forgotten my password the software just does not recognize it. I have a hard drive backup but don’t know if this file would have been backed up.

We have no known issue with login passwords in any version of mSecure besides mSecure 4 for Android. That version can often add a space to the login password when you are first creating the login password in mSecure 4 for Android. If the app is not accepting your login password, you are not inputting it exactly as it is. Additionally, each mSecure backup file is encrypted with the login password (mSecure 4 or below) or account password (v5) used at the time of its creation. In order to restore from a .mscx or .msim backup file, you would need to know your backup's password.

To find the database file in mSecure 3 for Mac and reset your database to start over:

  1. Quit mSecure on your Mac
  2. Open a Finder window and using the menus at the top, select the ‘Go’ -> ‘Go to Folder…’
  3. Enter
    ~/Library/Containers/com.msevensoftware.mSecure/Data/Library/Application Support/mSecure
    If using mSecure 3.5.6 or below or our website version: ~/Library/Application Support/mSecure
  4. Click ‘Go’
  5. Move the mSecure.mscm file to the trash or rename the file
  6. Re-launch mSecure

That location would also have a Backups folder with .mscx or .msim backup files that you could restore your information from if you know the backup's password.

You now have a documented case where a password does not work for version 3.5.7.  to the right of the place where one enters the password the padlock is open - if that means anything.  I have the password written down and enter it as it should be.  So its not that I have forgotten it ---- it just stopped working.    Thanks  Doug

I understand how you feel that this is a case of the login password simply not working, but I do not believe that to be the case. You could have written the password down incorrectly or changed the login password at some point. However, you can see if this is an issue of the app being damaged by uninstalling or removing mSecure 3 and redownloading the app again:

Note the reinstalling mSecure 3 will not affect the mSecure 3 information on your computer unless you use something like Clean My Mac which will remove the database and preferences file when uninstalling an app.

Did you find a solution to this?  I am having the same problem. I use mSecure 3.5.7 on my mac.  It was fine this morning, then I upgraded my OS to High Sierra (10. 13.4).  Now mSecure says my password is wrong.  It isn't.  In addition, the password hint is not set and I had one.  Lock symbol is open.  I have not tried uninstalling and reinstalling mSecure 3 yet.

Hi Carol,

You might be experiencing a completely different issue here. Could you please do a Spotlight search for ".mscm" and open the Finder with the results? I suspect that you might have several database files and you are currently opening a different database file that has a different login password and password hint. Please let me know if you find multiple .mscm database files and their locations. You can close mSecure and double click each of the files to have it open that database and try to login to the database. Hopefully, you can find the correct database file here.

I was told it was me not remembering my password. I wrote it down and put in my safe. It is correct just does not work anymore. I will have to enter all this data again. I will use a competitor since this failed

Yesterday, after my post here, I deleted mSecure3 on my mac and reinstalled using the download from the website (note: my mac app store only showed mSecure5 and did not show it in the purchased folder).  This did solve my problem.  When I relaunched mSecure it showed the correct hint and took my password.  Whew.

Writing something down does not mean that it was written down correctly unfortunately or that the what was written is necessarily for the correct app or login or account. All that said, I understand your frustration on losing access to your information because the login password is incorrect here. Please let me know if there's anything else I can do for you here.

Not just a Mac issue, I have the same on my windows Dell and I know my password, nothing has changed. Worked fine 12 hours ago, now not. Haven't even opened my laptop in between. Please fix. 


I don't understand what you're saying here. The original poster was talking about a password issue. Are you saying mSecure is not accepting your password? Is it telling you the password is incorrect?

We experienced a server outage today (Monday, Feb 12th), so maybe that is what caused the issue you're experiencing. However, I need to know whether or not mSecure is telling you your password is incorrect or not, because that issue would not be related to the server outage.

Connexion ou Inscription pour poster un commentaire