Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure


can't sign in with iPhone

I am not able to sign in on my iPhone,  we have tried repeatedly.  it is the same password for mSecure on my laptop and my iPad

A portal account has been created and follow the link that was sent to activate my account and select a password!- It was authenticated nut unfortunatley I still can't sign in with my iphone

As I continue to have problems, the email sent me to this forum to contact you again

I have been using msecure for many years and never I ever face this kind of difficulty, until I upgraded to msecure 5 which is very frustated 

Is there a customer support number that you can provide for assistance?

2 personnes ont le même problème

Hi Dillian,

 Thank you for contacting us and I'm sorry about the issue you're experiencing. As the portal support account creation email should tell, it is in no way related to our mSecure account system or app. Please create an mSecure account in mSecure 5 or on our website here:

Note: we do not have phone support

Thanks for your response. Unfortunatley I was doing what you just suggested the whole afternoon. I even deleted the app and re-installed many time thinking that will resolve the isssue to not avail.

I'm incredulous that you suggested "it is in no way related to our mSecure account system or app. then Please advise were is the fault? 

I have no problem signing in with my Macbook and IPad, the problem relys with my iPhone which dosen't make any sense

Same for me

Yes, people often forget their mSecure account. 

Unfortunately, there is not a lot we can do in these situations. In order for the information stored in mSecure to be as secure as possible, mSeven Software doesn't acquire our customer's password or the data stored in mSecure, so there is no way for us to retrieve the password or your information. Also, in order to keep your information from being accessed without your permission, it is not possible to bypass or change the password when mSecure is not accepting the password being entered. The only thing we can do here is reset the app, but that means all of the data stored in it will be lost. I'm really sorry I don't have better news here.

If you have forgotten the account password, you can go here to reset your mSecure account and create a new account password:

I can't open my mSecure on my iPhone.  The hint doesn't make sense and I have never changed my password so I can't figure out what to do. Help.


Hi Carol,

Thank you for contacting us and I'm sorry about the issue you are experiencing. It looks like you just created an account on March 19th, 2018. Have you forgotten your mSecure account? Here's a guide in case you've forgotten your mSecure account password:

I have used mSecure for years, with Terrific success. This inability to access my account on my iPhone boggles my mind. This is an indispensable iPhone app. So wherein does the problem lie if not within the app? My old and new iPad app perform so far without a hitch. So now what? Left high and dry? Is my only option to figure out how to print out my data, close out this account (how?) and then start afresh, hoping the iPhone app will work? Paying for another account? You have a great app, just so very disappointed with this situation. 

Hi Sue,

Thank you for contacting us and I'm sorry about the issue you are experiencing.  I'm not quite sure I understand your issue here. mSecure 4 and below has no account system. mSecure 5 has an account system. This has confused a lot of our customers in the password. 

You created an account for the email address you are using on this website on Feb 24th 2017. You then did an account or password change on June 01st 2017. This account is only for mSecure 5. If you have forgotten your account's password, you can go here to troubleshoot your issues:

Sorry for creating confusion within my email. The issue: I cannot log into using mSecure app on my iPhone. Never had any issues up to now. I enter my password which I have not changed in a year. Nothing happens. No problems on my former iPad and now my new iPad. I am lost with the inability to access my passwords. It seems I am not along with this issue. Hoping you can help! Thanks, sue

Which version of mSecure are you using on your devices though?

If you're using mSecure 5 on all devices, and you have access to mSecure 5 on at lest one device, you can always change your account password to potentially fix your issues here:

I am using the same password for the last year, at least. I actually don’t remember changing it recently. The same password works on my iPad.

Ok but can you let me know what version of mSecure you are using on your devices.

It worked! Logged in on iPad with old PW. Changed PW. Removed app on iPhone. Turned phone off Turned phone on Loaded mSecure app again. Logged in wth new PW. Got in! However, the iPhone procedure should be done in this order. Just entering the new PW did On the iPhone did not work. I was lucky that app was working on my iPad. Thanks so much for that successful suggestion. 

Les commentaires de cette discussion sont désormais fermés !