Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

Non sélectionné

Support for Windows 7

I'm still happily using Windows 7 on my work laptop and would very much like to access my passwords. Now I am forced to use version 3 and sync the passwords manually. Is there a way to install the Windows client for version 5 on Windows 7?


3 personnes aiment cette idée

Hi Steve,

Welcome to the discussion :-) Unfortunately, I do not understand your question here. However, we have no current plans to make mSecure 5 available on Windows 8 or below. Also the end of life support for Windows 7 ends in 2020 :-/

Yes, but it’s one year stil until 2020. MSexure has many fields that can’t be migrated to another password manager, so we’re trapped in 3.5

I am also an msecure 5.5 user looking for an alternative to Windows 10 (for me, Win10 is too network-invasive of my PC to feel secure,  and of course Windows is the obvious hacking target for all the crooks out there). So I am now migrating to Linux (Mint, i.e. basically Ubuntu). A shame that the msecure folks did/do not provide an .exe version of msecure 5.5,  as that would presumably be (more or less) accessible to Linux users via Wine.

But I understand msecure's commercial philosophy, most of the market is with Windows 10, so they need focus on that to survive. Those of you out there making irate comments should cut them some slack...

Another Win7 user here, not planning on switching main workstation to Win10 any time real soon (if it ain't broke...). So far mSecure is first program I use which is now incompatible in a new version.  M$ can say all they want about ending support, but Win7 still accounts for 20-35% of the installed base (depending on who you ask, and that's not counting all the Win Server versions based on Win7).  They've extended support in the past, so who knows what will really happen in a year (enterprises are always slow to adopt).  Ultimately it's up to developers to decide which OSs to support. Dropping Win7+8 is a bit ironic IMHO because out of all the major OSs, Win has always been the easiest to keep backwards-compatible (yes, I'm a software developer also).  Guess it's mSecure v3.5/4 only for us dinosaurs.

As it's very frustrating not to baaa able to use latest msecure on win 7, I found a trick :I've installed an android emulator as droid4x and mSecure5 in it. It works perfectly and I'm still using my lovely win7. Have a try!

Les commentaires de cette discussion sont désormais fermés !