Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Soporte mSecure

Syncing issue on Android phone

Hi All,

I currently have ticket 105690 open for this, but it's been ongoing for 3 days and apart from the original response from the case owner, there has been no other action, and things have got worse.  I'm getting pretty desperate so i'm now posting in the Forum as well.

I am running the latest version of Android on my Pixel 7 Pro, with the latest version of mSecure  

Basically, all my devices appear to be syncing okay at present except for my Pixel 7 Pro running Android.  It will sync fine one, but then if I do a second "Sync Now", most of the records are no longer in their respective vaults.  If I do another Sync Now, it corrects itself, but then another Sync Now, reverts back to not being in the respective vaults.  Rinse and Repeat.  Basically every second Sync Now is getting old information.  it's almost like there are two versions of cloud data for the Android phone.  I use the Cloud sync option for all my devices.  All the others appear to be picking up the right version, but not the android phone.

I've tried rebooting the phone, uninstalling the app, re-installing the app, deleting old backups from the phone, restoring from a backup file, and even tried re-installing, and just letting the sync automatically happen, but again, when I do a Sync Now, it picks up old information every second time I do it.

In case anyone is interested in why I keep having to do a Sync Now, it's because I had a question about syncing and was told by mSecure to follow steps to try and reset the sync and thinking it may have been a glitch that I was experiencing instead of a feature, I followed the steps.  This resulted in loosing all the records on the android phone initially.  Then I managed to stuff it up on my iPad as well, and then on the PC.  I have a backup which is great, but the backup doesn't restore what's in the various vaults, so i've been meticulously updating all the vaults, and had several syncs done.  Also, on the android phone, it's not always obvious when a sync is happening or completed, so I often feel like I have to press it again if nothing changes after several minutes.

Anyway, all I want to do now is get my Android Phone to pick up the same data the PC's and iPad are using and be all synced up.  It's too unreliable at the moment because every second sync results in records being in the wrong vaults.

See the screenshots attached.  One shows the Private vault to have records (this is wrong), and the other shows no Private vault because the other vaults have the records (this is the correct one).

Can anyone please assist asap?



Hi Geoff,

Thank you for writing this up in the forum. However, I just saw your email correspondence with Nick, our other support rep, and I'm going to take over that ticket. He's been off work a couple of times over the past week, so that's why you haven't been getting consistent responses from him. He's back to a normal schedule now, but I'll take that ticket over and try to get some traction on what's going wrong here.

Thanks Mike.  I've replied to your email.

Thank Geoff. I responded to your email earlier, so hopefully you already received it. Let me know if anything seems confusing.

Iniciar sesión o Registrarse para publicar un comentario