Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Soporte mSecure

Synchronizing multiple devices post conversion

I like many was forced to convert from version 4 to version 6 since it was to no longer be supported in the Apple platform. I have used mSecure for years now and have recommended it to many over the years as well.  I tried to sync my 3 devices before (iPhone, MacBook Pro and iPad Pro) before converting and the sync kept failing. I tried everything in the forum to get it working to no avail. I finally decided to back up from the desktop and the iphone with recovery files and then convert on my phone to version 6. It moved everything from my iPhone into the new version but now I need to know how to get my desktop back up synced up into the new version 6 as I know there are changes and additions in that version. Support has been extremely slow to respond and basically not helpful. I am literally about to find another solution but before I do I want to see if anyone in this forum can help me. Ever since moving to a paid account the service is non-existent! I thought it worked the other way around! 

Hi Brian,

I'm not sure what is going wrong here, but it's obviously not by design. If we were to purposely cause sync problems when you moved to the newest version of mSecure or we made it impossible to sync after you paid for a license, we wouldn't have a business. There is something going wrong, but as soon as we get it figured out, syncing will work as it should.

First, I checked your account, and I can see you are using iCloud to sync your information. Everything should work, but when it doesn't, it can be a difficult feature to troubleshoot, because all of the actual syncing is handled by Apple's iCloud Drive system. mSecure simply hands off data to either iOS or macOS, the sync is entirely handled by iCloud, then when the data reaches the other device, mSecure is notified, and the data is synced in. If anything goes wrong after the data is handed off and before it's synced over to your other devices. we have no way to tell what's actually happening.

Real quick, I'm going to have you try changing over to mSecure Cloud syncing. It's very consistent, it's the most simply sync feature to use, and it doesn't rely on an outside system, so it's the best way for me to troubleshoot any possible issues. Also, if the syncing does work correctly using mSecure Cloud, then we know the issue is isolated to iCloud syncing and it makes it simpler to figure out what's going wrong.

Go ahead and open mSecure on just your Mac, click "mSecure > Preferences" in the menubar in the top left corner of your screen, then click the Sync tab. Change over to mSecure Cloud syncing. After about a minute, open mSecure on your iOS devices, tap the menu button in the top left corner (3 stacked lines), then tap Settings. Tap Sync Settings in the Settings screen. Does it show that mSecure Cloud syncing is being used? If it doesn't, don't change it, just let me know.


You are not fully grasping the issue as I explained it above. I first simply needed to sync all 3 devices (not using iCloud as i was on the legacy platform that did not work with iCloud). I needed to successfully sync all 3 devices on the legacy versions so I could upgrade to the new version. That was the first issue to solve and it never got solved so I simply upgraded to the new version and then converted what was on my iPhone to msecure and then wanted to bring in the data from the legacy desktop. This was where nobody could help or get in touch with me in a timely manner. I ran out of time to solve this issue and spent all evening moving to another password keeper after many years of being with mSecure. I am now converting other members of my family to the new platform as well. I am out! Regards - B

Hi Brian,

Sorry I wasn't able to get back to you sooner. Let me know if you need help with mSecure in the future.

Iniciar sesión o Registrarse para publicar un comentario