Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Soporte mSecure

Version 6.0.6 suddenly stopped offering fingerprint login after startup

And, of course, I don't remember the password, having used it defacto only once. And then just a fingerprint login. What now?

Hi Daniel,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. I'm not sure what could be happening here, as there are only a few things we know of that can cause Biometrics to become disabled for a 3rd party app like mSecure. First, you can disable the feature in mSecure's Settings, which isn't likely to be the cause of the problem your are reporting.


Next, OS updates have been known to disrupt Biometric functionality, and it's also possible the permission for an app to use these features gets removed somehow. Neither of these events are supposed to disable this functionality, but it does happen occasionally.


The third action we know will disable Biometric unlock is if you change the fingerprint data in Android's Settings. This, however, is an intentional security feature. Whenever the user's biometric information is altered in this manner, the authentication data in the device's secure storage is reset which causes the biometric unlock feature to be disabled for mSecure. The reason for this feature is to keep thieves from bypassing the security of your installed apps. If this feature didn't exist, then anyone could get hold of your device, add a new fingerprint in the device's settings, then they would be able to open and unlock mSecure and any other app you gave permission to unlock via biometric authentication.


The fourth thing that might cause this to happen is permissions being lost for the app to use the biometric features on the device. Unfortunately, I have not been able to confirm this happening in Android OS, but we have had a couple of customers mention something that sounded like there may be permissions for 3rd party apps on their device. If the permission for using the fingerprint scanner on your device was removed in Android OS, that would cause the feature to stop working inSecure. If this happened, then giving mSecure permission again should make it possible to use the feature to unlock the app. Again though, I'm not entirely sure this is possible for Android devices.


The first thing I need to do is confirm whether or not you see the fingerprint icon on the lock screen for mSecure. When you open the app to the screen asking for your password, do you see a blue icon near the bottom of the screen? If you do, what happens when you tap on that icon?

Hey, Mike. Thanks for the quick response. Unfortunately, that icon just disappeared. There are only two options "Show Hint" and "Unlock" (see photo). I haven't made any changes to my phone (Xiaomi Mi 9T - android 10) recently, no system installs. The last time I entered the mSecure app was about 14 days ago, when I was entering a new password for another app. Everything went correctly as always. And yesterday I needed to use one of the passwords and the biometrics login was just suddenly gone.

image

Hi Daniel,

I'm really sorry to hear about what's happened here. Due to the security build into the app, there's no way to get around the lock screen when trying to access data stored in the app. The password has to be accepted in order for the data stored in the app to be decrypted, so if mSecure can't decrypt the data it has, it simply won't unlock. Unfortunately, since we don't get access to your account password, there's just no way for me to help you get access to your data. I'm really sorry I don't have better news here.

Hi Mike.
You're not serious, are you? Can't you do some kind of update that forces the fingerprint back on the start screen? I have it in the app. I just don't have a way to use it. I don't want to have to set up all the passwords again.

Hi Daniel,

Unfortunately, I don't believe that what you are asking for is possible. If the fingerprint information needed to unlock the mSecure app, which is stored by the Android OS on the device, was still available, the feature would not have been disabled to begin with. I'll talk to our developer about this to see if it's somehow possible the security information still exists, but it's not likely. I'll get back to you after I hear from the developer.

Hey, Mike,

Thanks so much for trying to help. Once again, I remind you that I have not changed any settings. The last time, about 14 days ago, when I added a new record, the app worked correctly. I turned it on, logged in with my fingerprint, entered a new record and closed the app normally. Now, a few days ago, when I started it up again the fingerprint was gone.

 

I understand exactly what's happening here Daniel. The problem is, there are all sorts of things that can happen behind the scenes that causes issues with settings in apps. For the biometric unlock feature, the behavior when things go wrong is very difficult to weed out because mSecure is not in control of the feature. The app is simply tying into a feature fully controlled by the OS. So when you turn on barometric unlock, data is stored in a secure location on your device that's managed by the OS. When you open your device and your prompted to use the biometric unlock feature, mSecure is simply asking Android OS to authenticate the user, and if they are authenticated, then the OS will return password so the mSecure can use it to decrypt the information in the app and unlock it. In this case, it's not clear what is causing the feature to be disabled. It could be that mSecure just thinks the feature is disabled but the security information is still stored with the OS, but we have never seen that happen before. The most likely case is that the data stored with the OS has been lost somehow, like maybe during an auto-update, and now mSecure is finding out from the OS that the feature can't be used. In the end, it's very complicated to figure out the problem.


After talking to our developer, he recommended installing the latest beta of the 6.1 release that will be published soon. Are you open to install that build of the app to see if it can fix the problem?

Hey, Mike,


thank you for explaining. And yes, of course I'm happy to try the beta version. Now I have nothing to lose ;)

Either it works, or 

Hi Daniel,

Since I'll be sending you links to beta versions of mSecure, I'm moving our correspondence to email instead of the forum. I just sent you an email a few minutes ago, so go ahead and respond to it after you get a chance to read it and install the beta version for Android.

Hi, I have the same problem this evening : without any reason, the fingerprint has just disappeared and I don't remember the password. I have the latest version 6.o.6 for Android. Does the 6.1 beta version solved the problem ? If yes, may I have also the link to try the app ? Thank you on advance

@Christophe It's possible the beta version of mSecure 6.1 will fix it for you, but it's not certain. The issue 6.1 fixes is a bug that causes mSecure to require a password when it shouldn't, after about a 3 year period, I think. However, it's possible the device simply disabled fingerprint recognition for mSecure, and in that case, 6.1 will not fix the problem.


If you would like to try 6.1, please send an email to support@msevensoftware.com. After you send the email, let me know here in the forum, and I'll respond as soon as I see it.

Hi Mike, Thank you for your answer. I have sent you the mail. Nothing has been changed on my phone. My wife encounters the same problem, at the same time with mSecure without doing anything.
Hi Mike, I have found a workaround to enable again the fingerprint : in phone parameters, change the date to manual and define a date 2 weeks before, for example : the fingerprint is now enable. If msecure password has been stored in msecure, you are saved ! Change then the date mode into automatic then run mSecure with the password and, at the next session, the finger print will be enable. Thank Mike for your help (the information about the date) So, I confirm the bug and don't need the beta version. Have.a nice day

Iniciar sesión o Registrarse para publicar un comentario