Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Soporte mSecure

Safari Extension not working


I am unable to get the Password Autofil Safari Extension to work which is pretty frustrating as it work so well on iOS and iPadOS.

iMac running macOS Monterey 12.3 with Safari 15.4 and mSecure 6.02. I have enable mSecure in System Prefs - Extensions and the machine has been rebooted a couple of times since the installation of mSecure 6.x.

Any ideas?


Forgot to point out that it doesn't work for any site I have tried. URLs are correct in mSecure. Ironically, it didn't work for logging in to this mSecure support portal

Hi Steve,

Thank you for contacting us. I'm not sure why the password autofill features isn't working. I have tested it recently on my Mac, and it is working as it should. Really quick, have you checked out our support article on setting up and using this feature: Mac Password AutoFill? It has information on how the feature should work. 

It it's still not working after look through the article, the only thing I can think of that would cause the feature to not work is if your records were not using the Login template, or they don't have a URL, Username and Password type fields in them.

Were you able to look through the help article, paying special attention to when it talks about the required fields in your records?

Thanks Mike.

I had read through those links but just double checked. All OK. In case there was something odd with my Login records I created a new one using the template from mSecure6 (as opposed to entries which pre-existed upgrades to v5 or v6). Still no luck.

So, I started digging around a bit more. In Safari preferences there is, of course, an autofill tab with a checkbox for Usernames and Passwords. Yes, you guessed it, it was not ticked

Awesome news Steve! It's great to hear everything's working now. If I had a quarter for every time I missed a setting like this on computers, I would not have to work any longer =)  I will update the documentation to make sure that setting is talked about, so hopefully others will find the solution more quickly.

Iniciar sesión o Registrarse para publicar un comentario